Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [résolu] sons au ralenti avec M-audio 2496
Dernier post

[résolu] sons au ralenti avec M-audio 2496

slyholborn utilisateur non connecté
Bonjour! je me suis débarrassé de cette carte sur mon PC au profit d'une UA-25 de chez Rolland qui ne me pose plus de soucis et me comble de joie... Seulement voilà, au travail (foyer d'hébergement pour personnes en situation de handicap mental) j'anime une activité autour de la bidouille de musique Electronique : donc, Jack, temps réel etc... J'avais un petite interface behringer UC222 qui marchait très bien mais dont les possibilités étaient trop faibles (entrée midi en particulier) Bref, je ressors ma M-audio du placard et la configure avec ce qui va bien depuis F15 et mon abandon de Ubuntu au profit de Fedora...
Configuration de la carte
le tuto sur ubuntu.fr
et pour la sortie de veille... ce qui était mon principal problème, mais ça c'était avant....

Je n'ai plus besoin de mettre le PC en veille, donc pas grave pour le troisième point. Par contre, je me sers pas mal de Mixxx pour les fêtes au foyer et je me suis rendu compte que depuis mon passage à la M-Audio, les mp3 flacs oggs etc en lecture sont au ralenti, comme si elles avaient un problème de pitch à -10... Que ce soit dans Mixxx, rhythmbox? ou autre...

Bref, que faire? Des idées? Des pistes? Merci!

Salut

Si le son est au ralenti c'est un problème de fréquence d'échantillonage . Si c'est lent c'est parce que la fs est réglée sur 22000 hz alors que le fichier est encodé en 44100 ou 96000hz .
A titre comparatif regarde ce paragraphe

slyholborn utilisateur non connecté
Je ne vois rien qui concerne la fréquence... j'ai essayé de les changer dans envy24, mais ca ne change rien. J'ai aussi
default-sample-format = float32le ; s24le
default-sample-rate = 96000
dans /etc/pulse/daemon.conf ça ne devrait donc pas le faire si? Du moins, pas avec toutes les chansons!

Citation :
default-sample-rate = 96000


Image
Passe le sur int 96000

[Edit] Le "volume change rate tu devrait le laissé tel que à 48 . Je n'ai jamais vraiment compris cette fonction mais une chose est sur c'est que la modifier faut le bazar ..

slyholborn utilisateur non connecté
Je n'ai jamais touché au volum change rate, et j'avais déjà mis int96000 dans envy24... d'ailleurs, le mettre à n'importe quelle autre valeur ne change rien au son...

Le problème avec pulseaudio c'est qu'après il faut que tu regarde comment chaque logiciel transmet vers pulse audio .

Essais voir avec une valeur de 48000hz autant dans ta configue de PA que depuis ta carte son (envy24).

slyholborn utilisateur non connecté
Je crois que je vais surtout virer purement et simplement pulseaudio : cette config ne sert qu'a l'audio...

N'empêche que ça aurai du fonctionner quand même mais je suis tout à fait d'accord que pulseaudio et mao ne font pas bon ménage .

slyholborn utilisateur non connecté
C'est vrai que ça devrait quand même marcher... Je vire pulse demain quand même.

slyholborn utilisateur non connecté
Bon, je vais être obligé de garder pulse-audio... je suis sous Fedora 20 et gnome3 ne marche pas sans pulse... c'est un ordi "du boulot" et j'ai commence à apprendre à quelques collègues a faire fonctionner gnome3 alors c'est pas ôur recommencer avec xfce ou autre...
Bref, comment je fais?

Et si tu fais passer pulseaudio par jack ? Il y existe un module qui s'appelle je crois pulseaudio-module-jac .

jphaenlin utilisateur non connecté France
Salut,

Dans le lien que tu cite dans ton 1er message, il y a une modif du fichier etc/pulse/daemon.conf pour gérer la carte en 96000Hz.

; default-sample-format = s16le
; default-sample-rate = 44100
default-sample-format = float32le ; s24le
default-sample-rate = 96000


Je tenterais de remettre la conf par défaut. (s16le/44100)

-- jp

olinuxx utilisateur non connecté France
Salut slyholborn,
as-tu essayé l'astuce de jphaenlin ?

slyholborn utilisateur non connecté
Non, pas eu le temps et j'ai été obligé de formater pour modifier la taille des partitions... ça marche out of the box, mais pas pour tous les morceaux. Je peux changer les valeurs dans mix, mais il se met alors à "chevroter" : connu ou pas comme bug? Ou en lien avec le temps réel? C'est le PC qui me sert pour les animations au boulot et je suis en vacances. Je remets le nez dedans la semaine prochaine.

olinuxx utilisateur non connecté France
Ça marche. Tiens nous au jus après tes vacances.

slyholborn utilisateur non connecté
Bon, ça doit être un soucis avec pulse audio : mixxx fonctionne nikel sous jack... (beaucoup de xruns par contre, mais aucun plantage) Par contre ma toute petite table mp3e2 ne disposant pas de pré-écoute, je voulais faire tourner une carte en sortie en + avec alsa_out Pas de soucis chez moi, mais au taf... commande inconnue. Quelqu'un sait pourquoi ou je dois ouvrir un autre sujet?

au fait, plus de soucis de "lenteur" mais est-ce du à une maj ou a l'astuce de jphaenlin? (merci au passage) ayant tout fait un peu en même temps... je ne saurais le dire! Ciao tutti!

olinuxx utilisateur non connecté France
Quelle distribution as-tu au boulot ?
Sur Debian et consœurs, alsa_out et alsa_in viennent avec les paquets jackd1 ou jackd2.

slyholborn utilisateur non connecté
Je tourne sous fedora 21 et au taf et à la maison... Il y a sans doute mieux genre distro dédiée mais bon je ne veux pas (plus) d'Ubuntu et j'aime ma fedora, point.
Après moultes analyses, le problème de Mixxx au ralenti ne se produit que sous pulse audio, au taf, pas chez moi... je pense à un bug en lien avec la m-audio 2496 sous pulse qui a aussi des soucis de sortie de veille. Comme ça marche sous Jack, on va dire que c'est résolu!

Pour le alsa_out, sous fedora il est fourni avec le paquet jack-audio-connection-kit-example-clients ce n'était pas évident et pas mal de personnes sur le net semblent se poser la question, ca vaudrait peut etre le coup de le rajouter dans la page dédiée à jack I/O...

Merci en tous cas! Et à très vite, j'ai une question sur luppp...

olinuxx utilisateur non connecté France
Nickel pour le RÉSOLU dans le titre. Sens-toi libre d'éditer les pages du wiki.
Je ferme, a+
Olivier

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 12:30, ven. 24 Sep 2021: Bonjour à et bienvenue à kitty32, beldic2, et à Carlos54 cool
olinuxx, 21:29, mer. 22 Sep 2021: Bonjour et bienvenue à tezere cool
funroad34, 15:50, lun. 20 Sep 2021: c est surtout lors de la connection que ça rame sinon c 'est correct niveau timming a l'ouverture des pages..
funroad34, 15:43, lun. 20 Sep 2021: slt Oui patience et perseverence...
Houston4444, 11:17, lun. 20 Sep 2021: Ici on apprend la patience, bientôt la cafetière aura terminé sa mission avant que la page soit chargée...
sub26nico, 17:50, dim. 19 Sep 2021: pas de souci ici
funroad34, 14:14, dim. 19 Sep 2021: Bonjour idem chez moi
Geis007, 18:03, sam. 18 Sep 2021: binjch, c'est très lent, en effet !
binjch, 22:51, ven. 17 Sep 2021: Salut c'est hyper lent chez tout le monde là? Ou c'est moi qui ai un problème?
olinuxx, 18:46, jeu. 16 Sep 2021: Bonjour et bienvenue à pierre2 cool
zicstef, 22:40, mer. 15 Sep 2021: Hello, il y a bien longtemps que je n'ai pas eu la joie de passer. Découvert au détour d'un surf: /
olinuxx, 18:30, lun. 13 Sep 2021: [INFO] nouveau compte Diaspora pour linuxmao : [Lien] Venez nous y rejoindre cool