Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

Dernier post
Page : 1/2   -   Aller directement à la page : 1  2 

[RESOLU] Alternative à pulseaudio

nscott32 utilisateur non connecté
Bonjour,

je n'ai jamais réussi à configurer dmix avec ma carte RME multiface II, du coup j'en suis à utiliser pulseaudio, cela dit je m'en passerait bien.
Après avoir lu l'article Alternative à PulseAudio je me demande comment cela fonctionne, est-ce que pour avoir du son multi-source en utilisant cette config il faut nécessairement dmix ou cela est géré dans la config ?

Merci

Je n'ai jamais eu à utiliser dmix mais par contre aloop peut être lancé en jusqu'à 16 canaux entrées/sorties mais je n'ai jamais eut à configurer du multivoie à vrai dire ma configuration d'écoute n'est pas faite pour ça.

Si t'y arrive n'hésite pas poser tes griffes sur le tuto ;)

nscott32 utilisateur non connecté
N'ayant jamais réussi à configurer Alsa par moi même je voudrais bien de l'aide pour créer une configuration, si ce n'est pas trop demander...

Je n'ai pas de PC dédié MAO, j'utilise le même labtop pour travailler (programmer) et pour la mao, donc j'aimerais pouvoir utiliser plusieurs sources dans Alsa, genre de la musique sur mpd, youtube/soundclound dans un browser, etc...
Tout ça redirigé dans jack avec aloop.
Je déja activé le module noyau snd-aloop pour pouvoir bridger Pulseaudio vers Jack, maintenant j'aimerais créer la config Alsa qui me permettrait de désinstaller Jack.

Je suis tomber là dessus , la personne a une RME multiface II en plus, comme moi, mais dans ça configuration il me semble qu'il dit ne pas vouloir utiliser plusieurs sources à la fois.
Qu'elle est la bonne config pour moi ?

Merci.

Je ne sui pas certain que tu avait besoin d'aloop pour brdger pa vers vers jack. Tu aurai justement tout intérêt à garder jack et de faire passer youtube par aloop justement et garder jack opérationnel pour la mao.
D'ailleurs à vrai dire tu pourrais tout aussi bien le faire pulseaudio et son module pulseaudio-module-jack et pavucontrol.
(La page MAO sans Pulseaudio et Pulseaudio sans MAO est bien rédigée.)
Dans le cas de aloop qui ne servirai que pour router youtube soundclound ect.. vers jack.
Regarde il suffit par exemple que tu teste la chose youtube sera lu directement sur loopback injecté dans jack et tout ce qui est multimédia tu peux le diriger directement vers jack depuis les propriétés audio.

Tu peux par la suite automatiser jack pour que tout ça fonctionne au démarrage de ta machine.
Je le fait via cadence mais tu peux aussi le faire avec qjackctl

nscott32 utilisateur non connecté
utilisateur_anonyme écrit :
Je ne sui pas certain que tu avait besoin d'aloop pour brdger pa vers vers jack. Tu aurai justement tout intérêt à garder jack et de faire passer youtube par aloop justement et garder jack opérationnel pour la mao.

C'est exactement ce que j'aimerais faire.

Quelqu'un pourrait-il m'aider à créer ma configuration en se basant sur l'explication la configuration sur ce site ?

nscott32 utilisateur non connecté
Ok apparament la configuration peut être faite directement dans cadence en choisissant Bridge Type: Alsa -> Loop -> Jack.
Par contre je n'arrive pas à lancer le bridge, il ne se passe rien quand je fais start.

Il y a deux façons avec cadence

L'une est celle qui consiste à lancer le bridge mais pour ça il te faut pulseaudio-module-jack ET pulseaudio doit être démarré au préalable.

Sinon l'autre c'est de lancer pulse audio depuis la fonction pulseaudio (de puis cadence) mais dans cas le bridge ne fonctionne pas (du moins depuis l'interface de cadence) mais dans les deux cas c'est exactement la même chose se sont juste deux méthodes qui diffèrent.

nscott32 utilisateur non connecté
Tu as du lire mon post de travers ! lol
Je ne souhaite PAS utiliser pulseaudio, ma question est en gros comment se passer de pulseaudio avec Alsa + Jack.
Je viens d'essayer la solution du script python pour le loopback mais en sortie j'obtiens :

alsa_in: no process found
alsa_out: no process found
pulseaudio: no process found
ALSA lib pcm_direct.c:1562:(_snd_pcm_direct_get_slave_ipc_offset) Invalid value for card
ALSA lib pcm_hw.c:1700:(_snd_pcm_hw_open) Invalid value for card


Mais je ne suis pas sur que cela soit nécessaire de passer par cette manip puisque cadence propose lui même un bridge ALSA -> Loop -> JACK. Cela dit je n'arrive pas à le lancer.

Effectivement j'étais aux fraises désolé

Essais voir ce qu'il se passe avec ça: (su ou sudo avant c'est selon ...)

modprobe snd_aloop


nscott32 utilisateur non connecté
Les fraises du maroc ! Elles sont pas mauvaises d'ailleurs...

Le résultat de la commande :
libkmod: kmod_config_parse: /etc/modprobe.d/loopback.conf line 1: ignoring bad line starting with 'snd-aloop'


J'ai créé ce fichier qui contient simplement la ligne "snd-aloop", c'était dans l'optique de charger le module au démarrage.

essais plutôt de le mettre directement dans ton alsa-base.conf


options snd-loopback  index=0


place le en 0 et si t'as d'autre carte son tu les place en 1, 2 etc ...

Mais il me semble qu'on peut faire plus proprement que ça .

Cela dit attention à l'arrosage à partir d'eau usées drainant ...

nscott32 utilisateur non connecté
Ok merci, maintenant
modprobe snd_aloop
fonctionne, et ensuite ?

Il te faut créer un fichier /etc/modules

dans lequel tu mets:

snd-aloop

et tu peux aussi (si besoin) ajouter d'autre choses comme
snd-seq-midi


Tu sauve et tu redémarre ta machine aloop "devrait" être là

Citation :
fonctionne, et ensuite ?


Bin cadence et hop

Ci dessus c'est juste pour que ce soit actif au démarrage ...

nscott32 utilisateur non connecté
J'ai un dossier /etc/modules-load, est-ce que c'est pas mieux de le mettre dedans ?

nscott32 utilisateur non connecté
Ok, j'ai vérifié sur le net et c'est bien ici que je dois le placer, c'est comme ça pour les utilisateurs de systemd. Désolé pour cette question inutile.

Ok, maintenant c'est bon, quand je fais aplay je vois bien les deux device loopback avec tout les subdevices.
Du coup j'ai désinstallé pulseaudio, rebooté, cadence -> Jack puis j'ai pu starter le loopback qui se lance, par contre je n'ai pas de son.

Comment ça pas de son ? Alors attend y'a un ordre il faut que tu t'assure que cadence (ou plutôt jack via cadence) sorte au bon endroit.

  1. Stoppe le aloop
  2. Le ~.asoundrc doit pointer sur ta carte son donc il ne doit pas contenir la version qui est sur Alternative à PulseAudio
    1. En clair tu le supprime directe et tu reprend la configuration de cadence (dans l'ordre c'est important!
  3. teste ta configuration avec jack mais PAS avec youtube tu prend un lecteur quelconque mplayer ou ce que tu veux que tu dirige sur jack depuis ses préférences audio. Ne zappe pas l'étape.
    Si ça marche la suite le devrait aussi par contre si ça ne marche pas c'est qu'il y a un 'blème genre réglages de niveau(x) carte son et au pire tu mettre jack_meter sur le parcours pour voir si le son sort ou pas. Si ça bouge c'est un problème de gestionnaire de volume (son) au pire alsa-mixer t'aidera.
  4. Ensuite seulement quand cadence est démarré sur ta carte son et que tu as pu tester le son dans jack
    alors là tu lance aloop
  5. une fois aloop lancé j'imagine que youtube devrait pouvoir causer dans jack et si ce n'est pas le cas .. on verra à ce moment là inutile d'en mettre trop pour le moment.

nscott32 utilisateur non connecté
Ca y est ça marche !

Le problème venait simplement du fait que l'output n'était pas séléctionnée ! redface
Maintenant ça marche nickel !
Merci beaucoup !

Il y a tellement d'info sur le net qu'il est difficile de faire le tri...

Je résume ma config :
  • supprimer pulseaudio et toute configuration alsa (~/.asoundrc, /etc/asound.conf)
  • créer un (ou ajouter dans le) fichier /etc/modprobe.d/alsa-base.conf avec la ligne options snd-loopback index=0
  • créer un (ou ajouter dans le) fichier /etc/modules.load.d/alsa.conf avec la ligne snd-aloop
(Ces deux opérations permettent le chargement de la carte virtuelle aloop par le noyau au démarrage.)
  • installer Cadence comme interface Jack
  • configurer l'output dans la partie configuration de Cadence
  • lancer Jack dans Cadence
  • Activer le bridge ALSA -> Loop -> JACK dans cadence

et le tour est joué !
Aucune configuration de alsa via asoundrc, alsa.conf, etc... Donc faisable par n'importe qui (qui suit ces étapes).
Je précise que les dossier /etc/modprobe.d et /etc/modules-load.d son propre à mon systême (Arch ou tout autre systême utilisant systemd) et qu'ils changent selon les distributions.

Une dernière question, sur mon systême Arch l'option de démarrage automatique de Jack ne fonctionne pas, et j'aimerais aussi pouvoir activer le bridge par défaut, connais-tu une solution ?

Tu utilise bien cadence ?

Si c'est bien cadence que que tu utilise voici ce que je fait

Déjà je me créer un fichier qui va lancer cadence minimisé dans la zone de notification

nano /etc/xdg/autostart/cadence-minimized.desktop

Je lui colle ce contenu:
[Desktop Entry]
Version=1.0
Name=Cadence minized
Name[fr]=Cadence minimised
Comment=Start icon cadence in notification zone
Comment[fr]=Activer l'icon de notication de Cadence 
Exec=cadence-minimized
Terminal=false
Type=Application
Categories=
Icon=cadence
Terminal=false
GenericName=
NoDisplay=true


Après il te faut un studio ladish qui va nommer défaut. ça c'est archi simple depuis cadence tu lance claudia

Qui va t'ouvrir un gestionnaire de session ladish ok ?
Le stidio en route doit avoir un nom chelou avec des numero qui correspondent à un Id de de session. T'es toujours là?
On poursuis ce studio sur le sauve sous "Default" ou autre chose on s'en, fout du moment que tu sais comment il est nommé.

Ensuite plutôt que de te t'em#### enfin tu vois quoi :

TU va éditer un fichier de conf dans ton home:

nano ~/.config/Cadence/GlobalSettings.conf


Dedans tu lui donne ton studio et en même temps tu active l'autoload et l'autostart dans la foulée

[JACK]
AutoStart=true
AutoLoadLadishStudio=true
LadishStudioName=Default

[ALSA-Audio]
BridgeIndexType=1
BridgeChannels=2
BridgeTool=alsa_in

[A2J]
AutoStart=true
ExportHW=true

[Pulse2JACK]
AutoStart=false
PlaybackModeOnly=false


Et là si cadence est bien configuré (actif) et que ta carte son reste bien figée dans l'ordre de chargement des modules sinon voir: Fixer l ordre des cartes-son mais logiquement si tout est bien suivit et que je n'ai pas dit quelques chose qui sonne faux n'est ce pas dans ce cas, ça devrait fonctionner. Sinon c'est que j'ai zappé un truc mais t'inquiète pas on cherchera et on trouvera.

De manière générale quand on cherche bien on trouve toujours ! twisted

Citation :
Aucune configuration de alsa via asoundrc, alsa.conf, etc..


Faut dire aussi que cadence est super bien ficelé regarde ton ~.asoundrc et fait le test à l'occasion, il le réécrit à la volée en fonction de ses besoins :-)

EDIT: J'ai oublié un détail

Dès que tout fonctionne avec aloop en marche TU SAUVE TON STUDIO LADISH

EDIT (2) : aussi quand tu active le bridge ou que tu le stoppe puis que tu ferme ta session cadence enregistre l'état de sa session dans le fichiers de config que je t'ai montré plus haut. ~/.config/Cadence/GlobalSettings.conf
Si le bridge était à l'arrêt avant de fermer alors il le sera à l'ouverture et l'inverse pareil.

Les seuls moments ou ça peut foiré, c'est quand l'ordre des cartes devient mouvant. Je tenais à apporter cette petite précision avant de bouger.

J'espère pour toi que ça va marcher.

nscott32 utilisateur non connecté
Etrange, Claudia ne se lance pas... Catia oui mais pas Claudia.

Page : 1/2  [Suivant]
1  2 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 20:37, mer. 04 Aug 2021: Bonjour et bienvenue à PianoOrgan3478 cool
sub26nico, 16:00, mer. 04 Aug 2021: Bonjour et bienvenue à EricV86, smith8395john, alinabeth et leowilson :-)
sub26nico, 13:05, lun. 02 Aug 2021: @CyrilRos, ton lien ci-bas ne fonctionne pas
CyrilRos, 22:59, dim. 01 Aug 2021: Tux|N|Mix 21.1 disponible [Lien]
sub26nico, 14:33, dim. 01 Aug 2021: Salut et bienvenue à Youplala, Cant' et Bluetak :-)
CyrilRos, 21:45, mar. 27 Jul 2021: [Lien]
olinuxx, 20:54, mar. 27 Jul 2021: Bonjour et bienvenue à nick cool
olinuxx, 20:47, dim. 25 Jul 2021: Bonjour et bienvenue à GrosRems et à paulisaak cool
olinuxx, 20:05, jeu. 22 Jul 2021: Bonjour et bienvenue à labeyte07 cool
olinuxx, 21:03, mar. 20 Jul 2021: Bonjour et bienvenue à tv cool
Nolwen, 19:33, lun. 19 Jul 2021: Hola,À propos de la création de pattern (motifs) MIDI pour batterie, quelqu'un sait-il où en est la discussion ?
olinuxx, 01:28, lun. 19 Jul 2021: Lolo-Rosso : l'adresse courriel que tu as renseignée lors de ton inscription n'est pas fonctionnelle. Contacte moi pour corriger le soucis : [Lien]