Forum : 2 - Les distributions et les noyaux

[RESOLU] LIBRAZIK - Soucis avec Kernel Real Time??

stamkorg utilisateur non connecté
Bonjour,

J'ai installé pour essai Librazik.

La carte son est reconnue (Focusrite Scarlett 6i6), Jack fonctionne, j'ai du son.
Après l'installation du noyau RT, ça marche... mais après un redémarrage, je n'ai plus de son. Hors, la carte son est toujours reconnue et Jack semble toujours fonctionner correctement. De plus la partie midi marche puisque j'ai du signal dans mon logiciel.

Pour info, il s'agit pour moi de jouer Pianoteq (version Linux native), donc une latence la plus faible possible est souhaitée, vu qu'il s'agit d'un piano virtuel.

Y a-t-il une orientation que vous pourriez me donner pour m'en sortir avec cette distribution qui semble très prometteuse?

Merci


SK

olinuxx utilisateur non connecté France
Salut stamkorg,

Un installation de noyau avec Synaptic ou apt-get (ou autre), installe un noyau, mais ne le met pas en marche. C'est pour cela, dans ton cas, que ça continue à fonctionner (puisque tu es toujours sur le même système et le même noyau) après installation, mais qu'après un redémarrage, ça ne fonctionne plus.

Il va falloir maintenant trouver pourquoi ça ne fonctionne plus pour toi.

Donne moi (avec ta Scarlett branchée) :
  • un retour de lsusb
  • un retour de cat /proc/asound/cards
  • un retour de aplay -L
  • des copies d'écran de QjackCtl :
    • -> Réglages
    • -> Connecter
      • -> onglet Audio
      • -> onglet MIDI
      • -> ongle ALSA

stamkorg utilisateur non connecté
Bonjour Olivier et merci pour ton intérêt.

Voici les informations demandées:


stamatis@stamatis:~$ lsusb
Bus 002 Device 004: ID 1235:8012 Novation EMS 
Bus 002 Device 003: ID 045e:0745 Microsoft Corp. Nano Transceiver v1.0 for Bluetooth
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
stamatis@stamatis:~$



stamatis@stamatis:~$ cat /proc/asound/cards
 0 [MID            ]: HDA-Intel - HDA Intel MID
                      HDA Intel MID at 0xf6800000 irq 28
 1 [USB            ]: USB-Audio - Scarlett 6i6 USB
                      Focusrite Scarlett 6i6 USB at usb-0000:00:1d.0-1.5, high speed
stamatis@stamatis:~$



stamatis@stamatis:~$ aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
pulse
    PulseAudio Sound Server
default:CARD=MID
    HDA Intel MID, ALC662 rev1 Analog
    Default Audio Device
sysdefault:CARD=MID
    HDA Intel MID, ALC662 rev1 Analog
    Default Audio Device
front:CARD=MID,DEV=0
    HDA Intel MID, ALC662 rev1 Analog
    Front speakers
surround21:CARD=MID,DEV=0
    HDA Intel MID, ALC662 rev1 Analog
    2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=MID,DEV=0
    HDA Intel MID, ALC662 rev1 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=MID,DEV=0
    HDA Intel MID, ALC662 rev1 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=MID,DEV=0
    HDA Intel MID, ALC662 rev1 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=MID,DEV=0
    HDA Intel MID, ALC662 rev1 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=MID,DEV=0
    HDA Intel MID, ALC662 rev1 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
hdmi:CARD=MID,DEV=0
    HDA Intel MID, HDMI 0
    HDMI Audio Output
dmix:CARD=MID,DEV=0
    HDA Intel MID, ALC662 rev1 Analog
    Direct sample mixing device
dmix:CARD=MID,DEV=3
    HDA Intel MID, HDMI 0
    Direct sample mixing device
dsnoop:CARD=MID,DEV=0
    HDA Intel MID, ALC662 rev1 Analog
    Direct sample snooping device
dsnoop:CARD=MID,DEV=3
    HDA Intel MID, HDMI 0
    Direct sample snooping device
hw:CARD=MID,DEV=0
    HDA Intel MID, ALC662 rev1 Analog
    Direct hardware device without any conversions
hw:CARD=MID,DEV=3
    HDA Intel MID, HDMI 0
    Direct hardware device without any conversions
plughw:CARD=MID,DEV=0
    HDA Intel MID, ALC662 rev1 Analog
    Hardware device with all software conversions
plughw:CARD=MID,DEV=3
    HDA Intel MID, HDMI 0
    Hardware device with all software conversions
default:CARD=USB
    Scarlett 6i6 USB, USB Audio
    Default Audio Device
sysdefault:CARD=USB
    Scarlett 6i6 USB, USB Audio
    Default Audio Device
front:CARD=USB,DEV=0
    Scarlett 6i6 USB, USB Audio
    Front speakers
surround21:CARD=USB,DEV=0
    Scarlett 6i6 USB, USB Audio
    2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=USB,DEV=0
    Scarlett 6i6 USB, USB Audio
    4.0 Surround output to Front and Rear speakers
surround41:CARD=USB,DEV=0
    Scarlett 6i6 USB, USB Audio
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=USB,DEV=0
    Scarlett 6i6 USB, USB Audio
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=USB,DEV=0
    Scarlett 6i6 USB, USB Audio
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=USB,DEV=0
    Scarlett 6i6 USB, USB Audio
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=USB,DEV=0
    Scarlett 6i6 USB, USB Audio
    IEC958 (S/PDIF) Digital Audio Output
dmix:CARD=USB,DEV=0
    Scarlett 6i6 USB, USB Audio
    Direct sample mixing device
dsnoop:CARD=USB,DEV=0
    Scarlett 6i6 USB, USB Audio
    Direct sample snooping device
hw:CARD=USB,DEV=0
    Scarlett 6i6 USB, USB Audio
    Direct hardware device without any conversions
plughw:CARD=USB,DEV=0
    Scarlett 6i6 USB, USB Audio
    Hardware device with all software conversions
stamatis@stamatis:~$


stamkorg utilisateur non connecté
Bon...

Petite précision...

Quand j'ai installé le Kernel Real Time, ne sachant pas trop, j'ai installé 2 choses:

- linux-headers-4.0.4-rt1-librazik-real-time

et

- librazik-linux-real-time


Serait-ce moi qui ai fait une erreur?

stamkorg utilisateur non connecté
Bon... le problème survient après une mise à jour.


Voici la séquence exacte de ce que j'ai fait hier soir:

- Installation neuve de Librazik, ok j'ai du son

- Update, ugrade, dist-upgrade, ok j'ai du son

- Redémarrage, ok j'ai du son

- Installation de Real Time kernel, ok j'ai du son

- Redémarrage, ok j'ai du son (multiprocesseur détecté, donc sous RT), système stable et robuste à 44100Hz et 64 samples.

- Update, upgrade, dist-upgrade et redémarrage, et là, plus de son...


Merci d'avance pour votre support

stamkorg utilisateur non connecté
OK, voilà le coupable:

La carte son s'est mise en mode "Mute" dans ALSAMIXER, pour je ne sais quelle raison.
Avouez qu'il faut quand même aller le chercher...

Il a suffi d'aller dans alsamixer via le terminal et de tapper "m" pour les pistes concernées.

A+

SK

olinuxx utilisateur non connecté France
Citation :
La carte son s'est mise en mode "Mute" dans ALSAMIXER, pour je ne sais quelle raison.


C'est un classique :-)
Une partie de la raison (du côté de chez ALSA) est qu'ils considèrent pour des raisons de sécurité qu'il faut muter les interfaces son lors de l'installation des outils alsa (alsa mixer, ...). J'imagine que tu as eu une mise à jour d'alsa-*, non ?

Bien joué pour l'auto résolution et pour le [RÉSOLU] dans le titre.

stamkorg utilisateur non connecté
Oui ça doit être ça.

Donc voilà, je suis bien sûr intéressé par une version 64bits, je pense qu'on aura encore l'occasion d'échanger sur cette distribution où je retrouve la qualité et la stabilité de Tango Studio.

olinuxx utilisateur non connecté France
Merci pour ce retour. La version 64 bits devrait arriver sous peu.