Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

> Forums de discussion > 5 - Les serveurs son : Jack, PulseAudio et autres... > Jackd + Line6 : problème de monitoring (était : "Qjackctrl voire autre application")[RESOLU]
Dernier post
Page : 1/3   -   Aller directement à la page : 1  2  3 

Jackd + Line6 : problème de monitoring (était : "Qjackctrl voire autre application")[RESOLU]

Brizfer utilisateur non connecté France
Bonjour,
Voici ma première requête depuis mon inscription (ben oui redface)

Je ne sais pas comment l'intituler redfaceexclaim.

Pour rappel : Ubuntu Studio 14.04 Lts sur DD externe 250 Go Ordi sous W7 Pro 64 bits 8 Go Cartes son usb Line6 UX2 + Sonuus i2M ici , je vous en dirai un peu plus, plus tard, sur ce petit bijou.

Au Boot de la distri :
1- Est-ce normal que j'entende mon instru (basse/guitare) connecté à la Line6 UX2 (saturé + souffle) et ce même pendant toute mon activité sur le bureau (consultation net, mise à jour,etc...) ? QjackCtrl n'est pas lancé frown

2- Le son est très saturé + souffle en jouant sur l'un des instrus sans avoir lancé une appli dédiée à l'audio sauf lorsque j'écoute un fichier wav, mp3 voire streaming !!!frown QjackCtrl toujours pas lancé

3- Par contre, si je lance pavucontrol le son est clair mais le problème reste entier. Là encore, je n'ai toujours pas lancé ardour ou autresquestion !!! QjackCtrl encore, toujours pas lancé... sic

4- Si je retire le pavucontrol, on revient au pb du départ (saturation + souffle). Toujours pas d'application(mao) d'ouverte. QjackCtrl là encore et encore non démarré

Je suis obligé de bosser de cette façon(laisser ouvert le pavucontrol sur le plan2 par exemple) : Ardour ou Audacity ou Rosegarden lancés(pas toutes en même temps, je sais que linux le permet yesrazz) pour la capture audio. QjackCtrl est lancé sad. Je peux enregistrer sans problème sans saturation, mais si je retire le pavucontrol tout en jouant c'est la cata pour mes deux oreilles...

J'ai bien retiré pulseaudio (éteint) en suivant les # tutos mais rien ne se passe evil. Pour info, j'ai fait des captures audio du net avec audacity, QjackCtrl est bien reconnu, l'enregistrement est une merveille, mais mon instrument(je l'entends toujours) est toujours saturé bien qu'il ne soit pas encore armé sur une piste pour enregistrer !!! Damned

Connaissez-vous (avez-vous vécu) ce problème ?

Je ne suis pas devant mon ordi à l'instant. J'ai préféré ne pas vous envoyer de copies d'écran ou relevés du terminal afin d'éviter de vous donner les mauvaises infos.

Je vous remercie de votre aide.

Pour information ce post a été créé avec le titre suivant : "QjackCtrl voire autre application". Avec un très bel échange avec Allany (merci pour lui)

Briz(icalement)fer vôtre.

allany utilisateur non connecté
Hello !

Si je comprends bien, ça fait comme si la carte balançait en permanence ce qu'elle capte en entrée vers la sortie, en ayant amplifié le tout (à fond) au passage ?
J'ai regardé vite fait les caractéristique de cette UX2.
Tu es bien certain de tous les réglages de gain/volume(s) ?
N'y a-t-il pas un réglage genre mix dry/wet ?
Tu la branches bien en USB ?
Peux-tu poster un :
lsusb

et un :
aplay -l

Line6 connectée ?

A+

edit : j'ai fait abstraction du Sonuus, n'ayant pas tout compris mais estimant qu'il n'intervenait pas, pour l'instant, dans tes soucis de config'. Ce serait plus du côté MIDI de la force, si je pige bien...

Brizfer utilisateur non connecté France
Bonjour Allany,

Merci pour ta célérité.

N'étant pas devant mon matériel, je pourrai te faire un retour que ce soir.

Tu as bien résumé sauf que le volume en sortie sur cette carte (potard physique) est au minimum !!!

Pour les réglages, il me semble, je n'ai pas encore toute la main sous cette distri confused désolé, contrairement à W7 voire Apple, elle est fournie avec 2 applications standalone au nom de GearBox et le PodFarm -possibilité de choisir son instru, effets, accordeur, playback, créer son rack, ect...- rien à voir c'est du standalone, mais elle n'est pas fournie avec une table de mixage, le tout se fait dans la DAW....

J'ai bien fouiné, fouillé, géré alsamixer, pavucontrol dans le terminal, tout me semble OK exclaim.

Oui pour le Dry/Wet mais où puis trouver les paramètres (ubuntu, W7 avec wine !!!)

Branchée USB oui...

Les commandes que tu cites, je les ai déjà effectuées et la carte est bien reconnue en troisième position (carte interne je l'ai éteinte (rien en entrée, rien en sortie), carte usb Sonuus et Line6 dans l'ordre d'apparition). Je t'en ferai part dès ce soir.

T'inquiète pour la i2M. Je peux aussi travailler en audio (éh oui)cool, :
- Je crée un piste audio
- une deuxième en midi (paramétrer instrument GM, un soundfont ou instru virtuel)
- je les arme
- Je lance le rec
- Je joue mes plans
Résultat : j'ai ainsi ma région audio et midi sans décalage, sans latence (c'est super pour quelqu'un qui maîtrise peu un clavier maître sauf que c'est du monophonique -peu importe-, le but était pour moi de retranscrire en midi avec le son adéquat une partie jouée (cuivres, violons, etc...) par exemple en sextolet et avoir mes messages de contrôleurs (pitch bend, breath controller, modulation, etc) avec un mon jeu, de plus, mes partitions sont bien retranscrites sous GuitarPro.

Merci encore. Je fais tout cela ce soir et reviens vers toi/vous si d'autres questions exclaim

Brizfer

olinuxx utilisateur non connecté France
Britzfer écrit :
... Sonuus i2M ici, je vous en dirai un peu plus, plus tard, sur ce petit bijou.


Ah oui alors ! J'attends ce retour avec impatience ! Nous le placerons dans la documentation.
:-)

Brizfer utilisateur non connecté France
Salut Olinuux,

J'en ai dit un peu ici :

Citation :
Je peux aussi travailler en audio (éh oui)cool, :
- Je crée un piste audio
- une deuxième en midi (paramétrer instrument GM, un soundfont ou instru virtuel)
- je les arme
- Je lance le rec
- Je joue mes plans
Résultat : j'ai ainsi ma région audio et midi sans décalage, sans latence (c'est super pour quelqu'un qui maîtrise peu un clavier maître sauf que c'est du monophonique -peu importe-, le but était pour moi de retranscrire en midi avec le son adéquat une partie jouée (cuivres, violons, etc...) par exemple en sextolet et avoir mes messages de contrôleurs (pitch bend, breath controller, modulation, etc) avec un mon jeu, de plus, mes partitions sont bien retranscrites sous GuitarPro


La suite en détail dès que j'aurai un peu de temps libre...

Merci

Briz(icalement)fer

allany utilisateur non connecté
... les deux commandes dont je t'ai demandé de poster les résultats, peux-tu les exécuter avec Sonuus branchée et débranchée, ce soir ?
Sonuus débranchée, est-ce que les manifestations sont identiques ?
A tout'

Brizfer utilisateur non connecté France
Allany,

J'y ai pensé justement. Voici les résultats avec la Sonuus débranchée :

lsusb

elvava@elvava:~$ lsusb
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 006: ID 03f0:0024 Hewlett-Packard KU-0316 Keyboard
Bus 001 Device 005: ID 0461:4d51 Primax Electronics, Ltd 0Y357C PMX-MMOCZUL (B) [Dell Laser Mouse]
Bus 001 Device 004: ID 174c:1153 ASMedia Technology Inc. ASM2115 SATA 6Gb/s bridge
Bus 001 Device 003: ID 0e41:4142 Line6, Inc. 
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


aplay -l

elvava@elvava:~$ aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: PCH [HDA Intel PCH], périphérique 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: TonePortUX2 [TonePort UX2], périphérique 0: TonePort UX2 [TonePort UX2]
  Sous-périphériques: 0/1
  Sous-périphérique #0: subdevice #0


le résultat est de même, j'entends toujours la saturation, aucune application hors le navigateur est lancée !!!

Brizfer utilisateur non connecté France
Avec Sonuus branchée

elvava@elvava:~$ lsusb
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 007: ID 03f0:0024 Hewlett-Packard KU-0316 Keyboard
Bus 001 Device 006: ID 0461:4d51 Primax Electronics, Ltd 0Y357C PMX-MMOCZUL (B) [Dell Laser Mouse]
Bus 001 Device 005: ID 174c:1153 ASMedia Technology Inc. ASM2115 SATA 6Gb/s bridge
Bus 001 Device 004: ID 0e41:4142 Line6, Inc. 
Bus 001 Device 003: ID 231c:0001  
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


elvava@elvava:~$ aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: PCH [HDA Intel PCH], périphérique 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 2: TonePortUX2 [TonePort UX2], périphérique 0: TonePort UX2 [TonePort UX2]
  Sous-périphériques: 0/1
  Sous-périphérique #0: subdevice #0


le résultat est le même saturation et aucune application de lancée...

Brizfer utilisateur non connecté France
J'ai fait ce test aussi :
elvava@elvava:~$ lsmod | grep -i usb
snd_usb_toneport       16384  0 
snd_usb_audio         176128  1 
snd_usb_line6          32768  4 snd_usb_toneport
snd_usbmidi_lib        36864  1 snd_usb_audio
snd_hwdep              16384  2 snd_usb_audio,snd_hda_codec
snd_pcm               102400  8 snd_usb_audio,snd_usb_line6,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core
snd_rawmidi            32768  3 snd_usb_line6,snd_usbmidi_lib,snd_seq_midi
snd                    81920  24 snd_hda_codec_realtek,snd_usb_audio,snd_usb_line6,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_usbmidi_lib,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_usb_toneport
usb_storage            69632  3 uas
usbhid                 49152  0 
hid                   118784  2 hid_generic,usbhid


allany utilisateur non connecté
C'est clair que ça n'est ni normal ni habituel... eek
Les deux commandes renvoient des résultats nickel, pourtant.
Tu écoutes sur quoi, connecté comment ?
A+

olinuxx utilisateur non connecté France
@allany : je n'ai pas tout lu de cette discussion, du coup, je te le dis à toi : ça ne serait pas un merdouillage apporter par le HDMI par hasard ? Peut être qu'une désactivation du HDMI (BIOS ou blacklist si pas possible) pourrait être testé. Sans garantie...

allany utilisateur non connecté
PS : j'ai regardé la démo de la Sonuus. Le p'tit solo de sax, à la gratte, est assez impressionnant, je reconnais...
Alors, dans ton 1er post, tu parlais de l'intitulé et tu as raison. Pas très parlant, le titre...
Tu pourrais peut-être corriger en :
Jackd + Line6 : problème de monitoring ?
Histoire d'avoir davantage de lecteurs...

A+

Brizfer utilisateur non connecté France
J'écoute sur le casque de la Line6 UX2.

Suis Connecté en filaire 1 Ethernet !!! Lors de mes tests (je débute sur la distri cool, soyez indulgents merci redface), je retire justement le câble afin d'éviter tout parasite...

Y a peut être une config spéciale !!!

allany utilisateur non connecté
@olinuxx : oui, c'est possible mais, pour l'instant, on élimine d'autres hypothèses car la carte HDMI ne présente rien d'inhabituel. Mais, à voir plus tard, sans doute.

Brizfer utilisateur non connecté France
@Ollinux : merci de nous rejoindre !!! Je n'ai pas de port HDMI sur cet ordi. Sous W7, j'ai une config Home studio et tout roule. Tout ce qui peut parasiter, j'ai écarté et m'en suis même très éloigné....

@Allany : Intéressé par la bête !!! Elle est vraiment bien pour un nomade comme moi, pratique, dans la poche, plug'n'play...Bon je m'arrête.

Comment changer le titre ?

Merci à vous deux...

Brizfer utilisateur non connecté France
Bon, il est dit dans la charte (Respect aux modéros biggrin)

Seuls les modérateurs du forum sont capables de supprimer ou déplacer des messages. Si vous trouvez après-coup que vous n'avez pas posté au bon endroit, laissez un message aux modéros dans le sujet du forum en question, ou devenez modérateur vous-même !


Je vais les solliciter.

allany utilisateur non connecté
Brizfer écrit :
J'écoute sur le casque de la Line6 UX2

C'est pour ça que je te posais la question, je m'en doutais.
Je pense que la boucle source-écoute est générée dans le Line-6 et jackd, ensuite, n'utilise pas les bonnes entrées/sorties.
Bref, une histoire de routage de signaux.

Peux-tu poster tes réglages de jackd ?

Avec un peu de bol, peut-être que :
alsamixer

te donneras accès à quelques réglages pour la Line6 (F6, flèches et "M", dans alsamixer) ?
Sinon, pas grave...

A+

allany utilisateur non connecté
Aaaaah oui... Pour modifier le titre de ton 1er poste, tu y vas, tu cliques sur l'icône "éditer" (feuille avec crayon), tu saisis, tu valides.
Pas besoin de modéro. Je te l'aurais dit, j'en fais partie... cool
A+

Brizfer utilisateur non connecté France
Oups, pardon @Ollinux, mes doigts ont été plus vite que ma relecture (important) : je vois qu'effectivement y a un codec "snd_hda_codec_hdmi" pour la Line6 et la carte PC. Je suis justement en train de parcourir le
[tuto] Black lister le HDMI debian/ubuntu
... dois-je le mettre en pratique ???

Brizfer utilisateur non connecté France
@allany voici mon réglage pour le moment :

Image

Brizfer utilisateur non connecté France
alsamixer-Lecture : Image

alsamixer-Capture : Image

alsamixer-Tout : Image

Page : 1/3  [Suivant]
1  2  3 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 20:37, mer. 04 Aug 2021: Bonjour et bienvenue à PianoOrgan3478 cool
sub26nico, 16:00, mer. 04 Aug 2021: Bonjour et bienvenue à EricV86, smith8395john, alinabeth et leowilson :-)
sub26nico, 13:05, lun. 02 Aug 2021: @CyrilRos, ton lien ci-bas ne fonctionne pas
CyrilRos, 22:59, dim. 01 Aug 2021: Tux|N|Mix 21.1 disponible [Lien]
sub26nico, 14:33, dim. 01 Aug 2021: Salut et bienvenue à Youplala, Cant' et Bluetak :-)
CyrilRos, 21:45, mar. 27 Jul 2021: [Lien]
olinuxx, 20:54, mar. 27 Jul 2021: Bonjour et bienvenue à nick cool
olinuxx, 20:47, dim. 25 Jul 2021: Bonjour et bienvenue à GrosRems et à paulisaak cool
olinuxx, 20:05, jeu. 22 Jul 2021: Bonjour et bienvenue à labeyte07 cool
olinuxx, 21:03, mar. 20 Jul 2021: Bonjour et bienvenue à tv cool
Nolwen, 19:33, lun. 19 Jul 2021: Hola,À propos de la création de pattern (motifs) MIDI pour batterie, quelqu'un sait-il où en est la discussion ?
olinuxx, 01:28, lun. 19 Jul 2021: Lolo-Rosso : l'adresse courriel que tu as renseignée lors de ton inscription n'est pas fonctionnelle. Contacte moi pour corriger le soucis : [Lien]