Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

> Forums de discussion > 5 - Les serveurs son : Jack, PulseAudio et autres... > Problème d'installation Scarlett 18i8 avec Jack
Dernier post
Page : 1/3   -   Aller directement à la page : 1  2  3 

Problème d'installation Scarlett 18i8 avec Jack

RomuGuitariste utilisateur non connecté France
bonjour,

après ma présentation voici mon premier post de nouvel utilisateur désespéré !!

J'ai acheté il y a 1 an une carte son Focusrite Scarlett 18i8 pour renouvellé une M-Audio vieillissante, en prenant soin de vérifier qu'il y avait déjà des utilisateurs de ce matos sous linux, car même si à l'époque j'étais encore sous mac, j'avais déjà décidé de switcher rapidement !

J'ai depuis trouvé le temps d'acheté un PC dédié à Linux ( pour une autre utilisation: Fablab) et j'ai installé Ubuntu Studio 16.04 afin d'en profité pour validé l'aspect MAO et ma carte son avant de changé mon pc de home studio.

Ce jour j'ai branché la dite carte voici mon prob : (attention je débute sous linux)

J'ai pluggé la bestiole avant de démarrer le PC.

Regardé avec alsa mixer si elle était bien reconnue ..... c'est ok

J'ai ensuite démarré QjackCtl pour lancer le serveur jack et là le drame il me répond :


DBUS : impossible de démarrer le serveur JACK.

Désolé


puis

Impossible de connecter le serveur JACK comme client.
- L'opération a échoué.
- Incapable de se connecter au serveur.
Veuillez consulter la fenêtre des messages pour plus d'informations.


après quelques recherches sur internet qui m'ont mené ici entre autre, je seche un peu.

lorsque je fais la commande :

$ aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: HDMI [HDA ATI HDMI], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: Generic [HD-Audio Generic], périphérique 0: CX20751/2 Analog [CX20751/2 Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 2: USB [Scarlett 18i8 USB], périphérique 0: USB Audio [USB Audio]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0


et la commande :

$lsmod |grep snd
snd_seq_dummy          16384  0
snd_hda_codec_conexant    24576  1
snd_hda_codec_generic    77824  1 snd_hda_codec_conexant
snd_usb_audio         176128  1
snd_hda_codec_hdmi     53248  1
snd_hda_intel          40960  5
snd_usbmidi_lib        36864  1 snd_usb_audio
snd_hda_codec         135168  4 snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_codec_generic,snd_hda_intel
snd_hda_core           69632  5 snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_hwdep              16384  2 snd_usb_audio,snd_hda_codec
snd_rawmidi            32768  2 snd_usbmidi_lib,snd_seq_midi
snd_seq                69632  6 snd_seq_midi_event,snd_seq_dummy,snd_seq_midi
snd_pcm               106496  5 snd_usb_audio,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              32768  2 snd_pcm,snd_seq
snd                    81920  26 snd_usb_audio,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_usbmidi_lib,snd_hda_codec,snd_hda_intel,snd_seq_device
soundcore              16384  1 snd


à ce que j'ai compris tant que je n'aurai pas réussi à démarrer JACK il me sera impossible d'utilisé ma carte dans Ardour ou un autre logiciel !

Je suis bien administrateur du groupe audio ( j'ai vu que c'était fréquemment demandé sur les forums)

Avez vous des pistes à me donner ? besoin du résultat d'autres commandes ? pour pouvoir m'aiguiller vers la lumière !!

Merci d'avance pour votre aide

olinuxx utilisateur non connecté France
Tu peux nous filer le log complet de qjackctl ?

RomuGuitariste utilisateur non connecté France
21:32:45.486 Réinitialisation des statistiques.
21:32:45.661 Changement des connexions ALSA.
21:32:46.202 DBUS : le service est disponible (org.jackaudio.service soit jackdbus).
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock
21:32:46.791 Changement du graphique des connexions ALSA.
21:32:59.501 DBUS : impossible de démarrer le serveur JACK. Désolé
Sat Jan 14 21:32:59 2017: Starting jack server...
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock
Sat Jan 14 21:32:59 2017: JACK server starting in realtime mode with priority 10
Sat Jan 14 21:32:59 2017: self-connect-mode is "Don't restrict self connect requests"
Sat Jan 14 21:32:59 2017: Acquired audio card Audio1
Sat Jan 14 21:32:59 2017: creating alsa driver ... hw:USB|hw:USB|256|2|48000|0|0|nomon|swmeter|-|32bit
Sat Jan 14 21:32:59 2017: configuring for 48000Hz, period = 256 frames (5.3 ms), buffer = 2 periods
Sat Jan 14 21:32:59 2017: ALSA: final selected sample format for capture: 32bit integer little-endian
Sat Jan 14 21:32:59 2017: ALSA: use 2 periods for capture
Sat Jan 14 21:32:59 2017: ALSA: final selected sample format for playback: 32bit integer little-endian
Sat Jan 14 21:32:59 2017: ALSA: use 2 periods for playback
Sat Jan 14 21:32:59 2017: ERROR: ALSA: cannot set hardware parameters for playback
Sat Jan 14 21:32:59 2017: ERROR: ALSA: cannot configure playback channel
Sat Jan 14 21:32:59 2017: ERROR: Cannot initialize driver
Sat Jan 14 21:32:59 2017: ERROR: JackServer::Open failed with -1
Sat Jan 14 21:32:59 2017: ERROR: Failed to open server
Sat Jan 14 21:33:00 2017: Saving settings to "/home/romu/.config/jack/conf.xml" ...
21:33:22.821 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Incapable de se connecter au serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock


après avoir lu plusieurs topic sur la scarlett 18i8 j'ai vu qu'il pouvait y avoir des problème avec le device HDMI sur certain portable, je l'ai donc "éteint" dans pavucontrol (dernier onglet config) j'ai redémarré mais c'est pareil, et je le vois toujours quand je fais aplay-l est ce normal ?

olinuxx utilisateur non connecté France
Essaies de commencer en lui demandant 1024 échantillons/période plutôt que 256.

sub26nico utilisateur non connecté France
tu peux poster des captures d'écrans des réglages de Qjackclt,
ça nous permettrait de voir s'il n'y a pas de soucis de ce coté là.

RomuGuitariste utilisateur non connecté France
Ce matin j'ai remarqué qu'en fait indépendamment de ma Scarlett Jack ne se lance absolument jamais ! J'ai essayé de le lancé en démarrant l'ordi sans la carte externe, en utilisant uniquement le hardware interne et ça semble faire la même chose !

Je vous prépare les captures d'écran.

EDIT1 :

j'ai essayé ce matin en passant par la ligne de commande :

jackd -sRp 70 -d alsa -d hw:1 -r 44100 -H -z s &


et le serveur JACK s'est lancé avec la carte interne du laptop. J'ai ensuite démarré Qjack et depuis j'arrive à faire démarrer sans erreur et même si je sélectionne ma Scarlett 18i8.

Par contre je n'ai toujours pas de son en sortie.

Et j'ai remarqué sous pavucontrol que dans l'onglet configuration ma carte n'apparait qu'en Entrée ( dans le menu déroulant j'ai MultiEntree et Eteint comme choix c'est tout)

Image

sub26nico utilisateur non connecté France
- As tu un noyau basse latence ou temps réel?

- Dans le menu déroulant de configuration, tu n'as pas l'option
'duplex stereo analogique' ?

RomuGuitariste utilisateur non connecté France
je suis sur Ubuntu Studio donc low latency

$ uname -a
Linux romu-X555YI 4.4.0-59-lowlatency #80-Ubuntu SMP PREEMPT Fri Jan 6 21:04:05 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux



Je viens de faire tout ce qui est écrit ici :

https://doc.ubuntu-fr.org/jackd

configuration de pulseaudio via jack et rien n'y fait pas de son, après 48h dedans j'ai qu'une envie de bruler le PC lol !! c'est franchement lourding...

sub26nico utilisateur non connecté France
Ca m'est arrivé sur Ubuntu, récemment, et par un moyen que j'ignore,
l'option 'duplex stereo analogique' m'a permis de sortir de ce mauvais pas.

RomuGuitariste utilisateur non connecté France
c'est à dire ?

je n'ai pas cette option pour la Scarlett !!

AUtre chose, j'ai vu partout des lignes de commande pour vérifier si le realtime est lancé ou pas, mais à chaque fois il est écrit que pour Ubuntu studio c'est forcément ok, c'est sur ?

car j'ai l'impression que c'est pas bon de mon coté

lsmod | grep realtime


ne retourne rien :-( :-(

olinuxx utilisateur non connecté France
lsmod, c'est pour regarder les modules du noyau chargés. Le temps-réel n'est pas un module noyau, donc c'est normal que ça ne te retourne rien.

RomuGuitariste utilisateur non connecté France
ok merci pour cette précision.

Je cherche de quel coté maintenant ?

sub26nico utilisateur non connecté France
Peut être du coté de Qjackctl, peux tu poster des captures d'écrans
des différentes fenêtres de configurations stp?

olinuxx utilisateur non connecté France
Y'a un peu de documentation ici : Focusrite Scarlett 18i8. Fais-en le tour, y compris les liens en bas de la page, y'a peut être des spécificités liées à cette interface.

Dis nous.

Long Sam Silver utilisateur non connecté
Salut RomuGuitariste

Ne brûle rien surtout :-)
On va partir du début. Tu es sous UbuntuStudio, que j'utilise aussi. Donc tu as bien un noyau lowlatency qui va permettre à Jack de fonctionner.

1) Personnellement, j'aurai tendance à te dire de te passer de pulseaudio qui ne fait que rajouter une couche (inutile pour le moment) entre Alsa et Jack. Je te suggère fortement de désactiver pulseaudio pour commencer.
D'abord on va créer un petit fichier qui va empêcher pulseaudio de redémarrer automatiquement dans ta session.
Pour cela dans un terminal tapes :
$ echo "autospawn = no" > ~/.pulse/client.conf

Maintenant on peut arrêter pulseaudio :

$ pulseaudio -k

2) [edit] D'après ce que j'ai lu dans ton premier post, ta carte est bien reconnue par alsa. Quand tu lances alsamixer ça donne bien quelque chose comme ça ?

dl4175?display

3) Comment fais-tu pour tester les sorties son de ta carte. Quels branchements as-tu fait dans jack ?

RomuGuitariste utilisateur non connecté France
Salut Long Sam Silver

1 / J'ai fait la manip mais il me dit que l'accès à client.conf n'est pas autorisé, meme si je fais un sudo ?? j'ai été obligé de changer un peu ta ligne de commande par ceci :

$ echo "autospawn = no" > /etc/pulse/client.conf


car sinon il me disait que le fichier était introuvable ! j'ai peut etre mal fait ?

2/ oui j'ai l'affichage que tu me donne en exemple, une fois que j'ai fait F6 et que j'ai sélectionné ma carte

3/ je crois que c'est mon plus gros souci, je comprends rien à ce qu'il faut faire dans Jack et je trouve pas de tuto pas à pas pour expliqué le coup des branchement.

Déjà quand tu utilise QjackCtl à ce que j'ai compris il faut déjà "Démarer le serveur JACK" et ensuite faire PLAY ???? je comprends pas la nuance entre les deux ? tu peux m'expliquer ?

d'autre part je m'attendais à avoir des entrées et des sorties qui apparaissent dans la baie de cablage mais il n'y a rien !! c'est à moi de les renseigne ?

olinuxx utilisateur non connecté France
RomuGuitariste écrit :
je crois que c'est mon plus gros souci, je comprends rien à ce qu'il faut faire dans Jack et je trouve pas de tuto pas à pas pour expliqué le coup des branchement.


Je te conseille de commencer par la lecture des quelques pages Débuter. Ensuite, tu pourras aller lire la page QJackctl - connecter des applications.

Long Sam Silver utilisateur non connecté
re salut

Pour Pulseaudio, ce que tu as fait est très bien aussi. Pas de souci. Personnellement, je n'utilise pas du tout pulseaudio. Pour de la MAO au sens strict, ça ne sert à rien et c'est souvent susceptible de poser des problème avec Jack.

Donc tu lances QJackCtl et tu cliques sur le bouton "Start". Et Jack démarre.

Maintenant il faut que tu gères les connections dans Jack. C'est à dire comment tu connectes tes entrées son dans des logiciels, comment tu connectes tes logiciels avec tes sorties son. En effet, Jack est un serveur de son en temps réel très puissant, mais cette puissance t'impose de définir exactement comment il va gérer le son entre ta carte et tes diverses application (filtres, ampli virtuel type guitarix, sampler, instrument virtuel, séquenceur)

Pour cela, sous ubuntustudio, tu peux utiliser Patchage qui simplifie beaucoup les connections par rapport à l'interface de QJackCtl qui est assez peu intuitif pour cela.

Donc après avoir démarré Jack avec QjackCtl, tu lances Patchage.
Pour tester maintenant lance par exemple un synthé comme ZynAddSubFX ou Yoshimi, demande lui d'afficher son clavier virtuel.
Dans Patchage, connecte les sorties son de ZynAddSubfx au sorties son de ta carte et normalement ça fait du bruit :-)
Plus d'info sur Patchage ici (en anglais)
http://www.penguinproducer.com/Blog/2011/10/making-jack-connections-with-patchage/

RomuGuitariste utilisateur non connecté France
bon j'avance, j'ai fait un peu mumuse avec Yoshimi et Patchage et j'ai bien compris la philosophie de l'ensemble. Les choses deviennent plus claire.


Donc concretement le souci c'est que JACK ne se lance jamais sur mon hw:2 (ma carte Scarlett) même quand je la selectionne dans QJackCtl c'est en réalité celle par défaut qui est utilisé. J'ai vu que c'est déjà arrivée à quelques personnes qui ont été obligé de desactivé le hardware du hdmi.

Mais je n'ai pas compris comment ils ont fait.

Actuellement sous patchage je vois juste l'entrée midi ALSA de ma carte Scarlett c'est tout.

Coté jackd il n'y a qu'en ligne de commande ou j'arrive à voir l'erreur de ma carte, car là il me prend bien mon hw2 comme argument et du coup me retourne une erreur.


no message buffer overruns
no message buffer overruns
no message buffer overruns
Failed to open server



Edit:

Voici les copies d'écran de QJACKCtl

Image

Image

Image

Image

sub26nico utilisateur non connecté France
As tu bien renseigné ton nombre d'entrées/sorties dans l'onglet 'Avancé' de Qjackctl?

RomuGuitariste utilisateur non connecté France
sub26nico : j'étais entrain d'éditer mon message précédent et je t'ai mis les copie d'écrans que tu voulais.

Page : 1/3  [Suivant]
1  2  3 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 20:05, jeu. 22 Jul 2021: Bonjour et bienvenue à labeyte07 cool
olinuxx, 21:03, mar. 20 Jul 2021: Bonjour et bienvenue à tv cool
Nolwen, 19:33, lun. 19 Jul 2021: Hola,À propos de la création de pattern (motifs) MIDI pour batterie, quelqu'un sait-il où en est la discussion ?
olinuxx, 01:28, lun. 19 Jul 2021: Lolo-Rosso : l'adresse courriel que tu as renseignée lors de ton inscription n'est pas fonctionnelle. Contacte moi pour corriger le soucis : [Lien]
calixtus06, 18:07, ven. 16 Jul 2021: Bonjour et bienvenue à titicplusplus :-)
calixtus06, 11:35, ven. 16 Jul 2021: Bonjour et bienvenue à toi lablonde ! :-)
calixtus06, 18:53, mer. 14 Jul 2021: Bonjour et bienvenue à Lolo Rosso :-)
calixtus06, 08:54, mar. 13 Jul 2021: Bonjour et Bienvenue Pieriv, scamut, AvocadoToast:)
allany, 08:50, mar. 06 Jul 2021: @r1 : ouaip, fait pas chaud, là-haut et que d'eau !
r1, 20:57, lun. 05 Jul 2021: @allany: c'est faux ! En bzh, la météo est un vrai fiasco ! :-)
Samuel, 12:00, lun. 05 Jul 2021: Ardour 6.8 vient de sortir [Lien]
allany, 09:51, lun. 05 Jul 2021: La météo se met toujours au beau, avec l'édito ! [Lien]