Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

> Forums de discussion > 5 - Les serveurs son : Jack, PulseAudio et autres... > Ardour ZynAddSubFX... ne se lancent pas
Dernier post

Ardour ZynAddSubFX... ne se lancent pas

Survoje utilisateur non connecté
Bonjour, bonjour

Après mon qjackctl résolu , je continue ici par un autre problème... Ardour, ZynAddSubFX ne se lance pas

hydrogen, audacity, gxtuner, guitarix, lmms oui !.

À la demande de olinuxx, le lancement de ZynAddSubFx par la commande
zynaddsubfx -a -I jack -O jack

a renvoyé : Erreur de segmentation

Pour ardour, lancé avec qjackctl tournant, j'entends le disque dur mais rien à l'affichage.

lancé en ligne de commande >ardour4 ça me répond :

/usr/bin/ardour4: 31: /usr/bin/ardour4: nm: not found
/usr/bin/ardour4: 31: [: -gt: unexpected operator
Cannot find ArdourMono TrueType font
bind txt domain [gtk2_ardour4] to /usr/share/ardour4/locale
Ardour4.7.0 (built using 1:4.7~dfsg-1librazik2 and GCC version 4.9.2)
ardour: [INFO]: Your system is configured to limit Ardour to only 65536 open files
ardour: [INFO]: Loading system configuration file /etc/ardour4/system_config
CPU vendor: AuthenticAMD
ardour: [INFO]: CPU brand: AMD Sempron(tm) 2600+
ardour: [INFO]: Using SSE optimized routines
ardour: [INFO]: Loading default ui configuration file /etc/ardour4/default_ui_config
ardour: [INFO]: Loading user ui configuration file /home/gulliver/.config/ardour4/ui_config
/usr/share/themes/LibraZiK/gtk-2.0/gtkrc:99: error: unexpected identifier 'reliefstyle', expected character '}'
ardour: [INFO]: Loading color file /etc/ardour4/dark.colors
/usr/share/themes/LibraZiK/gtk-2.0/gtkrc:99: error: unexpected identifier 'reliefstyle', expected character '}'
ardour: [INFO]: Loading ui configuration file /etc/ardour4/clearlooks.rc
ardour: [INFO]: Loading ui configuration file /etc/ardour4/clearlooks.rc
ardour: [FATAL]: cannot find icon image for ardour_icon_48px.png using /home/gulliver/.config/ardour4/icons:/usr/share/ardour4/icons


la version installée est celle par défaut ardour 1:4.7-dfsg-librazik2

Merci pour votre aide !

olinuxx utilisateur non connecté France
Alors tu devrais mettre à jour tes logiciels avec Synaptic car la version d'Ardour actuelle dans LibraZiK est la 5.4, pas la 4.7.

Je te remets le lien pour cette procédure de mise à jour Image .

PS : quelle est la version de zynaddsubfx actuellement installée sur le système ?

Survoje utilisateur non connecté
Bonjour olinuxx, et merci de t'intéresser à mon cas biggrin

J'ai fait mon update upgrade et effectivement ça change... j'ai beaucoup plus de logiciels MAO.

pour la question zynaddsubbfx est la 3.01. Quand je lance en terminal, j'ai "Erreur de segmentation"

Ardour, hydrogen et lmms (ceux que j'ai testés) ne se lancent pas. J'ai comme message "Instruction non permise" en terminal.

Je mets les renvois d'Ardour (qui ouvre ses boites de dialogue jusqu'à la page de connexion avec Jack) et lmms qui peuvent renseigner.

ARDOUR
WARNING: Could not check your glib-2.0 for mutex locking atomic operations.

bind txt domain [gtk2_ardour5] to /usr/share/ardour5/locale
Ardour5.4.0 (construit avec 1:5.4.0~dfsg-2librazik2 et GCC version 4.9.2)
ardour: [INFO]: Votre configuration-système limite Ardour à 65 536 fichiers ouverts
ardour: [INFO]: Chargement du fichier de configuration-système /etc/ardour5/system_config
ardour: [INFO]: CPU vendor: AuthenticAMD
ardour: [INFO]: CPU brand: AMD Sempron(tm) 2600+
ardour: [INFO]: Using SSE optimized routines
ardour: [INFO]: Chargement du fichier de style par défaut (/etc/ardour5/default_ui_config) pour l'interface graphique
/usr/share/themes/LibraZiK/gtk-2.0/gtkrc:99: error: unexpected identifier 'reliefstyle', expected character '}'
ardour: [INFO]: Chargement du fichier de couleur /usr/share/ardour5/themes/dark-ardour.colors
/usr/share/themes/LibraZiK/gtk-2.0/gtkrc:99: error: unexpected identifier 'reliefstyle', expected character '}'
ardour: [INFO]: Loading ui configuration file /etc/ardour5/clearlooks.rc
ardour: [INFO]: Loading ui configuration file /etc/ardour5/clearlooks.rc
Found nothing along /home/gulliver/.config/ardour5/templates:/usr/share/ardour5/templates
run dialog
Instruction non permise


LMMS
VST sync support disabled in your configuration
Instruction non permise


HYDROGEN me renvoie juste "Instruction non permise"

Je suis bien dans le groupe "audio"

J'ajoute au cas où... l'accordeur FMIT fait planter de chez planter mon pc !

Cordialement

sub26nico utilisateur non connecté France
Jack est il lancé avant les applications?

olinuxx utilisateur non connecté France
La version "3.01" pour zynaddsubfx n'est pas suffisamment précise. Regarde dans ton synaptic, tu devrais avoir quelque chose du genre "3.0.1+git20170531~gitbb92bcc-0librazik1".

Questions : comment as-tu installé cette LibraZiK ? Quelle méthode as-tu suivi ?

Info nécessaire : donne moi le retour des commandes terminal :
lscpu | grep -i "mode(s)"
et
grep flags /proc/cpuinfo


Survoje utilisateur non connecté
  • Jack est bien lancé avant les applications.

  • La version de zynaddsubfx est bien celle mentionnée ci-dessus.

  • Install via l'iso 32bits chez LibraZik, copie sur une USB Live, test du Live, reboot "install"... rien de plus "classique"... Rien sur le pc auparavant (nettoyé)

retour de lspcu
Mode(s) opératoire(s) des processeurs : 32-bit


retour de grep
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mp mmxext 3dnowext 3dnow eagerfpu 3dnowprefetch vmmcall


PS:
1. au update/upgrade j'ai un paquet cassé "firmware-misc-nonfree". Après "réparer-application" j'ai un message d'erreur
E: /var/cache/apt/archives/firmware-misc-nonfree_20161130-3~bpo8+1_all.deb: tentative de remplacement de « /lib/firmware/ctefx.bin », qui appartient aussi au paquet alsa-firmware 1.0.29-0librazik2


2. je suis bien en mémoire RAM ?
total       used       free     shared    buffers     cached
Mem:          1,5G       1,1G       404M        55M        44M       574M
-/+ buffers/cache:       489M       1,0G
Swap:         4,0G         0B       4,0G



Merci Merci !!!

olinuxx utilisateur non connecté France
C'est quoi comme machine ? Les retours des commandes lscpu et grep flags ne me semble pas habituel. J'ai bien peur que tu ne puisses pas (pour l'instant) vraiment utiliser LibraZiK sur cette machine car les logiciels utilisent des instructions non-prévues pour ton processeur.

Reste à savoir pourquoi.

As-tu déjà installer d'autres distributions sur cette machine ? Si oui, lesquelles et quelles architectures (i386, amd64, x32, ...).

Survoje utilisateur non connecté
Le copain qui me l'a refilé m'a juste dit "une construction maison... un chinois de Paris !"

Y avait windows xp dessus... on a "nettoyé" avec gparted. D'ailleurs il croyait qu'il n'y avait que 40G0 de DD mais gparted en a trouvé une autre de 40Go "non allouée" (!) qu'on a mise en /home... On avait un DD 160G0 qui traînait par là, on l'a mis dessus pour des données.

Et la 1ère et seule install fut LibraZik (je souhaiterais en faire un pc démo MAO... si j'y arrive (!)

si ça t'inspire, je te donne le cat /proc/cpuinfo frown

processor	: 0
vendor_id	: AuthenticAMD
cpu family	: 6
model		: 8
model name	: AMD Sempron(tm) 2600+
stepping	: 1
cpu MHz		: 1832.783
cache size	: 256 KB
physical id	: 0
siblings	: 1
core id		: 0
cpu cores	: 1
apicid		: 0
initial apicid	: 0
fdiv_bug	: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mp mmxext 3dnowext 3dnow eagerfpu 3dnowprefetch vmmcall
bugs		: fxsave_leak sysret_ss_attrs
bogomips	: 3665.56
clflush size	: 32
cache_alignment	: 32
address sizes	: 34 bits physical, 32 bits virtual
power management: ts


et ne t'arraches pas les cheveux là-dessus... c'était une occasion pour nous d'avoir un pc démo uniquement dédié à la MAO !(une fois acquis les logiciels eek). On pourra toujours le recycler en "bureautique" !

Merci encore... si c'est vraiment une histoire de processeur, alors là, je n'aurais jamais trouvé !!!

olinuxx utilisateur non connecté France
Bizarre.

Essayons quelque chose. Les logiciels ne se lançant pas sont des logiciels que j'ai empaqueté moi même (zynaddsubbfx, Ardour, hydrogen et lmms). Peut être ai-je fais des erreurs pendant l'empaquetage.

Testons un truc sur un de ces logiciels : lmms. Ouvre ton synaptic et fais une recherche sur "lmms". Tu verras 2 paquets : "lmms" et "lmms-common". Cliques sur le paquet "lmms" puis va dans le menu synaptic -> Paquets -> Forcer la version..." et choisi la version "1.0.3-5 (oldstable)". Fais de même avec le paquet "lmms-common". Une fois fait, clique sur "Appliquer". Cela aura pour effet de supprimer la version Librazik de LMMS et d'installer la version de base de chez debian jessie.

Ensuite, ferme ton synpatic et lance LMMS à partir d'un terminal.

Dis nous si ça change quelque chose.

Survoje utilisateur non connecté
Bonjour olinuxx,

J'ai fait mais pas de changement !

Pour lmms même message "Instruction non permise"

J'ai fait pour hydrogen même message aussi.


Des lueurs quand même :
  • la version antérieure de l'accordeur FMIT ne fait plus planter le pc, il se connecte à jack.
  • la version antérieure de zynaddsubfx 2.4.3-4 tourne sous jack

Comme tu as parlé du processeur, j'ai noté au boot deux messages qui ne me plaisent pas :

  • failed to find CPU0 device node
  • modprobe : module microcode not found in module.dep

Il semble que quelques pc connaissent ce problème si j'en crois le retour de google mais je n'ai pas fouillé pour l'instant (pas mal de trucs en anglais (!)

Aurait-ce à voir avec les retour lscpu et grep flags dont tu parles ci-dessus ?

olinuxx utilisateur non connecté France
Je ne sais pas trop quoi te dire. On atteint ici la limite de ma compréhension.

Ma réflexion est celle-ci : si tu as des problèmes avec le lmms provenant de debian, c'est peut être que la base Debian sur laquelle LibraZiK repose a des problèmes. Savoir s'ils viennent du matériel ou autre, je ne sais pas, mais en tout cas, LibraZiK ne pourra pas fonctionner si la debian jessie sur laquelle il s'appuie ne fonctionne pas.

J'aurai donc ce conseil pour toi : réinstalle totalement une debian à partir d'une netinstall en sélectionnant le bureau MATE.

Ensuite, n'installe pas LibraZiK, mais installe les logiciels Qjackctl, Ardour, Hydrogen, LMMS, FMIT, zynaddsubfx qui possèdent tous une version dans debian (moins récente que celle de LibraZiK, mais à ce stade, c'est pas important).

Ensuite, essaie de faire fonctionne ça, si ça fonctionne, on pourra essayer de mettre LibraZiK par dessus cette debian + MATE. Si ça ne fonctionne pas, c'est certainement que le soucis se situe un cran en "dessous" et on verra ce que l'on peut faire.

Tiens nous au jus.

Survoje utilisateur non connecté
Merci olinuxx !

je vais faire ce que tu dis au plus tôt et je reviens donner le résultat !

A+

Survoje utilisateur non connecté
Merci de l'idée !

J'ai fait ce que tu m'as proposé : netinstall 8 + MATE et j'ai installé les logiciels... apparemment ça marche ! j'ai testé, les logiciels, ardour, hydrogen, lmms, zynaddsubfx, audacity s'ouvrent et certains se connectent à jackd en auto.

Du coup, je laisse cette Debian... avec une installation de logiciels MAO au coup par coup ?

Est-ce que update et upgrade restent possibles ?

Dois-je abandonner LibraZik (sur cette machine) ou une piste est encore envisageable ? Anecdote : comme j'avais un /home séparé, j'ai toujours le fond d'écran LibraZik... suivant la réponse à la question précédente, je virerai pour ne pas faire croire que...

En tout cas, chapeau pour l'aide !

J'attends ta réponse pour mettre en résolu.

olinuxx utilisateur non connecté France
Si t'as envie de m'aider à comprendre pourquoi ça ne fonctionnait pas, je peux te proposer une méthode afin de débusquer le ou les coupable(s). Ce qui pourrait faire en sorte que tu finisses par être sur LibraZiK. T'es partant ?

Survoje utilisateur non connecté
Pourquoi pas ? Je ne me sers pas du PC ! il est là pour "l'expérimentation", en l'occurrence la MAO. On peut donc tenter, ça n'en sera que plus pédagogique pour moi biggrin

Ok donc pour la méthode, j'ai quelques compétences Linux autour de moi qui pourront m'aider si je suis dépassé !

olinuxx utilisateur non connecté France
OK, je réfléchi à une méthode, et je te tiens au jus.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]


EricV86

Mégaphone [Afficher / Cacher]

olinuxx, 20:37, mer. 04 Aug 2021: Bonjour et bienvenue à PianoOrgan3478 cool
sub26nico, 16:00, mer. 04 Aug 2021: Bonjour et bienvenue à EricV86, smith8395john, alinabeth et leowilson :-)
sub26nico, 13:05, lun. 02 Aug 2021: @CyrilRos, ton lien ci-bas ne fonctionne pas
CyrilRos, 22:59, dim. 01 Aug 2021: Tux|N|Mix 21.1 disponible [Lien]
sub26nico, 14:33, dim. 01 Aug 2021: Salut et bienvenue à Youplala, Cant' et Bluetak :-)
CyrilRos, 21:45, mar. 27 Jul 2021: [Lien]
olinuxx, 20:54, mar. 27 Jul 2021: Bonjour et bienvenue à nick cool
olinuxx, 20:47, dim. 25 Jul 2021: Bonjour et bienvenue à GrosRems et à paulisaak cool
olinuxx, 20:05, jeu. 22 Jul 2021: Bonjour et bienvenue à labeyte07 cool
olinuxx, 21:03, mar. 20 Jul 2021: Bonjour et bienvenue à tv cool
Nolwen, 19:33, lun. 19 Jul 2021: Hola,À propos de la création de pattern (motifs) MIDI pour batterie, quelqu'un sait-il où en est la discussion ?
olinuxx, 01:28, lun. 19 Jul 2021: Lolo-Rosso : l'adresse courriel que tu as renseignée lors de ton inscription n'est pas fonctionnelle. Contacte moi pour corriger le soucis : [Lien]