Forum : 4 - Toutes les autres applications, les émulateurs...

[RESOLU]Installer Tuxguitar 1.4

Sapiens Articles : 256 utilisateur non connecté
Bonjour,

Je souhaite installer Tuxguitar 1.4 sous linuxmint 18.2, or cette version n'est pas présente dans le gestionnaire Synaptic. J'ai donc téléchargé un fichier .tar.gz que j'ai extrait dans mon dossier Téléchargements.

Je me retrouve donc, à l'adresse /home/yann/Téléchargements ( orthographe vérifiée ) avec le dossier tuxguitar-1.4-linux-x86_64 dont je ne sais que faire. J'ai tenté quelques lignes de commande mais je maîtrise très mal et ça n'a rien donné. J'ai lu un ou deux sujets sans trouver la situation équivalente.

Si quelqu'un peut m'aider.
Merci

r1 Articles : 821 utilisateur non connecté France
Hello,

Peut-être devrais-tu plutôt essayer d'installer le .deb ?

https://sourceforge.net/projects/tuxguitar/files/TuxGuitar/TuxGuitar-1.4/tuxguitar-1.4-linux-x86.deb/download
ou
https://sourceforge.net/projects/tuxguitar/files/TuxGuitar/TuxGuitar-1.4/tuxguitar-1.4-linux-x86_64.deb/download

En fonction de ton système (32 ou 64 bits).

Puis d'essayer de l'installer avec la commande suivante ?

sudo dpkg -i nom_du_programme


Pas sur que cela fonctionne mais si c'est le cas, je pense que ce sera plus simple et que tuxguitar sera mieux intégré à ton système.

Sinon, à priori, tu as déjà décompressé l'archive :

cd /home/yann/Téléchargements/tuxguitar-1.4-linux-qt-x86_64/


puis :

./tuxguitar.sh



A+
Erwan

allany Articles : 5777 utilisateur non connecté
Si tu veux continuer dans la voie de la compilation, tu as très certainement, dans ton dossier tuxguitar-1.4-linux-x86_64, un fichier README ou INSTALL qui te décrira la procédure.
Y'a des chances que ce soit une séquence :
./configure
make 
(su ou sudo) make install
enfin, regarde...
A+

Sapiens Articles : 256 utilisateur non connecté
Merci pour vos réponses,

Alors voilà : J'ai suivi le conseil de r1, à savoir télécharger le paquet .deb.

En cliquant sur le dossier, ça a ouvert directement une fenêtre "Installateur de paquets". J'ai donc validé l'installation et la procédure d'installation s'est déroulée normalement. Mais j'ai tout de même eu un message m'informant que "L'API sound java" ne peut être chargé".

Je n'ai tout d'abord pas eu de son, puis, après avoir configuré "Fluidsynth output plugin" sur Alsa au lieu de Pulseaudio, le son est arrivé.

Ça marche, donc, mais est-ce que l'install est vraiment correcte ?

Sapiens Articles : 256 utilisateur non connecté
Argh ! Ça ne fonctionne pas bien ! Ce nouveau Tux refuse d'ouvrir les .GP5 et il plante à la fermeture.

Alors la question est, maintenant, de savoir comment désinstaller proprement pour remettre la version présente dans synaptic ?

Merci

Sapiens Articles : 256 utilisateur non connecté
Re,

Désolé, je pose des questions sans attendre les réponses !

Bon, j'ai désinstallé Tuxguitar 1.4 par clic droit>desinstaller. J'ai ensuite réinstallé la version 1.2 + les dépendances Alsa, fluidsynth et JSA. Ça fonctionne à nouveau mais je ne peux toujours pas ouvrir les .gp5 alors qu'auparavant ça marchait...

Merci encore...confused

r1 Articles : 821 utilisateur non connecté France
Bizarre...

Au début, j'allais te dire d'essayer de déplacer le répertoire de config. Mais celui-ci doit être différent sur la 1.2 et la 1.4...

En effet, j'ai ça :
/home/erwan/.tuxguitar-1.4/

Tu devrais essayer de le lancer à partir de la console à la main pour voir si tu n'as pas des messages d'erreur.

D'ailleurs quand tu dis, "je ne peux pas ouvrir les .gp5", tu as un message d'erreur ?

A+
Erwan

sub26nico Articles : 3654 utilisateur non connecté France
Citation :
Ça fonctionne à nouveau mais je ne peux toujours pas ouvrir les .gp5


As tu vérifié que les greffons 'GPX File Format Plugin' et
'Guitar Pro File Format Plugin' étaient activés?
Pour se faire, tu vas dans le menu 'Outils', puis dans 'Greffons' et si les 2 cases
ne sont pas cochées, tu cliques dessus.

Sapiens Articles : 256 utilisateur non connecté
Merci pour votre aide,

Dans les greffons, j'ai bien "GPx file format plugin", qui est coché, mais pas trace de "Guitar Pro File Format Plugin".

Le message d'erreur est : "Erreur d'ouverture : {0}"
et à l'importation : "Erreur d'importation : {0}"

Sapiens Articles : 256 utilisateur non connecté
Suite... et fin.

Après lecture en diagonale de plusieurs fils, une procédure a retenu mon attention : supprimer les fichiers en question et les télécharger de nouveau ( encore faut-il pouvoir et je pouvais vu qu'ils étaient toujours en pièces jointes dans ma messagerie ).

J'ai essayé et ça a fonctionné.

Merci encore de vous être penchés sur mon cas.

Je mets un [RESOLU].

Yann