Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [RÉSOLU] Problème jack avec firewire / installation table firewire Phonic
Dernier post
Page : 1/2   -   Aller directement à la page : 1  2 

[RÉSOLU] Problème jack avec firewire / installation table firewire Phonic

graphachen utilisateur non connecté
Bonjour, je suis novice en linux, j'ai une distribution Ubuntu Studio toute neuve avec ardour etc ...

je dois lancer à ce que j'ai compri, Jack avant de lancer ardour et dans le setup de jack choisir FREEBOB à la place de ALSA ... et j'ai un message d'erreur quand je lance jack !!

quel est le pb ?
est-ce que quelqu'un a déjà installé une table phonic firewire sous ubuntu ?
ou même toute autre table firewire ????
j'ai l'impression que le problème vient juste du fait que les drivers firewire ne snt pas ok ...
...
Peut être juste une configuration dans Jack ??? j'y comprend rien ...

help !

voilà le message :

[+]

sylvain.leconte utilisateur non connecté
Citation :
cannot load driver module freebob


Est-ce que tu as bien installé le driver freebob (ie. le paquet libfreebob0) ?

graphachen utilisateur non connecté
Je pense qu'il est installé d'office sur ubuntu studio, non ?

j'avais cru comprendre ça ...

peut on vérifier ensemble stp ?



sylvain.leconte utilisateur non connecté
pour vérifier, vas dans synaptic, et cherche "libfreebob", tu veras tout de suite s'il est installé ou non (le carré est vert s'il est installé)

graphachen utilisateur non connecté
j'ai libfreebob0 qui est installé


sylvain.leconte utilisateur non connecté
ok.

Bon, alors c'est que t'as pas du choisir le bon périphérique audio. Va dans le setup de Qjackctl, et regarde au niveau du champ "Interface". Il doit y avoir marqué "Default" dedant. Regardes les autres choix que tu as, il faut que tu choisissent le périphérique correspondant à ta table. En espérant qu'elle soit supportée...

graphachen utilisateur non connecté
nous avions choisi defeult, effectivement......

Il y à hw:0 ou hw:1 disponibles !??

Que choisir .....

j'essaie ....................

graphachen utilisateur non connecté
Même message d'erreur en utilisant hw:0 ou hw:1 ..........

On devrait voire autre chose disponible comme choix ???

sylvain.leconte utilisateur non connecté
oui, essayer est la meilleure solution, ça dépend tellement d'un ordi à l'autre ! Bon ceci dit, en théorie, Default, c'est hw:0, donc ça devrait être l'autre biggrin

sylvain.leconte utilisateur non connecté
ah merde, crosspost...

Bon, je vois pas trop... tu as toujours cette ligne là :

Citation :
FreeBoB ERR: device (-d) argument not valid


où une autre quand tu passes en hw:1 ?

Sinon, tu peux essayer gscanbus pour vérifier que ta table est bien branchée. C'est quel modèle que tu as ?

graphachen utilisateur non connecté
Même message, malheureusement :


et gscanbus command not found !!!

[+]

graphachen utilisateur non connecté
la table est une PHONIC HELIX BOARD 24 MKII

sylvain.leconte utilisateur non connecté
Non, c'est pas du tout le même message regarde :

Ieee1394Service::initialize: Could not get 1394 handle: Invalid argument
Is ieee1394 and raw1394 driver loaded?
Fatal (devicemanager.cpp)68 initialize: Could not initialize Ieee1349Service object
Fatal (freebob.cpp)69 freebob_new_handle: Could not initialize device manager
FreeBoB ERR: FREEBOB: Error creating virtual device


Ta table est "reported to work", donc y'a bon espoir. Pour gscanbus, il faut l'installer via synaptic (tu recherches "gscanbus", et tu clickes sur le carré pour l'installer).

Bon, sinon, apparement, il ne trouve pas les drivers pour le port firewire (IEEE1394 est le protocole firewire, et les driver ieee1394 et raw1394 sont les drivers linux qui gèrent ce port)

2 solutions : soient ils sont pas installés => Synaptic (ce qui me smeble bizarre sous US)
Soient, ils sont installés mais tu n'as pas les droits en tant que simple utilisateur pour les utiliser.

Pour cela testes dans une console :
$ sudo /usr/bin/jackd -dfreebob -dhw:1 -r44100 -p1024 -n3 -D


Si ça marche, ce n'est qu'une question de droits (il faut que tu t'ajoutes au groupe "audio" ou un truc dans le genre. La manip est détaillée sur ce site).

Ieee1394Service::initialize: Could not get 1394 handle: Invalid argument
Is ieee1394 and raw1394 driver loaded?


Ce message d'erreur est un classique, regarde la page freebob. Tu y trouveras des infos concernant l'utilisation de freebob sous ubuntu et les moyens de corriger les erreurs les plus fréquentes.

T.

riton_lafouine utilisateur non connecté France
trouvé dans le WIKI de linux MAO

Error creating virtual device
JACK compiled with System V SHM support.
loading driver ..
Freebob using Firewire port 0, node -1
Ieee1394Service::initialize: Could not get 1394 handle: No such file or directory
Is ieee1394 and raw1394 driver loaded?
Fatal (devicemanager.cpp)68 initialize: Could not initialize Ieee1349Service object
Fatal (freebob.cpp)69 freebob_new_handle: Could not initialize device manager
FreeBoB ERR: FREEBOB: Error creating virtual device
cannot load driver module freebob


Ce message signifie que le module "raw1394" n'est pas chargé, ou inaccessible.
vous pouvez essayer ces commande en mode root :
$ modprobe raw1394
$ chmod a+rw /dev/raw1394


c'est une erreur récurente ...

surtout, il faut allumer ta table firewire après le lancement de l'OS, sinon, Freebob croit que le port est occupé.

Donc ... modprobe et chmod ... ensuite alumer ta table, lancer qjackctl et ca devrai marcher

graphachen utilisateur non connecté
Bon, me voici de retour

ne voulant pas vous importuner plus que ça, j'ai essayé avec toutes les infos que vous m'avez données + celle du topic d'installation freebob d'avancer dans mon problème ...

rien n'y fait !!!

bon je pense avoir avancé un peu quand même :

Dans le menu système / préférences / hardware informations, je vois bien ma table de mixage firewire branchée au port firewire, il me donne bien le nom de ma table (HB 24 MKII)

Donc elle semble reconnue, je me trompe ??

Ensuite, par le biais de la console (terminal) si je tape jackd -d freebob, j'ai le même message que si je lance jack crtl en mode graphique :


[+]

Avez vous une idée ??? j'avoue que ça fait quand même 1 semaine que je suis dessus et j'ai beau être patient, je dois dire qu'à certains moments, la moutarde me monte au nez !

Merci de votre aide précieuse !

sylvain.leconte utilisateur non connecté
Configure Jack avec une fréquence d'échantillonage de 96kHz : d'après la doc technique la table ne fonctionne qu'avec cette fréquence.

graphachen utilisateur non connecté
Sylvain, merci de ton aide, vraiment le tps que tu passes pour moi c''est très sympa.

alors j'ai changé le taux d'échantillonage ... rien n'y fait ...

[+]

je pense qu'on doit pas être loin, ça doit être un truc tout con de réglage ... enfin j'espère !
Vu que je vois ma table de mixage (en fait ma carte son) bien reconnue quand je l'allume dans de gestionaire de périphériques de ubuntu ...

donc c'est certainement juste un réglage de jack ! Mais lequel ??? mystère...

graphachen utilisateur non connecté
Ce qui est marrant qu'est que le message n'est pas le même ... la finalité du premier message quand je laisse 48000 c'est :
LibFreeBoB ERR: Failed to set samplerate...

quand je mets 96000 c'est :
cannot load driver module freebob ...


c'est n'importe quoi ces messages ... bizarre non ? il peut pas lancer le driver freebob si je suis en 96000 ? et en 48000 il peut pas mettre le taux d'échantillonage en place ... mais qu'est-ce qu'il veut à la fin ????

là on sent bien l'énervement de l'installateur déçu.

HELP !

dufy utilisateur non connecté
Salut.

Pardon si je reviens un peu en arrière, mais ce post est bien touffu.
J'ai eu un peu près le même problème avec ma presonus FP10 sous Ubuntu studio.
Je l'ai résolu en suivant ce post : FreeBob

Ce qui avait vraiment fait marcher le truc, c'est le sudo addgroup disk
Fais le et dis nous si tu vois ta carte avec gscanbus.
Si oui, ton driver FireWire est hors cause, et il faut chercher coté Jack.
Sinon, il faut passer + bas dans l'analyse de tes modules.

Yves

iData utilisateur non connecté
salut dufy,

ça m'intéresses grandement de connaître un peu ta conf niveau du FP10, car je pense me le commander d'ici peu de temps (1 à 2mois quand il y aura les sous :-) ) et en fonctionnement sur une ubuntuStudio ou 64Studio, pour l'instant je tests les 2 avec une SB Live !

J'aimerais connaître un peu avec qu'elle matos tu utilise, ta latence avec le FP10, et qu'elle configuration de Jack tu as utilisée (Priority, Frames/Period, etc...) et si ils fonctionnent bien sous linux, et l'utilisation, etc... en gros un peu tout lol :-)

Et si ça te dis de commencer a rédiger une page sur le fonctionnement du FP10, configuration, ça serait cool :-)


Merci par avance dufy.


Bonne soirée


--
Da

Page : 1/2  [Suivant]
1  2 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 18:46, jeu. 16 Sep 2021: Bonjour et bienvenue à pierre2 cool
zicstef, 22:40, mer. 15 Sep 2021: Hello, il y a bien longtemps que je n'ai pas eu la joie de passer. Découvert au détour d'un surf: /
olinuxx, 18:30, lun. 13 Sep 2021: [INFO] nouveau compte Diaspora pour linuxmao : [Lien] Venez nous y rejoindre cool
Samuel, 02:44, dim. 12 Sep 2021: [Lien] C'est la video de présentation du futur de VCV RACK, un synthé modulaire
olinuxx, 18:55, jeu. 09 Sep 2021: @dugalandco : utilises le forum pour mener des discussions. Le mégaphone n'est pas utilisé pour des discussions, mais pour informer de façon rapide.
dugalandco, 17:20, jeu. 09 Sep 2021: merci à olinuxx et sri raoul. Je vais donc tenter d'installer Ubuntu studio. Si je ne me trompe , il s'agit bien d'un système de distribution linux en son entier ? pas seulement la partie musique ?
sub26nico, 12:44, jeu. 09 Sep 2021: Bonjour et bienvenue à Jha :-)
sub26nico, 12:41, jeu. 09 Sep 2021: @Jha: ouvres un fil de forum pour que l'on puisse te répondre.
Jha, 11:12, jeu. 09 Sep 2021: bonjour j'arrive pas a telecharger ubuntustudio-audio klk un peut m'aider?
olinuxx, 20:41, mer. 08 Sep 2021: Les nouveautés LibraZiK des 5 derniers mois : [Lien]
olinuxx, 20:23, mer. 08 Sep 2021: Bonjour et bienvenue à dugalandco cool
olinuxx, 20:17, mer. 08 Sep 2021: l'édito ? quésako ? ahhh, ce truc très beau et tout chaud ! Je cours le lire tout de go !