Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

6 - Le MIDI

> Forums de discussion > 6 - Le MIDI > [résolu] Initialisation des controleurs dans rosegarden 16.06
Dernier post

[résolu] Initialisation des controleurs dans rosegarden 16.06

ardoisebleue utilisateur non connecté France
J'utilisais Rosegarden version 12.04 avec Debian 7, je suis passé à Debian 9, avec Rosegarden 16.06.

J'ai un problème avec la réinitialisation des codes contrôles quand je joue un morceau.
exemple :
j'utilise le Code Contôle 7 (volume) sur une piste qui contient une série de notes. Au début le CC7 est initialisé à 53, en fin de piste, je termine par un abaissement du son en appliquant une suite de valeur, de 52 à 0.

Avec la version 16.06 :
La première fois que je joue le morceau jusqu'au bout tout va bien j'obtiens bien un "shunt", Si je replace le curseur de la grille au milieu de la piste, plus de son, le CC7 reste initialisé à 0.

Avec la version 12.04, il n'y avait pas ce problème car un paramètre d'exécution dans la configuration:
editer->configuration->MIDI->général->Emettre tous les contrôleurs Midi au début de chaque exécution
replaçait les CC à la valeur la plus proche de la position du curseur.

Avec la version 16.06 : étrangement, ce paramètre n'existe plus et il est remplacé par :
Editer->configuration->MIDI->général->autorise la réinitialisation de tous les contôleurs (CC121)
qui semble ne pas avoir ce même effet. A noter aussi que dans le standard MIDI le code 121 : Reset All Controllers, remet les contrôleurs à leur valeur de base (ex: code 10 (balance) sera remis à 63 (centre)).

J'ai pu constater que dans le fichier de configuration de la 12.04 : la variable "alwayssendcontrollers=true" disparaissait dans la version 16.06 et qu'elle est remplacée par "allowresetallcontrollers=true".

Dans les versions intermédiaire y-a-t-il eu observation de ce problème et résolution ?

J'ai écumé le site rosegarden de sourceforce.net mais il n'y a pas de post sur ce problème.

Avant que je n'envoie un mail à l'équipe de Rosegarden, quelqu'un a-t-il un avis sur ce souci ou une solution ?

ardoisebleue utilisateur non connecté France
J'ai téléchargé et compilé la version Rosegarden 16.02 elle ne contient pas le bug.

olinuxx utilisateur non connecté France
Joli dégottage de bogue !
Bien vu et bien joué ardoisebleue wink

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 13:17, dim. 15 Sep 2019: Bonjour et bienvenue à wwp et à Kraod cool
sub26nico, 22:18, sam. 14 Sep 2019: Salut et bienvenue à Gretsh56 :-)
olinuxx, 13:44, sam. 14 Sep 2019: Bonjour et bienvenue à T-Yo cool
PenZyh, 16:09, mar. 10 Sep 2019: Merci ^^
olinuxx, 16:08, mar. 10 Sep 2019: Bienvenue e bonjour également à PenZyh cool
olinuxx, 14:47, mar. 10 Sep 2019: Bonjour et bienvenue à SKUNKLOAD cool
sub26nico, 10:29, lun. 09 Sep 2019: Salut et bienvenue à aldepr :-)
olinuxx, 09:01, dim. 08 Sep 2019: Bonjour et bienvenue à nuka cool
sub26nico, 20:21, jeu. 05 Sep 2019: Salut et bienvenue à smo :-)
olinuxx, 10:31, jeu. 05 Sep 2019: Il est tout beau, il est tout chaud, c'est l'édito de linuxmao ! [Lien]
olinuxx, 20:15, dim. 01 Sep 2019: Bonjour et bienvenue à Gordus cool
olinuxx, 01:46, ven. 30 Aug 2019: Bonjour et bienvenue à leouiche et à Bellus cool