Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

Dernier post

Erreur - JACK Audio Connection Kit

Kasukio utilisateur non connecté
Bonjour,

Je suis stagiaire en BTS Système Numérique, et pour mon stage j'ai l'occasion de bosser dans une radio et de faire des choses que je n'ai jamais fais, je suis assez largué et je rencontre un problème:
Image

J'ai beau chercher, j'ai l'impression que les autres installations (sur le forum) sont différentes, voici mes paramètres :
Image

Merci pour l'aide que vous pourrez m'apporter ^^

sub26nico utilisateur non connecté France
Il faudrait donner quelques renseignements supplémentaires,
sur quelle distribution? quel noyau? quelle carte son ?
Pour les 2 dernières questions, si tu peux nous retourner ,dans une boîte code,
le résultat des 2 commandes que tu taperas dans un terminal :
aplay -l

et
uname -a


olinuxx utilisateur non connecté France
Ouahou, les logiciels semblent plutôt vieux. Genre jackd version 1.9.9.5 qui date de décembre 2012 ! Il t'est possible de mettre à jour ?

Kasukio utilisateur non connecté
Ma demande est prématurée, j'ai plusieurs choses à tester avant, je m'en excuse je reviens vers vous quand j'aurais tout testé
Merci.

Kasukio utilisateur non connecté
Bonjour, je reviens vers vous avec plus d'informations

Pour la distribution, c'est Red Hat si je ne dis pas de bêtises
et pour les deux dernières questions, voila les résultats des commandes

aplay -l
Image

uname -a
Image

Et je ne pense pas pouvoir mettre à jour, je demande confirmation.
Merci pour votre aide

allany utilisateur non connecté
Ton aplay, peux-tu plutôt poster un copier-coller du résultat "texte" de la commande ? J'ai l'impression que ta capture d'écran ne montre pas la fin de la liste...

Ensuite, dans jackd, tu as mis hw:AXIA comme interface mais que te propose-t-il comme autre(s) option(s) ?

olinuxx utilisateur non connecté France
Red Hat, c'est le nom de la distribution.
Il y a eu des tas de versions différentes de Red Hat. Il serait utile que tu nous en dises plus sur son numéro de version. Car en l'état, elle semble être plutôt vieille (vu les versions des logiciels comme vu plus haut).

Kasukio utilisateur non connecté
Bonjour j'ai discuté avec le service client Paravel qui s'occupe de mes cartes son, il ma donné un patch correctif etc et Jack remarche, maintenant j'ai installé Rotter qui me servira pour la pige, cependant je n'arrive pas à le lancer, je fais clic droit "executer" mais l'application ne se lance pas.

Savez vous pourquoi ?

Kasukio utilisateur non connecté
Quand j'essaye visiblement de lancer (TEST) mon logiciel Rotter via le terminal j'ai ce messsage, je n'arrive pas à comprendre ce qu'il signifie, si vous avez une idée je suis preneur, merci.
Je m'excuse mais je débute sous linux, je débute la MAO.

[root@srv-rivendell Desktop]# rotter
[ERROR]  Thu Jun 21 11:30:04 2018  rotter requires a root directory argument.
rotter version 0.9

Usage: rotter [options] 
   -a            Automatically connect JACK ports
   -f    Format of recording (see list below)
   -b   Bitrate of recording (bitstream formats only)
   -c  Number of channels
   -n      Name for this JACK client
   -N  Name for archive files (default 'archive')
   -d     Delete files in directory older than this
   -R      Length of the ring buffer (in seconds)
   -L    File layout (default 'hierarchy')
   -j            Don't automatically start jackd
   -v            Enable verbose mode
   -q            Enable quiet mode


sub26nico utilisateur non connecté France
Note modération : merci d'utiliser la balise CODE lorsque tu copies/colles du code sur le site. Celles-ci permettent un meilleur affichage.
Image
Voir également cette page.

@Kasukio, j'ai édité ton message pour qu'il s'affiche correctement.

Concernant le message de la console, j'ai l'impression qu'il faut rajouter un ou plusieurs
'argument(s)' à ta commande, par exemple :

rotter -a

si tu veux que rotter se connecte automatiquement aux ports de Jack.

Kasukio utilisateur non connecté
J'ai rajouté les arguments, cependant je me suis trompé mais j'ai l'impression qu'il fait quand même des choses, et le fait qu'il n'y ait pas d'interface me perturbe

[root@srv-rivendell Desktop]# rotter -a -f mp3 -d 1000 -b 160 -v /var/archives
[FATAL]  Fri Jun 22 09:07:38 2018  Root directory does not exist: /var/archives
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jackdmp 1.9.9.5
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2012 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 10
creating alsa driver ... hw:PCH|hw:PCH|1024|2|48000|0|0|nomon|swmeter|-|32bit
configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 32bit integer little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 32bit integer little-endian
ALSA: use 2 periods for playback
[INFO]   Fri Jun 22 09:07:39 2018  JACK client registered as 'rotter'.
[DEBUG]  Fri Jun 22 09:07:39 2018  Size of the ring buffers is 2.00 seconds (384000 bytes).
[DEBUG]  Fri Jun 22 09:07:39 2018  User selected [mp3] 'MPEG Audio Layer 3'.
[INFO]   Fri Jun 22 09:07:39 2018  Encoding using liblame version 3.100.
[DEBUG]  Fri Jun 22 09:07:39 2018    Input: 48000 Hz, 2 channels
[DEBUG]  Fri Jun 22 09:07:39 2018    Output: MPEG-1 Layer 3, 160 kbps, Joint Stereo
[INFO]   Fri Jun 22 09:07:39 2018  Connecting 'system:capture_1' to 'rotter:left'
[INFO]   Fri Jun 22 09:07:39 2018  Connecting 'system:capture_2' to 'rotter:right'
[DEBUG]  Fri Jun 22 09:07:39 2018  Shutting down LAME encoder.
JackTemporaryException : now quits...


Kasukio utilisateur non connecté
Image

Si je comprends bien, rotter s'est connecté a capture_1 et 2 c'est bien ça ? Mais j'ai rien qui m'indique qu'effectivement c'est connecté

sub26nico utilisateur non connecté France
Citation :
Mais j'ai rien qui m'indique qu'effectivement c'est connecté

Il faut surement mettre les arguments qui l'affichent.
Peut être en essayant avec l'argument '-n'.

Kasukio utilisateur non connecté
Bah c'est à dire que dans le code il me dit que le client Jack se nomme rotter donc il a déjà un nom par défaut je suppose

sub26nico utilisateur non connecté France
Es tu sûr qu'il faille lancer rotter en root ?
Car pour Jack, il me semble qu'il faille être en user.

sub26nico utilisateur non connecté France
Je viens de trouver cette page , peut être que cela aidera.

Kasukio utilisateur non connecté
Je l'ai également trouvé, je me renseigne sur le logiciel depuis ce matin

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 20:37, mer. 04 Aug 2021: Bonjour et bienvenue à PianoOrgan3478 cool
sub26nico, 16:00, mer. 04 Aug 2021: Bonjour et bienvenue à EricV86, smith8395john, alinabeth et leowilson :-)
sub26nico, 13:05, lun. 02 Aug 2021: @CyrilRos, ton lien ci-bas ne fonctionne pas
CyrilRos, 22:59, dim. 01 Aug 2021: Tux|N|Mix 21.1 disponible [Lien]
sub26nico, 14:33, dim. 01 Aug 2021: Salut et bienvenue à Youplala, Cant' et Bluetak :-)
CyrilRos, 21:45, mar. 27 Jul 2021: [Lien]
olinuxx, 20:54, mar. 27 Jul 2021: Bonjour et bienvenue à nick cool
olinuxx, 20:47, dim. 25 Jul 2021: Bonjour et bienvenue à GrosRems et à paulisaak cool
olinuxx, 20:05, jeu. 22 Jul 2021: Bonjour et bienvenue à labeyte07 cool
olinuxx, 21:03, mar. 20 Jul 2021: Bonjour et bienvenue à tv cool
Nolwen, 19:33, lun. 19 Jul 2021: Hola,À propos de la création de pattern (motifs) MIDI pour batterie, quelqu'un sait-il où en est la discussion ?
olinuxx, 01:28, lun. 19 Jul 2021: Lolo-Rosso : l'adresse courriel que tu as renseignée lors de ton inscription n'est pas fonctionnelle. Contacte moi pour corriger le soucis : [Lien]