Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [Résolu] MOTU 624 AVB, connexion USB, ethernet et GUI
Dernier post

[Résolu] MOTU 624 AVB, connexion USB, ethernet et GUI

dede utilisateur non connecté
Bonjour à tous,

suite à de nombreux feedbacks positifs à propos de la nouvelle ligne d'interfaces MOTU et de son usage sous notre OS favori, j'ai décidé de passer le pas et de m'offrir une 624 en remplacement de ma vieille et fidèle Echo Layla 24 (qui va sur ses 20 ans si je ne m'abuse...).

Et là, c'est le drame. La carte étant censé être Class Compliant, je pensais qu'elle fonctionnerait out of the box, ou presque. Que nenni... Si mon PC la voit bien à travers KInfoCenter comme un périphérique USB, mon serveur Jack refuse absolument de démarrer, avec ces lignes en log :
Thu Nov  8 10:09:07 2018: Starting jack server...
Thu Nov  8 10:09:07 2018: JACK server starting in realtime mode with priority 85
Thu Nov  8 10:09:07 2018: self-connect-mode is "Don't restrict self connect requests"
Thu Nov  8 10:09:07 2018: Acquired audio card Audio2
Thu Nov  8 10:09:07 2018: creating alsa driver ... hw:D624,0|hw:D624,0|512|2|48000|6|8|hwmon|swmeter|-|32bit
Thu Nov  8 10:09:07 2018: Using ALSA driver USB-Audio running on card 2 - MOTU 624 at usb-0000:00:1a.0-1.2, high speed
Thu Nov  8 10:09:07 2018: configuring for 48000Hz, period = 512 frames (10.7 ms), buffer = 2 periods
Thu Nov  8 10:09:07 2018: ALSA: final selected sample format for capture: 24bit little-endian in 3bytes format
Thu Nov  8 10:09:07 2018: ERROR: ALSA: cannot set channel count to 6 for capture
Thu Nov  8 10:09:07 2018: ERROR: ALSA: cannot configure capture channel
Thu Nov  8 10:09:07 2018: Released audio card Audio2
Thu Nov  8 10:09:07 2018: ERROR: Cannot initialize driver
Thu Nov  8 10:09:07 2018: ERROR: JackServer::Open failed with -1
Thu Nov  8 10:09:07 2018: ERROR: Failed to open server


De plus, les tentatives de connexion ont tendance à faire bugger Cadence, qui freeze. KMix plante systématiquement quand j'allume la carte et s'éteint.

De plus, je ne parviens pas à me connecter à l'interface via mon navigateur et le port ethernet du PC ! Quand j'ai pingé l'adresse IP de la 624, j'ai eu droit à "host unreachable".

En bref, j'ai besoin d'aide. Dans le pire des cas, je la renverrai et resterai avec l'Echo Layla, mais bon, c'est pénible... Merci d'avance pour vos réponses.

Edit : quelques précisions. Le PC est sous KXStudio. J'ai aussi testé tout ça avec une clé USB contenant KXStudio Live (pour voir si ça venait des divers tripatouillages que j'ai pu faire sur mon PC), ainsi qu'avec une Librazik2 Live sur le même support. Ca ne change absolument rien au problème.

Édition modéro-forum olinuxx le 08 novembre 2018 à 12h58 : ajout de liens internes.


dede utilisateur non connecté
Ca alors... je viens de parvenir à résoudre le problème de son. J'ai passé 6h dessus hier sans succès, et juste après avoir posté le message, j'ai trouvé :il fallait passer dans Cadence le nombre d'Inputs et Outputs Channels à 0.

Par contre, toujours impossible de se connecter au GUI...

Edit : par contre, il faut impérativement la brancher à un port USB2. Ca plante sur un USB3. Un peu dégoûté quand même, mais comme je n'enregistre que rarement plus de deux pistes simultanément, ça ne devrait pas être trop gênant.

dede utilisateur non connecté
Résolu !!

Impossible de se connecter directement à la MOTU 624 en utilisant la deuxième interface réseau de ma tour. Alors que ça fonctionne sous Windows...

Heureusement, il me restait un vieux switch ethernet que j'ai exhumé d'un placard pour l'occasion, et miracle, ça tourne !

On dirait que le système ne savait pas quelle interface réseau utiliser pour se connecter... Mais plus étrange, même quand la carte était branchée seule au PC (cad sans aucune connexion ethernet supplémentaire), elle était impossible à atteindre. Même un ping en spécifiant l'interface réseau à utiliser ne donnait rien.

En bref, si votre tour dispose de plusieurs interfaces réseau et que vous voulez avoir votre connexion internet + le GUI MOTU, il faut passer par un switch. Ca marche peut-être aussi en connectant la carte son directment à la box, faut voir, mais ma box est trop loin de ma salle de musique pour que je teste ça...

olinuxx utilisateur non connecté France
Merci pour ce retour d'expérience @dede. Nous n'avions pas encore d'information concernant cette interface et son utilisation sur le site. J'ai donc créé une page MOTU 624 AVB et y ai mis un lien vers ici. Grâce à ton retour et à tes explications, la connaissance commune et partagée sur ce site vient encore d'augmenter ! Merci !

Et bonne musique à toi maintenant cool

dede utilisateur non connecté
De rien, j'ai tellement profité de ce site que je suis content d'apporter ma petite pierre.

En bref, pour faire fonctionner la MOTU624 sous Linux :

- à l'allumage du PC, la carte doit être éteinte et branchée sur un port USB2 (plantage sur USB3) et sur un port ethernet ;

- sous KXStudio, désactiver KMix qui va de toute façon planter ;

- allumer l'interface et attendre qu'elle soit initialisée pour ouvrir Cadence ;

- lancer le serveur Jack après l'avoir paramétré (choix de l'interface, nombre de canaux In et Out à zéro ;

- lancer le bridge PulseAudio si nécessaire (j'en ai besoin pour avoir du son depuis mon navigateur) ;

- ouvrir un navigateur et entrer l'adresse IP de la MOTU624 (elle apparaît sur l'écran de l'interface après être entré dans le sous-menu Network). Assurez-vous que votre navigateur accepte les cookies.

- A priori, enjoy ! Je reviendrai vers vous quand j'aurais tenté deux trois enregistrements avec Ardour.

Sylv_01 utilisateur non connecté
Salut,
ça n'a rien à voir avec la musique, mais concernant ton pb avec Ethernet, j'avais eu la même mésaventure avec une caméra IP : pas moyen de me connecter dessus directement depuis le PC, ça ne fonctionnait qu'en intercalant un switch !
Je n'ai jamais compris pourquoi...
Mais ça, ça ne va pas beaucoup t'aider ! mrgreen

dede utilisateur non connecté
Oui, et c'est d'autant plus bizarre que le switch est inutile sous Windows...

technomagniaque utilisateur non connecté
Merci pour cette précieuse information tu vien de confirmer ce que je pensai motu a tout câblée en dure dans le fpga donc la seule façon de faire pour que sa performe est fe dédié la paire usb2 aux classe complient et de dedier les 2 pairs usb3 a leur pilote propriétaire a tu essayer de la branchée sur l'usb3 avec un fils usb2 pour bénéficié de la diminution considérable de latence que aporte le xhci je esitait entre la 624 et la ultralite avb donc je vait prendre la ultralite avb qui est comprimé pour bien marcher sur linux: https://motu.com/products/proaudio/ultralite-mk4

technomagniaque utilisateur non connecté
Pour ceux qui save pas comment sont fabriqués toute puce et cpu et auter composen électronique je vais traduire:

Quand je dit de brancher avec un fil usb2 je fais référence a un file usb d'imprimente

Et pour (xhci) ca veux dire (extensible contrôle interface), ces ce que les contrôleurs usb3 utilise pour parler avec l'ordinateur et le xhci est une petite révolution en terme de latence et de performance compater aux vieux langage de l'usb2 et il faux savoir que le classe complient de motu est optimisée pour xhci le problèmes vien de leurs protocoles propriétaires qui passe par les 2 paire de fils dédié aux vitesse usb3 du coup le kernel reçoit du maime identifiant usb deux protocoles totalement différent que il vas essayé de traiter comme du classe complient car sur l'usb2 motu se présente comme classe complient mais linux ne peux pas différencié les donner provenant de la parti usb2 de celle qui vient de la parti usb3 puisque il partage la même adresse resulta tout ce melange et da plante

dede utilisateur non connecté
Alors ton message tombe bien parce que j'allais justement réactiver ce fil. Profitant de l'achat d'un nouveau SSD, j'ai installé une Ubuntu Studio 19.04 qui tourne autour d'un noyau récent (5.x). Et cette fois la carte fonctionne en USB3. Suffit juste de la démarrer avant le PC. Pas encore testé de MAO avec, mais tout fonctionne out of the box, je suis bluffé. J'ai aussi testé la Librazik 2, mais malgré la récente MàJ, je n'ai pas réussi à installer les pilotes proprios pour ma NVidia, et la MOTU faisait planter le système en USB3. A priori, c'était donc un problème de noyau (KXStudio tourne sur des noyaux vieillissants 3.x).

Je ne gardais pas un bon souvenir d'Ubuntu Studio, mais cette mouture récente est bien partie pour me faire changer d'avis. Reste à tester Wine pour certaines applis audio... Je vous tiendrai au courant.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]


Mégaphone [Afficher / Cacher]

olinuxx, 21:54, dim. 15 Dec 2019: Bonjour et bienvenue à XavSub cool
olinuxx, 13:53, sam. 14 Dec 2019: Bonjour et bienvenue à Huberts cool
olinuxx, 13:53, ven. 13 Dec 2019: Bonjour et bienvenue à Phidel cool
sub26nico, 11:59, jeu. 12 Dec 2019: Salut et bienvenue à DANTES :-)
sub26nico, 10:09, mar. 10 Dec 2019: Salut et bienvenue à milor et romger49 :-)
syberia303, 22:23, jeu. 05 Dec 2019: Sitala: une boîte à rythmes lecteur d'échantillons disponible au format vst ou en programme autonome:[Lien]
allany, 20:29, jeu. 05 Dec 2019: Coco, il est là l'édito ! [Lien]
sub26nico, 23:17, mer. 04 Dec 2019: Salut et bienvenue à Olivier212, MusoCompoSon, TroupeV et Fred71 :-)
olinuxx, 13:38, dim. 01 Dec 2019: Bonjour et bienvenue à FIFI71 cool
r1, 09:20, sam. 30 Nov 2019: @sasaki : dans le cas de mon album, cela veut dire trésor. Un clin d'œil à mes princesses dont la maman est chinoise.
Sasaki, 14:50, ven. 29 Nov 2019: @olinuxx : Bao Bao peut signifier en mandarin : - mon coeur/mon chéri/mon trésor/ma puce (宝宝) ou bien - tempête de grêle !(雹暴)
olinuxx, 14:27, jeu. 28 Nov 2019: Bonjour et bienvenue à LarryV cool