Forum : 9 - Synthèse sonore et Banques de sons

Swami sous Kubuntu 18.04 [CONTOURNÉ]

fabR utilisateur non connecté France
Bonjour
Depuis de nombreuses versions d'ubuntu j'utilise swami sans problème.
Je viens d'installer Kubuntu 18.04 et lorsque je veux lance swami (en console pour identifier le problème) 'j'ai le message suivant:
libswami-Message: 16:55:22.803: Loading plugins from /usr/lib/swami
libswami-Message: 16:55:22.807: Loaded 4 plugins
Erreur de segmentation (core dumped)


Avec la commande swami -p (sans les plugins) le programme se lance mais pas de communication audio ou midi sous QjackCtl

Avez vous une idée sur cette erreur de segmentation et d’où cela pourrait bien provenir?
Je précise que les autres applications comme Qsynth, ZynAddSubFx, Rosegarden fonctionnent très bien.

Nota:Idem avec la dernière version de la distribution Neon

olinuxx utilisateur non connecté France
Swami est connu pour être défaillant sur les dernières versions d'ubuntu et de debian. Il y a des rustines qui traînent pour celles et ceux qui souhaitent quand même l'utiliser.

Sinon, en fonction de ton utilisation de swami, peut être que petri-foo ou polyphone peuvent être de bonnes alternatives. À noter que polyphone est activement développé contrairement au 2 autres.

Note de modération : j'ai édité ton message pour le rendre plus lisible.

Note modération : merci d'utiliser la balise CODE lorsque tu copies/colles du code sur le site. Celles-ci permettent un meilleur affichage.
Image
Voir également cette page.


fabR utilisateur non connecté France
Ok,
J'utiliserai les balises code une prochaine fois.
J'utilise swami pour créer mes propres soundfonts.
J'ai bien vu qu'il existait polyphone, mais pour l'instant il n'est pas supporté par ma distribution Néon basée sur ubuntu 18.04.
Je vais patienter.
Merci.

olinuxx utilisateur non connecté France
Bonjour fabR.

Pour info, j'ai vu qu'il y avait une version 2.0 de polyphone en préparation ces temps-ci (2.0-beta). Ça me paraît être un très bon moment pour aller demander gentiment dans le forum officiel de polyphone de fabriquer des paquets pour ubuntu 18.04 .

olinuxx utilisateur non connecté France
Super, tu nous diras si ça correspond à ton besoin ici.

sub26nico utilisateur non connecté France
Du nouveau ici fabR ?

fabR utilisateur non connecté France
Salut,
J'utilise maintenant polyphone 2.0 et cela me convient.
Pas de difficulté particulière.

sub26nico utilisateur non connecté France
Chouette que tu aies trouvé une autre solution. Tu nous rajoutes un [Abandonné] ou un [Contourné] dans le titre stp ?
Note modération : le sujet étant résolu, merci d'ajouter un [RÉSOLU] (ou un [CONTOURNÉ], ou bien encore un [ABANDONNÉ]) dans le titre de ton premier message. Voir ce paragraphe du manuel du site pour davantage d'informations.