Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

> Forums de discussion > 5 - Les serveurs son : Jack, PulseAudio et autres... > [RESOLU] Problème de sortie du son Jack
Dernier post

[RESOLU] Problème de sortie du son Jack

Asdipeck utilisateur non connecté
Bonjour,
J'ai branché ma carte son U-PHORIA UM2 sur mon pc afin d'utiliser un clavier sur LMMS.
Le problème c'est que je n'ai aucune sortie de son dans mes hauts-parleurs... j'ai beau éplucher les sujets du forum je pense que je suis passé a côté de quelque chose.

-> Mon clavier marche, puisque je reçoit un signal dans LMMS
-> J'ai effectuer le bridge pulsaudio

Voici des captures d'écran de mes connexions jack:
Image

et de mes paramètres:
Image
Image

enfin voici les 3 codes conseillé par le forum (dans l'ordre):
:
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xdf220000 irq 129
 1 [CODEC          ]: USB-Audio - USB Audio CODEC
                      Burr-Brown from TI USB Audio CODEC at usb-0000:00:14.0-6, full speed
 2 [M25            ]: USB-Audio - Samson Graphite M25
                      Samson Samson Graphite M25 at usb-0000:00:14.0-1, full speed


ensuite

audio.conf  audio.conf.sauve


enfin
[Defaults]
ConnectionsTabPage=0
MessagesStatusTabPage=0
PatchbayPath=
SessionSaveVersion=true

[Geometry]
qjackctlConnectionsForm\geometry=@ByteArray(\x1\xd9\xd0\xcb\0\x2\0\0\0\0\0\x41\0\0\x1\xf\0\0\x2\xeb\0\0\x2'\0\0\0\x41\0\0\x1\xf\0\0\x2\xeb\0\0\x2'\0\0\0\0\0\0\0\0\a\x80)
qjackctlConnectionsForm\visible=false
qjackctlMainForm\geometry=@ByteArray(\x1\xd9\xd0\xcb\0\x2\0\0\0\0\0?\0\0\0v\0\0\x2j\0\0\0\xf5\0\0\0?\0\0\0\x92\0\0\x2j\0\0\0\xf5\0\0\0\0\0\0\0\0\a\x80)
qjackctlMainForm\visible=true
qjackctlMessagesStatusForm\geometry=@ByteArray(\x1\xd9\xd0\xcb\0\x2\0\0\0\0\0?\0\0\0\x18\0\0\x2r\0\0\x1(\0\0\0?\0\0\0\x18\0\0\x2r\0\0\x1(\0\0\0\0\0\0\0\0\a\x80)
qjackctlMessagesStatusForm\visible=false
qjackctlPatchbayForm\geometry=@ByteArray(\x1\xd9\xd0\xcb\0\x2\0\0\0\0\0?\0\0\0\x18\0\0\x3\x85\0\0\x1`\0\0\0?\0\0\0\x18\0\0\x3\x85\0\0\x1`\0\0\0\0\0\0\0\0\a\x80)
qjackctlPatchbayForm\visible=false
qjackctlSessionForm\geometry=@ByteArray(\x1\xd9\xd0\xcb\0\x2\0\0\0\0\0?\0\0\0\x18\0\0\x2\xdd\0\0\x1\xbe\0\0\0?\0\0\0\x18\0\0\x2\xdd\0\0\x1\xbe\0\0\0\0\0\0\0\0\a\x80)
qjackctlSessionForm\visible=false

[History]
MessagesLogPathComboBox\Item1=qjackctl.log
ServerConfigNameComboBox\Item1=.jackdrc
ServerNameComboBox\Item1=(par d\xe9\x66\x61ut)
ServerPrefixComboBox\Item1=/usr/bin/jackd
ServerPrefixComboBox\Item2=jackd
ServerPrefixComboBox\Item3=jackdmp
ServerPrefixComboBox\Item4=jackstart
StartupScriptShellComboBox\Item1=/home/ossian/script/jack_startup
XrunRegexComboBox\Item1=xrun of at least ([0-9|\\.]+) msecs
XrunRegexComboBox\Item2=d\xe9synchronisation (XRUN) d'au moins ([0-9|\\.]+) ms

[Options]
ActivePatchbay=false
ActivePatchbayPath=
ActivePatchbayReset=false
AliasesEditing=false
AliasesEnabled=false
AlsaSeqEnabled=true
BaseFontSize=0
BezierLines=false
ConnectionsFont="Ubuntu,11,-1,5,50,0,0,0,0,0"
ConnectionsIconSize=0
DBusEnabled=true
DisplayBlink=true
DisplayEffect=true
DisplayFont1="Ubuntu,14,-1,5,75,0,0,0,0,0"
DisplayFont2="Ubuntu,8,-1,5,50,0,0,0,0,0"
JackClientPortAlias=0
JackClientPortMetadata=false
JackDBusEnabled=true
KeepOnTop=false
LeftButtons=true
MessagesFont="Ubuntu,11,-1,5,50,0,0,0,0,0"
MessagesLimit=true
MessagesLimitLines=1000
MessagesLog=false
MessagesLogPath=qjackctl.log
PostShutdownScript=false
PostShutdownScriptShell=
PostStartupScript=false
PostStartupScriptShell=
QueryClose=true
QueryDisconnect=true
QueryShutdown=true
RightButtons=true
ServerConfig=true
ServerConfigName=.jackdrc
ServerConfigTemp=false
ShutdownScript=false
ShutdownScriptShell=
Singleton=true
StartJack=false
StartupScript=true
StartupScriptShell=/home/ossian/script/jack_startup
StdoutCapture=true
StopJack=true
SystemTray=false
SystemTrayQueryClose=true
TextLabels=true
TimeDisplay=0
TimeFormat=0
TransportButtons=true
XrunRegex=xrun of at least ([0-9|\\.]+) msecs

[Presets]
DefPreset=(par d\xe9\x66\x61ut)

[Program]
Version=0.4.2

[Settings]
Audio=0
Chan=0
Dither=0
Driver=alsa
Frames=1024
HWMeter=false
HWMon=false
IgnoreHW=false
InChannels=0
InDevice=
InLatency=0
Interface=
MidiDriver=aucun
Monitor=false
NoMemLock=false
OutChannels=0
OutDevice=
OutLatency=0
Periods=2
PortMax=256
Priority=5
Realtime=true
SampleRate=44100
Server=/usr/bin/jackd
ServerName=
ServerSuffix=
Shorts=false
SoftMode=false
StartDelay=2
Timeout=500
UnlockMem=false
Verbose=false
Wait=21333
WordLength=16

[Splitter]
AlsaConnectView\sizes=38, 20, 38
AudioConnectView\sizes=269, 90, 269
InfraClientSplitter\sizes=12, 12
MidiConnectView\sizes=38, 20, 38
PatchbayView\sizes=38, 20, 38


Voila, j’espère que c'était suffisamment claire, merci de votre attention!

jujudusud utilisateur non connecté France
Bonjour Asdipeck,

Je récapitule :

- Distribution Ubuntu
- Clavier Samson Graphite M25 Mini USB MIDI Controller
- Interface audio Behringer U-PHORIA UM2 2x2 USB
- Qjackctl - Alsa - Jack - Pulseaudio - Pont Pulseaudio Jack
- LMMS

Le clavier MIDI à l'air d'être bien reconnu.
L'interface audio aussi.

Ton interface audio est bien branchée sur un amplificateur et des enceintes ?
Ta configuration de Qjackctl montre que tu utilises le périphérique sont "par défaut", Est ce que l'interface audio Berhinger est bien la carte "par défaut" ? Si ce n'est pas le cas, il faut configurer Qjackctl sur l'interface audio.

Ton message est très clair et très agréable à lire.
J'attend ton retour pour avancer tranquillement avec toi.

Asdipeck utilisateur non connecté
Alors c'est bien ça (ubuntu 16.04 LTS)

Je pense que mon interface audio n'as pas besoin d'ampli puisqu'elle contient un "pré-ampli" (il y a d'ailleurs une alimentation fantôme 48v je crois que c'est en rapport), donc non pas d'ampli, ni d'enceinte d'ailleurs j'aurais aimé utiliser dans un premier temps les hauts parleurs internes de mon ordinateur portable.
Je pose ça la au cas où:
Image
Image

Concernant Qjackctl je n'ai aucune idée de quelle est ma carte par défault (puisque j'ai une carte son integrer ce serait plutôt celle là?)
Donc pour la configuration j'ai deux possibilité dans chacun des menus Entrée/Sortie et du menu interface (deux qui portent le nom de ma carte CODEC): "hw:CODEC,0" et "hw:CODEC" je les ait tout les deux essayer sans succès.

Merci d'avoir repondu si vite en tout cas.

jujudusud utilisateur non connecté France
Ta carte son interne de ton PC n'est pas prévue pour traiter du son avec une faible latence, elle va donc induire un retard significatif dans la retranscription de ton son et ne va pas te permettre de jouer "en direct".

Donc il faut que tu utilises la carte son externe et que tu configures Qjackctl sur l'option qui porte le nom de ta carte externe (CODEC).

une fois que le son sort du PC par le port USB et qu'il arrive dans la carte externe, il va tenter de sortir par les sorties physique de la carte externe (à l'arrière de la carte ou si elle existe la sortie casque ...).
Pour cela il faut donc que tu relis les sorties (gauche et droite) de ta carte externe avec un ampli et des enceintes ou alors des enceintes amplifiées (aussi appelées monitoring).
Sans cela le son ne sort jamais de ta carte externe et tu n'entends rien.

Si tu veux tester dans un premier temps, débranches la carte externe et configures Qjackctl sur la carte son interne.

Tu devrais entendre le son sortir des hauts parleurs internes.

Asdipeck utilisateur non connecté
Ah d'accord j'y ai pensé un moment mais j'ai pas creuser beaucoup vu que j'avais vu des vidéo de teste ou le type en question branchait seulement son micro et le cable usb... J'aurais du lire plus attentivement le tuto

J'ai retiré ma carte son externe (lmms est toujours configurer sur jack) et j'ai du son (en plus j'ai trouvé un moyen plus simple de brancher mon clavier qui n'avait de toute façon rien à voire avec tout ça)

Mais donc en gros mon "montage" est bon? Si je branche mon casque (je retrouve pas mon adaptateur c'est pour ça que je fait sans) ça devrait marcher?

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 20:37, mer. 04 Aug 2021: Bonjour et bienvenue à PianoOrgan3478 cool
sub26nico, 16:00, mer. 04 Aug 2021: Bonjour et bienvenue à EricV86, smith8395john, alinabeth et leowilson :-)
sub26nico, 13:05, lun. 02 Aug 2021: @CyrilRos, ton lien ci-bas ne fonctionne pas
CyrilRos, 22:59, dim. 01 Aug 2021: Tux|N|Mix 21.1 disponible [Lien]
sub26nico, 14:33, dim. 01 Aug 2021: Salut et bienvenue à Youplala, Cant' et Bluetak :-)
CyrilRos, 21:45, mar. 27 Jul 2021: [Lien]
olinuxx, 20:54, mar. 27 Jul 2021: Bonjour et bienvenue à nick cool
olinuxx, 20:47, dim. 25 Jul 2021: Bonjour et bienvenue à GrosRems et à paulisaak cool
olinuxx, 20:05, jeu. 22 Jul 2021: Bonjour et bienvenue à labeyte07 cool
olinuxx, 21:03, mar. 20 Jul 2021: Bonjour et bienvenue à tv cool
Nolwen, 19:33, lun. 19 Jul 2021: Hola,À propos de la création de pattern (motifs) MIDI pour batterie, quelqu'un sait-il où en est la discussion ?
olinuxx, 01:28, lun. 19 Jul 2021: Lolo-Rosso : l'adresse courriel que tu as renseignée lors de ton inscription n'est pas fonctionnelle. Contacte moi pour corriger le soucis : [Lien]