Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

> Forums de discussion > 5 - Les serveurs son : Jack, PulseAudio et autres... > [RÉSOLU] Charger une config jack_mixer au lancement d'un studio Claudia
Dernier post

[RÉSOLU] Charger une config jack_mixer au lancement d'un studio Claudia

sibfactory utilisateur non connecté
Bonjour,

J'aimerais charger une config perso de jack_mixer au chargement d'un studio Claudia.

Je ne vois pas quelle commande insérer dans le lanceur personnalisé question :/

Lorsque je lance la commande "man jack_mixer" j'ai :
-c CONFIG, --config=CONFIG
use a non default configuration file

J'ai essayé avec :
jack_mixer --config=CONFIG /home/user/Music/mon_fichier

ca ne fonctionne pas, ça ne doit pas être la bonne :P

aletheia utilisateur non connecté France
Bonjour

la commande c'est :

jack_mixer -c /home/user/Music/mon_fichier

Cordialement

sibfactory utilisateur non connecté
aletheia écrit :
la commande c'est :

jack_mixer -c /home/user/Music/mon_fichier


j'avais bien testé cette commande mais ça ne fonctionne pas :/ j'ai un message d'erreur

Image


idem cadence-pulse2jack ne lance pas automatiquement au démarrage il faut que je fasse clique droit-> demarrer une fois le studio lancé...

aletheia utilisateur non connecté France
Ça fonctionne pourtant très bien chez moi.
Cordialement

sibfactory utilisateur non connecté
ah mince grrr

Le fichier de config de jack_mixer a une extension ?

"normalement" la commande "cadence-pulse2jack" sur un lanceur personnalisé, devrait lancer le pont Pulse Audio tout seul ?

car dans mon cas, je dois le démarrer une fois le studio lancé en faisant clic droit-> démarrer

je ne sais pas si c'est lié :/

olinuxx utilisateur non connecté France
Quelle est la commande exacte que tu mets dans claudia ?

sibfactory utilisateur non connecté
Pour lancer Pulse => Lanceur personnalisé avec
cadence-pulse2jack


et pour jack_mixer =>
jack_mixer -c  /home/USER/Music/Studios/custom_jack_mixer


aletheia utilisateur non connecté France
est-ce que jack est actif au moment de l'appel à ton script jack_mixer? Dans le cas contraire, pas de jack_mixer.

olinuxx utilisateur non connecté France
"USER" -> à remplacer par un nom réel d'utilisateur

sibfactory utilisateur non connecté
olinuxx écrit :
"USER" - à remplacer par un nom réel d'utilisateur


bien évidemment wink

sibfactory utilisateur non connecté
Voici les logs lorsque j'essaie de lancer jack_mixer

Tue Oct 22 16:27:34 2019: New client 'jack_mixer' with PID 1942
Tue Oct 22 16:27:34 2019: ERROR: JackEngine::XRun: client = jack_mixer was not finished, state = Triggered
Tue Oct 22 16:27:34 2019: ERROR: JackAudioDriver::ProcessGraphAsyncMaster: Process error
Tue Oct 22 16:27:34 2019: ERROR: Failed to find port 'jack_mixer:midi in' to destroy
Tue Oct 22 16:27:34 2019: ERROR: Failed to find port 'jack_mixer:MAIN L' to destroy
Tue Oct 22 16:27:34 2019: ERROR: Failed to find port 'jack_mixer:MAIN R' to destroy
Tue Oct 22 16:27:34 2019: ERROR: Failed to find port 'jack_mixer:midi out' to destroy
Tue Oct 22 16:27:34 2019: ERROR: Failed to find port 'jack_mixer:Monitor L' to destroy
Tue Oct 22 16:27:34 2019: ERROR: Failed to find port 'jack_mixer:Monitor R' to destroy
Tue Oct 22 16:27:34 2019: Client 'jack_mixer' with PID 1942 is out
Tue Oct 22 16:27:34 2019: ERROR: cannot find client 13


sibfactory utilisateur non connecté
J'ai tout repris le studio de zéro, jack_mixer lance bien mon fichier de config au démarrage du studio, chouette ! :-)

Je ne vois pas ce qui plantait dans l'autre :/


Reste cadence-pulse2jack qui ne veut toujours pas se lancer au démarrage du studio, je dois le faire manuellement (clic droit -> Démarrer)...

Une idée pour ça ?

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 09:25, mar. 15 Jun 2021: Bonjour et bienvenue à Hexaal :-)
Ubuntu_Studio_User, 02:29, lun. 14 Jun 2021: Salut à tous...
allany, 12:12, sam. 12 Jun 2021: @tourneriff : merci pour le signalement, c'est fait !
tourneriff, 07:52, sam. 12 Jun 2021: Bonjour à tous ☺ ! Avis aux modos : pourrait-on voir la "joute 16" en cours à l'accueil du site plutôt que l'antique "joute 15"
sub26nico, 14:56, jeu. 10 Jun 2021: Salut et bienvenue à jamesonmount, freerawsound et Loop :-)
ycollet, 10:28, mer. 09 Jun 2021: Cool, un revival de rakarrak ! [Lien]
sub26nico, 22:08, lun. 07 Jun 2021: Bonjour et bienvenue à ArchLinux59, Djobi et gakgakgak :-)
olof, 09:27, lun. 07 Jun 2021: ardour 6.7 build tourne chez moi, mais pas le package 6.6
allany, 14:46, dim. 06 Jun 2021: @r1 : t'as raison : trop c'est trop, ça sature du goulot !
r1, 22:54, sam. 05 Jun 2021: Mon cerveau a bobo à force de faire le gogo sur l'annonce de l'édito !
allany, 11:49, sam. 05 Jun 2021: Z'ont encore abattu un sacré boulot, les poulbots de l'édito ! [Lien]
ycollet, 20:37, ven. 04 Jun 2021: Un article intéressant sur un truc à venir sur USB audio: [Lien]