Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

4 - Techniques et manipulations du son

> Forums de discussion > 4 - Techniques et manipulations du son > [Résolu] Mesurer la latence de l'ampli guitare connecté en USB-Audio
Dernier post

[Résolu] Mesurer la latence de l'ampli guitare connecté en USB-Audio

Dens1 utilisateur non connecté France
Bonjour,

je me demande comment je peux mesurer la latence de l'ampli (pour rappel Mustang 1, Fender) connecté au port USB, capturé dans capturé dans capture system.
Il fonctionne un peu comme une carte son, définie comme Hw:Amplifier,0 dans les réglages Jack rubrique périphérique d'entrée.

je lance jdelay, ou plutôt jack_iodelay en console.
je connecte comme indiqué jdelay et je bute sur :
Citation :
ensuite connectez physiquement l'entrée et la sortie de votre carte son ensemble, avec un vrai câble cette fois-ci !

Si c'est dire le fil usb de l'ampli à l'ordi, c'est branché. Si par contre l'ordre de branchement à son importance (celui ci en dernier) je peux pas, débrancher l'ampli me fait buguer jack dbus si je fais à l'arrache. Et si pas connecté je connecte l'ampli jack ne le vois pas sans devoir d'abord le redémarrer. Du coup le serpent qui se mord la queue. mrgreen

ps: simple curiosité de ma part, la latence affichée dans les réglages jack étant purement indicative, je voulais voir plus précisément l'ampli.

tenryu utilisateur non connecté France
Bonjour,
Si j'ai bien compris de quoi il s'agit, il faudrait que tu branches la sortie line ( si tu en as une) de ton ampli directement dans l'entrée jack de ton ampli. Cela nécessite de débrancher le haut parleur ( ce qui ne plaira pas à ton ampli surtout s'il est à lampe), sinon gare au larsen. Peut être tu peux essayer d'utiliser la sortie casque ( encore une fois si tu en a une), qui normalement désactive le haut parleur. Je ne sais pas si j'ai répondu à ta question.

Dens1 utilisateur non connecté France
bonjour,
j'ai aussi 2 prise mini jack "aux" et "phones". C'est ces eux que je dois connectés l'une à l'autre ?
Débrancher le HP ? heu, peut-être qu'il suffit du Master à 0 plutôt ?
Merci.

jujudusud utilisateur non connecté France
Non,

Il faut que le son envoyé par le PC et qui donc va sortir par le port usb et rejoindre l'ampli et aller voir le haut parleur soit réinjecté dans l'entree de l'ampli pour pouvoir rejoindre le PC par le port usb.

le logiciel sert à mesurer le temps que met le son pour parcourir ce chemin qui est appelé latence.

avec une carte son, c'est possible car il y a une sortie qu'on peut relier à une entrée, physiquement avec un vrai cable.

Sur ton ampli je ne sais pas.

Est ce que tu comprends le principe ?

Dens1 utilisateur non connecté France
Salut Juju,

oui, c'est donc la sortie casque (de la carte son intégrée de l'ordi) que je dois brancher sur mon entrée "aux" avec un simple jack mâle-mâle 3.5 mm, Exact ? Reste à trouver ce câble, j'en ai rarement vu mais ça doit exister si je l'ai imaginé lol.

jujudusud utilisateur non connecté France
Non,

Si tu passes par la carte son intégrée à ton ordinateur, tu prends en compte sa latence et pas celle de l'ampli guitare.

Tu peux quand même essayer et voir ce que ça donne.

Pour info, ton ampli possède-t-il une sortie ligne située après le retour du son traité par le pc ? Comme sur une interface audio USB classique ?
Je ne crois pas car il ne me semble pas que le son traité par le pc puisse être diffusé par l'ampli. Il n'y a que "capture" qui s'active et pas de "playback" ? Non ?

Dens1 utilisateur non connecté France
capture et playback de l'ordi ? oui. Par contre je te rappelle que l'ampli n'est pas visualisé dans le graphe Claudia, je le récupère dans capture (de system donc) et je l'envoie dans playback (de system).
Mais cette entrée jack 3.5 mini nommée AUX de l'ampli, c'est bien pour envoyé du son dans le HP de l'ampli non ? Le mustang c'est simple, j'ai 4 entrées:
- le jack de la gratte
- le FTSW de la pédale de switch
- une mini entrée AUX
- une mini entrée PHONES
basta.
+ le mini USB en sortie que je vais connecter à l'ordi.
Je vois pas trop comment faire donc. Mais c'est simple curiosité, je vis très bien sans la mesurer lol.

Dens1 utilisateur non connecté France
Citation :
Pour info, ton ampli possède-t-il une sortie ligne située après le retour du son traité par le pc ? Comme sur une interface audio USB classique ?

De fait je crois pas, note que j'ai encore jamais vu ou manipulé une interface audio usb classique (table de mix, carte son) lol

jujudusud utilisateur non connecté France
Si tu mets un greffon entre capture et playback est ce que tu l'entends dans le haut parleur de l'ampli guitare ?

Pour essayer, tu peux mettre un son clair sans effets sur l'ampli et dans le pc un delay ou une reverb. Comme ça tu sauras si le son est traité par l'ordinateur ou si l'USB ne sert qu'à faire l'acquisition du son.
Deuxième test, si le premier est concluant, tu branches le casque sur l'ampli et tu écoutes pour savoir si le son traité par le pc sort aussi au casque.

Si les deux tests sont concluants, tu reconnectes tout comme dans l'article qui explique comment mesurer la latence et tu branches physiquement la sortie casque et l'entrée guitare.

Dens1 utilisateur non connecté France
Citation :
Si tu mets un greffon entre capture et playback est ce que tu l'entends dans le haut parleur de l'ampli guitare ?

Houla j'ai même jamais pensé ça possible, je te dis ça de suite, donc: je mets un flanger ardour, je coupe le volume system et monte le master de l'ampli, pour voir si j'entends le flanger ? je fais ça mais carrément ça m'étonnerait.
Citation :
Si les deux tests sont concluants, tu reconnectes tout comme dans l'article qui explique comment mesurer la latence et tu branches physiquement la sortie casque et l'entrée guitare.

Heu ça attend c'est pas possible, avec quoi comme fil, PHONES c'est du 3.5 ou 2.5 mm et le jack guitare c'est du jack guitare ... et pour entendre quoi si ya plus de guitare branchée ? un son qui viendrait de l'ordi ? (j'ai le bulbe en surchauffe).

Dens1 utilisateur non connecté France
Non ça marche pas et c'est normale je vois pas comment ça pourrait marcher vu l'ordi en sortie est connecté à l'entrée de l'ampli hifi seulement, et non du mustang (avec un mini jack / et un cable video rouge-jaune-blanc qui me sert d'audio). mrgreen
Laisse tomber juju merci (à moins que tu me dises qu'il me faut tel câble pour pouvoir tester).

jujudusud utilisateur non connecté France
Il n'y a pas de "playback" sur l'ampli mustang ?
Regarde si tu peux, dans les réglages de jack, connecter le mustang en sortie en plus de l'entrée.

Dens1 utilisateur non connecté France
No, il n'apparaît jamais dans les périphériques de sorties proposés (QjackCtl ou Cadence). Seulement en périph d'entrée, HW:Amplifier,0
rolleyes

jujudusud utilisateur non connecté France
Ok. Tu peux donc clore ce fil de discussion avec pour conclusion qu'il n'est pas possible de mesurer la latence avec les moyens actuels.

Dens1 utilisateur non connecté France
Ok. Sauf que je serais pas moi-même si je faisais ça lol mrgreen
C'est pas pour chercher la p'tite bête, mais juste: mes moyens actuels (câblage), ceux de Jack, ou de par les caractéristiques du mustang ??
Merci, après je clos twisted

jujudusud utilisateur non connecté France
C'est ce que je te dis plus haut.
Le mustang n'a pas de "playback".

Pour faire une mesure quand même, tu dois relier avec un câble physique :

La sortie son sur ton pc -> l'entrée guitare de l'ampli

Ensuite tu lances la procédure décrite sur Linuxmao.

Dens1 utilisateur non connecté France
jujudusud écrit :
Pour faire une mesure quand même, tu dois relier avec un câble physique :
La sortie son sur ton pc - l'entrée guitare de l'ampli

Et que, dans le même temps, j'ai aussi la guitare branchée à l'ampli lui-même branché à l'ordi, c'est exact ? SINON, ça doit se trouver un Câble Audio Jack 3.5mm vers 6.35mm (sortie ordi -> entrée du jack guitare de l'ampli) ?
Quoiqu'il en soit, je clos biggrin

jujudusud utilisateur non connecté France
Mais non, tu debranches la guitare pour faire ça puisque c'est le logiciel qui envoi le son à l'ampli et regarde combien de temps met le son pour revenir.

Dens1 utilisateur non connecté France
ha le logiciel envoie du son en fait, je pensais qu'il mesurait juste un son qui passait par là, ok. DONC, il me faut le jack du SINON (?) ...

jujudusud utilisateur non connecté France
C'est ce qui est écrit dans le lien vers jdelay que tu as proposé dans ton fil de discussion dans le premier message.

Il te faudra surement un adaptateur pour brancher la sortie stéréo 3,5" du pc dans l'entrée 6,35 mono de l'ampli. Ou bien deux fils volants avec des pinces croco. Par exemple...

Dens1 utilisateur non connecté France
Ah ouaih okay, là c'est limpide merci juju ;-)

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

allany, 19:56, dim. 05 Apr 2020: :-D
r1, 19:56, dim. 05 Apr 2020: @allany : ouais !!! c'est noël ! Quelle équipe hallucinante ! :-D
allany, 19:28, dim. 05 Apr 2020: L'édito, c'est le bon topo, les cocos ! [Lien]
olinuxx, 21:36, mer. 01 Apr 2020: Bonjour et bienvenue à simon_martineau, martineau_simon, et à Roland57 cool
olinuxx, 20:13, mar. 31 mars 2020: Bonjour et bienvenue à sethi1cool
Nolwen, 22:46, lun. 30 mars 2020: Sortie d'Hydrogen 1.0.0-beta 2 ce 30 mars 2020. [Lien]
olinuxx, 17:39, lun. 30 mars 2020: Bonjour et bienvenue à JulienRadio cool
sub26nico, 23:48, dim. 29 mars 2020: Salut et bienvenue à Chihiro49130, Gigi, Ptilou, yudas, FF63, mimifloch, mvvl et tophque :-)
malt, 15:55, dim. 29 mars 2020: @Sahaathyva. Je n'avais pas vu ton post!
malt, 15:51, dim. 29 mars 2020: Ardour 6.0-pre1: [Lien]
sub26nico, 20:50, ven. 27 mars 2020: Salut et bienvenue à Topyweb, Serge Samson, ChtiJeff, Zeplead et Zonzon :-)
r1, 20:27, ven. 27 mars 2020: La joute 15 est sur les rails ! [Lien] Viendez jouer avec nous !!!