Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

4 - Toutes les autres applications, les émulateurs...

> Forums de discussion > 4 - Toutes les autres applications, les émulateurs... > muse rosegarden pb de synchro et vilains crashs
Dernier post

muse rosegarden pb de synchro et vilains crashs

lukool Articles : 91 utilisateur non connecté
salut tout le monde !!

alors voila mon problème du jour !

impossible de bosser correctement avec muse et rosegarden sans qu'ils plantent misérablement.

ce que je cherche à faire et pourtant très simple :

je lis une séquence midi dans le sequenceur, je mute toutes les pistes sauf ma piste batteire.
je patche ma batterie dans hydrogen de manière à m'en servir comme instru batterie.
et je connecte les sorties d'hydrogen dans ardour pour un éventuel enregistrement si seulement j'arrivais jusque là :-)

ce qui ce passe :
la synchro midi est vite perdue et muse ou rosegarden finissent par s'arreter voire crasher et disparaitre de l'écran quand ce n'est pas l'envoi midi qui est stoppé.

Muse est d'autre part une vraie calamité à faire focntionner. SI je commence une séquence midi, je demarre fluidsynth je charge une soundfont et là ou ca plante des que je fais play ou le tempo par en vrille et ca finir par un beau crash.

bref c'est la mermerde quand même. d'autant que je me souviens avoir réussi ce genre de choses avec une demudi sur un vieu P2 450.

Ma config est la suivante :

P4 2.4Ghz
512 M RAM
1 DD 20 Go pour l'OS
1 DD 80 Go pour l'audio
Carte son echo gina3G
Fedora Core 4
Planet ccrmùa pour le noyau patché et les apps

Peut-être que passer la ram à 1Go pourrait aider un peu je ne sais pas
Sinon ne serait-il pas plus judicieux de couper mon dd en deux et d'un coté garder une fedora propre et de l'autre installer une demudi ??

lukool Articles : 91 utilisateur non connecté
en même temps si je passe sur un système avec deux os ça risque de franchement me gonfler de rebooter pour faire de la zik. C'était déjà en partie pour ça que j'avais finit par zappé complètement windows.

je vais donc prendre en considération ubuntu studio dans ce cas. mais une question reste en suspend :

ma gina sera t-elle supportée ?? alsa ne la voit pas quand je teste avec le livecd breezy ?

Hermes_le_Messager Articles : 101 utilisateur non connecté Allemagne
Dans rosegarden, dans Configurer Rosegarden à l'onglet syncronisation, tu as quoi ? system timer ? Tu as la possibilité d'utiliser l'horloge midi de ta carte ?

De plus, as-tu la patch low latency avec les logiciels audio qui ont la priorité sur les autres process ? :o

Bref, il manque bcp de renseignements...

Sache que de toutes manières, un système musical linux qui tourne parfaitement, est un système compilé de a à z, surtout concernant les softs audio, à la fois pour avoir les toutes dernières versions, mais aussi pour avoir toutes les options...

Donc peu importe la distrib. J'ai opté pour ubuntu car la base est très stable (repose sur du debian) et les paquets de dev sont à jour et ne posent pas de problème.

Norrin_Radd Articles : 960 utilisateur non connecté France
lukool, tu parles de synchro midi, enfait ces applications se synchronisent avec jack.

Perso je n'utilise pas Rosegarden, d'ailleurs je me demande bien ce que vous lui trouvez. :-)
Faut croire que personne n'arrive à faire fonctionner Muse dans de bonnes conditions, et c'est vrai que ca peut demander quelques moments d'attention.

Pour ma part j'utilise (et encore aujourd'hui) Ardour+Muse+PureData en meme temps a 128 de buffer (3 frames) soit environ 8 ms de latency..

Et pour cela c'est vrai que j'ai une relativement belle config. (dual athlon 2ghz) et 768 meg de ram.

MusE est connu pour crasher lametablement, avec des latences trop basses.
En ce qui me concerne j'ai du fine tuner la latence des cartes PCI avec ces instructions:

setpci -v -s '*:*' latency_timer=20
setpci -v -s '0:0' latency_timer=0
setpci -v -s '00:09.0' latency_timer=FF

Tu peux essayer chez toi, si tu veux, ca peut aider.
Change juste 00.09.0 par le numero de carte son (obtenu avec lspci)

Sache aussi que la version Muse 0.7pre5 est sensé etre plus conciliante au niveau des crashs. Je te conseilles de mettre à jour si c possible.

Une nvelle version la derniere avant la 1.0 va sortir bientot aussi..

Tu peux aussi regarder si tes disques durs sont bien réglés et tu peux augmenter ta latence dans qjackctl.

Combien as tu en latence pour le moment ?




lukool Articles : 91 utilisateur non connecté
je vasi explorer la piste de la latence trop faible, la je suis à 2.1 ms, je vasi d'abord voir en changeant le buffer pour passer à 10 ou 12 ms.

pour répondre à hermes, j'ai simplifier mon install en choisissant planet ccrma et fais 2 gros apt-get, le premier pour le noyau basse latence et ensuite pour les apps.
Par contre,je me place plutot du coté utilisateur et non technicien, je ne sais donc pas vraiment comment configurer les priorité des apps les unes par rapport aux autres.

sinon autre petite chose, j'ai eu l'occasion de discuter avec qqn qui était en FC4 et avait aopté pour ccrma depuis déjà la FC1. Il m'a dit que pour la musique il avait préféré resté en fc3 car pour la 4 il n'avait eu que des problèmes. A l'heure actuelle tout n'est pas encore recompilé pour fc4 et certaines compils sont foireuses selon les configs.

Et pour avoir vu sa config tourner en fc3 + ccrma j'ai pu noter une grosse différence avec la mienne.


lukool Articles : 91 utilisateur non connecté
merci Norrin !

en augmentant la latence, j'arrive à avoir un flux midi constant. reste que Muse plante encore et toujours. Après différents tests, j'ai l'impression que c'est l'interface qui pose problème :

je lance la lecture d'un fichier midi, ca lit correctement, je click su rune piste pour changer un canal midi ou une barre de défilement et boum le crash.

Idem j'ai toujours le problème avec fluid synth, dés que je charge une soundfont muse plante.

En lancant muse dans un terminal, la seul indication que j'ai c'est #signal 2

Je crois que je vais d/l les sources et le recompiler à la mano pour voir si le problème est toujours existant

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 12:30, ven. 24 Sep 2021: Bonjour à et bienvenue à kitty32, beldic2, et à Carlos54 cool
olinuxx, 21:29, mer. 22 Sep 2021: Bonjour et bienvenue à tezere cool
funroad34, 15:50, lun. 20 Sep 2021: c est surtout lors de la connection que ça rame sinon c 'est correct niveau timming a l'ouverture des pages..
funroad34, 15:43, lun. 20 Sep 2021: slt Oui patience et perseverence...
Houston4444, 11:17, lun. 20 Sep 2021: Ici on apprend la patience, bientôt la cafetière aura terminé sa mission avant que la page soit chargée...
sub26nico, 17:50, dim. 19 Sep 2021: pas de souci ici
funroad34, 14:14, dim. 19 Sep 2021: Bonjour idem chez moi
Geis007, 18:03, sam. 18 Sep 2021: binjch, c'est très lent, en effet !
binjch, 22:51, ven. 17 Sep 2021: Salut c'est hyper lent chez tout le monde là? Ou c'est moi qui ai un problème?
olinuxx, 18:46, jeu. 16 Sep 2021: Bonjour et bienvenue à pierre2 cool
zicstef, 22:40, mer. 15 Sep 2021: Hello, il y a bien longtemps que je n'ai pas eu la joie de passer. Découvert au détour d'un surf: /
olinuxx, 18:30, lun. 13 Sep 2021: [INFO] nouveau compte Diaspora pour linuxmao : [Lien] Venez nous y rejoindre cool