Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > Line6 HX Stomp Pas de son avec pulseaudio après une session Jack
Dernier post

Line6 HX Stomp Pas de son avec pulseaudio après une session Jack

eleandar utilisateur non connecté France
Salut,

J'ai un souci avec mon Line6 HX Stomp (firmware 2.82) :

Au départ j'utilise pulseaudio: j'arrive à lire des MP3.
J'active Jack : Pulseaudio passe dans Jack (aucun problème) (je redirige la sortie vers vers "jack sink")
J'éteins Jack, j'indique au lecteur MP3 de rediriger la sortie le HX Stomp et le son ne revient pas dans pulseaudio mais j'arrive à lire les MP3 sur ma carte son interne avec pulseaudio.

Le volume de l'application et de la sortie HX Stomp s'activent mais rien dans le casque !

J'ai vu que c'était muté alors j'ai utilisé la commande suivante:
pacmd set-sink-mute 14 0


Commme il me semble que jack est démarré avec pasuspender, je tente de le désactiver avec:
pacmd suspend 0


Et maintenant:
pacmd list-sinks | grep -E "index|name|muted|suspend"


index: 1
	name: <alsa_output.pci-0000_00_1f.3.analog-stereo>
	suspend cause: (none)
	muted: no
		alsa.name = "ALC269VC Analog"
		alsa.subdevice_name = "subdevice #0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xdf220000 irq 131"
		alsa.driver_name = "snd_hda_intel"
		device.vendor.name = "Intel Corporation"
		device.product.name = "Sunrise Point-LP HD Audio"
		device.profile.name = "analog-stereo"
		alsa.mixer_name = "Realtek ALC269VC"
		device.icon_name = "audio-card-pci"
				device.icon_name = "audio-speakers"
				device.icon_name = "audio-headphones"
  * index: 15
	name: <alsa_output.usb-LINE_6_HX_Stomp_3013138-01.analog-surround-71>
	suspend cause: (none)
	muted: no
		alsa.name = "USB Audio"
		alsa.subdevice_name = "subdevice #0"
		alsa.card_name = "HX Stomp"
		alsa.long_card_name = "LINE 6 HX Stomp at usb-0000:00:14.0-7, high speed"
		alsa.driver_name = "snd_usb_audio"
		device.vendor.name = "Line6, Inc."
		device.product.name = "HX Stomp"
		device.profile.name = "analog-surround-71"
		alsa.mixer_name = "USB Mixer"
		device.icon_name = "audio-card-usb"


Mais toujours pas de son avec pulseaudio seul mais quand je réactive jack le son revient ...

Note: ça fonctionne avec mes autres cartes son ...

sudo alsa force-reload


n'y change rien et débrancher et rebrancher le câble USB non plus ...

Une idée ?

(ubuntustudio 19.10)

jujudusud utilisateur non connecté France
Bonjour eleandar,

Est ce que tu confirmes que cette interface fonctionne bien avec Linux ?
Est ce que tu serais pret à nous aider à rendre la page linux mao interessante au regard de cette interface audio pour eventuellement guider d'autre utilisateur de cet engin vers linux ?
une troisieme chose sympa serait de créer cette interface dans carte son des membres | Interfaces audio spéciales | Pédales d'effets guitare avec carte son intégrée et de dire que tu en possède une :-)

en ce qui concerne ton probleme je n'ai pas d'idée... malheureusement.

eleandar utilisateur non connecté France
Ok l'article est écrit.

Pour mon problème, c'est sûrement un problème avec pasuspender de pulseaudio ou un problème avec le driver ALSA ou les deux.

Il faut que je trouve où poser la question ...

olinuxx utilisateur non connecté France
Merci pour les ajouts dans la doc eleandar.
J'ai fait une passe dessus.
Pour info, dans les pages de matériel, on essaie de dépersonnaliser au maximum, et il y a les "commentaires" (bouton en bas de page) s'il les utilisateurs veulent apporter des commentaires plus personnels.
Encore merci pour cette contribution !

jujudusud utilisateur non connecté France
Oui merci pour tous les utilisateurs de cette marque qui vont maintenant tomber sur cette page ! :-)

Chouette pour l'issue sur le projet Pulseaudio, je croise les doigts pour qu'une réponse soit postée.
tiens nous au courant en tout cas.

olinuxx utilisateur non connecté France
Des nouvelles concernant ton soucis @eleandar ?

eleandar utilisateur non connecté France
Salut,

Pour répondre à @olinuxx

finalement j'ai trouvé un workaround.

Il faut aller dans pavucontrol / onglet Configuration et sélectionnez les différentes configuration de l'HX Stomp jusqu'à ce que le son revienne.

J'imagine que ça doit réinitialiser des variables dans le driver et du coup le son revient ...

Récemment, je suis passé à Ubuntu Studio 20.10, qui utilise Studio Controls & KDE. Ça marche plutôt bien mais quand on débranche le périphérique son USB pendant que jack fonctionne, il continue de partir en sucette avec 100% de CPU ...

Bref, j'ai pu constaté que l'HX Stomp génére des Xruns régulièrement et que pour mon utilisation avec Jamulus l'HX Stomp avait des limites (j'ai deux fois le son de l'instrument: le son de la pédale + le retour Jamulus de l'ordinateur) et qu'il valait mieux que je passe par une autre carte son.

Donc j'ai branché la sortie audio de l'HX Stomp sur un Zoom U22 et là plus un seul Xrun sur une très longue période plusieurs heures ...

Donc je suis content de ma conf car pas de Xrun mais j'ai toujours un souci, il me faut brancher d'autres instru et donc il faut que je trouve une carte son 4 entrées qui ne génère pas de Xrun sur une distribution optimisée pour l'audio. D'ailleurs je vais regarder la liste des cartes son des membres de LinuxMAO.

olinuxx utilisateur non connecté France
Merci pour ce retour.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 17:20, lun. 18 Oct 2021: Bonjour et bienvenue à white-wolf cool
olinuxx, 16:23, sam. 16 Oct 2021: Bonjour et bienvenue à didremi, TiFred et à Cecile43 cool
bluedid29, 12:40, dim. 10 Oct 2021: A titre d'info, test interface audio Audient Di14 en cours sur Debian, Ubuntu... ...pour l'instant, que du bon ;-) Je tiens au courant pour plus de précisions dès que que possible...
bluedid29, 12:38, dim. 10 Oct 2021: Merci pour l'édito et bon dimanche sous le soleil :-)
sub26nico, 22:05, mer. 06 Oct 2021: Bien joué les potos, qu'il est bien, qu'il est beau l'édito !
r1, 15:33, mer. 06 Oct 2021: Les rhinos comme les chameaux, tous sont accros à l'édito !
allany, 09:06, mer. 06 Oct 2021: Pas besoin d'otorhino, c'est juste l'édito ! [Lien]
olinuxx, 20:38, mar. 05 Oct 2021: Bonjour et bienvenue à Turtlebass6 et à FalCT60 cool
sub26nico, 23:39, lun. 04 Oct 2021: Bonjour et bienvenue à clem.radio et Scaviner56 :-)
sub26nico, 22:00, ven. 01 Oct 2021: funroad34, en éditant le titre. Dans l'encart de modération il y a un lien qui l'explique.
funroad34, 08:58, ven. 01 Oct 2021: Bonjour comment on marque un sujet resolu ?
Samuel, 17:55, jeu. 30 Sep 2021: LMMS 1.3 alpha commence à supporter les greffons LV2. ça c'est de la bonne nouvelle