Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

4 - Toutes les autres applications, les émulateurs...

> Forums de discussion > 4 - Toutes les autres applications, les émulateurs... > Compilation d'aubio 0.3.2 : erreur au « make »
Dernier post

Compilation d'aubio 0.3.2 : erreur au « make »

Ejis Articles : 165 utilisateur non connecté
Salut,

Ardour 2.5 vient de sortir, et j'aimerais le compiler. Je suis sous Zenwalk, distribution basée sur Slackware.
J'ai cherché des .tgz de la librairie aubio demandée par le nouvel Ardour, mais il n'y a que la version 0.3.1.
J'aimerais donc compiler aubio 0.3.2.
La configuration se passe bien, mais au make, j'ai une erreur :

Citation :
make1: entrant dans le répertoire « /home/aymeric/InstallLogiciels/MAO/Ardour/aubio-0.3.2/aubio-0.3.2/ext »
if /bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../src -I../src -Wall -Wextra -I/usr/local/include -I/usr/include/alsa -g -O2 -MT midi_alsa_seq.lo -MD -MP -MF ".deps/midi_alsa_seq.Tpo" -c -o midi_alsa_seq.lo `test -f 'midi/midi_alsa_seq.c' || echo './'`midi/midi_alsa_seq.c; \
then mv -f ".deps/midi_alsa_seq.Tpo" ".deps/midi_alsa_seq.Plo"; else rm -f ".deps/midi_alsa_seq.Tpo"; exit 1; fi
gcc -DHAVE_CONFIG_H -I. -I. -I../src -I../src -Wall -Wextra -I/usr/local/include -I/usr/include/alsa -g -O2 -MT midi_alsa_seq.lo -MD -MP -MF .deps/midi_alsa_seq.Tpo -c midi/midi_alsa_seq.c -fPIC -DPIC -o .libs/midi_alsa_seq.o
In file included from /usr/include/bits/errno.h:25,
from /usr/include/errno.h:36,
from /usr/include/alsa/asoundlib.h:39,
from midi/midi_alsa_seq.c:37:
/usr/include/linux/errno.h:4:23: error: asm/errno.h: No such file or directory
midi/midi_alsa_seq.c: In function 'aubio_alsa_seq_run':
midi/midi_alsa_seq.c:345: error: 'EAGAIN' undeclared (first use in this function)
midi/midi_alsa_seq.c:345: error: (Each undeclared identifier is reported only once
midi/midi_alsa_seq.c:345: error: for each function it appears in.)
make1: *** midi_alsa_seq.lo Erreur 1
make1: quittant le répertoire « /home/aymeric/InstallLogiciels/MAO/Ardour/aubio-0.3.2/aubio-0.3.2/ext »
make: *** all-recursive Erreur 1


Pourriez-vous me dire comment régler ce problème ?

Merci d'avance.

Ejis Articles : 165 utilisateur non connecté
Problème résolu : y'a un .tgz  ...

Désolé du dérangement.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 09:25, mar. 15 Jun 2021: Bonjour et bienvenue à Hexaal :-)
Ubuntu_Studio_User, 02:29, lun. 14 Jun 2021: Salut à tous...
allany, 12:12, sam. 12 Jun 2021: @tourneriff : merci pour le signalement, c'est fait !
tourneriff, 07:52, sam. 12 Jun 2021: Bonjour à tous ☺ ! Avis aux modos : pourrait-on voir la "joute 16" en cours à l'accueil du site plutôt que l'antique "joute 15"
sub26nico, 14:56, jeu. 10 Jun 2021: Salut et bienvenue à jamesonmount, freerawsound et Loop :-)
ycollet, 10:28, mer. 09 Jun 2021: Cool, un revival de rakarrak ! [Lien]
sub26nico, 22:08, lun. 07 Jun 2021: Bonjour et bienvenue à ArchLinux59, Djobi et gakgakgak :-)
olof, 09:27, lun. 07 Jun 2021: ardour 6.7 build tourne chez moi, mais pas le package 6.6
allany, 14:46, dim. 06 Jun 2021: @r1 : t'as raison : trop c'est trop, ça sature du goulot !
r1, 22:54, sam. 05 Jun 2021: Mon cerveau a bobo à force de faire le gogo sur l'annonce de l'édito !
allany, 11:49, sam. 05 Jun 2021: Z'ont encore abattu un sacré boulot, les poulbots de l'édito ! [Lien]
ycollet, 20:37, ven. 04 Jun 2021: Un article intéressant sur un truc à venir sur USB audio: [Lien]