Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > LBZ4 et numérotation carte son à trou
Dernier post
Page : 1/2   -   Aller directement à la page : 1  2 

LBZ4 et numérotation carte son à trou

piratebab utilisateur non connecté
Bonjour,
sur une LBZ4, j'utilise 2 cartes son USB.
Lorsque je regarde comment elles sont numérotées, il y a un trou (pas de carte 1)

arecord -l
**** Liste des Périphériques Matériels CAPTURE ****
carte 0: PCH [HDA Intel PCH], périphérique 0: CX20751/2 Analog [CX20751/2 Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 2: USB [Scarlett 18i20 USB], périphérique 0: USB Audio [USB Audio]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 3: S1810c [Studio 1810c], périphérique 0: USB Audio [USB Audio]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0


Et même avec une seule carte externe, toujours pas de carte 1. Et ça perturbe fortement OpenSoundMeter!
Auriez vous une explication à cette carte 1 fantôme ?

Je suis en train de me documenter sur la façon dont les cartes son sont numérotées.

bda utilisateur non connecté France
Bonjour,
Est-ce que
aplay -l
indique une interface en 1?
J'ai déjà vu ça sur un PC équipé d'une carte graphique nvidia. Il y avait une interface audio par la sortie HDMI mais pas d'entrée.
Si c'est le cas, il faut mettre le module en question en blacklist.

piratebab utilisateur non connecté
Ce matin tout est OK !
Alors que depuis plusieurs jours, c'était systématique.

arecord -l
**** Liste des Périphériques Matériels CAPTURE ****
carte 0: PCH [HDA Intel PCH], périphérique 0: CX20751/2 Analog [CX20751/2 Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: S1810c [Studio 1810c], périphérique 0: USB Audio [USB Audio]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0



aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: PCH [HDA Intel PCH], périphérique 0: CX20751/2 Analog [CX20751/2 Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 7: HDMI 1 [HDMI 1]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 8: HDMI 2 [HDMI 2]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 9: HDMI 3 [HDMI 3]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 10: HDMI 4 [HDMI 4]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: S1810c [Studio 1810c], périphérique 0: USB Audio [USB Audio]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0


Je vais refaire des tests dans le weekend

piratebab utilisateur non connecté
J'ai reproduit le probléme. Il faut connecter la carte aprés le boot
play -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: PCH [HDA Intel PCH], périphérique 0: CX20751/2 Analog [CX20751/2 Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 7: HDMI 1 [HDMI 1]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 8: HDMI 2 [HDMI 2]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 9: HDMI 3 [HDMI 3]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 10: HDMI 4 [HDMI 4]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 2: S1810c [Studio 1810c], périphérique 0: USB Audio [USB Audio]
  Sous-périphériques: 1/1


Je pense aussi que c'est un pilote pour la puce nvidia qui met le bazar, mais pourquoi il n’apparaît pas ?

piratebab utilisateur non connecté
Je l'ai piégée avec alsamixer
Image
C'est bien nvidia
Reste à trouver comment la faire apparaître proprement, ou comment supprimer uniquement la partie son du driver nouveau

piratebab utilisateur non connecté
c'est va étre compliqué de blacklister le module, c'est le même que celui de la carte son interne intel. Si je le blackliste, je n'aurais plus de son interne via la sortie casque

multimedia
                description: Audio device
                produit: GM107 High Definition Audio Controller [GeForce 940MX]
                fabriquant: NVIDIA Corporation
                identifiant matériel: 0.1
                information bus: pci@0000:01:00.1
                version: a1
                bits: 32 bits
                horloge: 33MHz
                fonctionnalités: pm msi pciexpress bus_master cap_list
                configuration: driver=snd_hda_intel latency=0
                ressources: irq:17 mémoire:ef080000-ef083fff


Ce qui explique le contenu du fichiers cards qui parle de HDA-intel pour la carte nvidia
cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xef128000 irq 132
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xef080000 irq 17
 2 [S1810c         ]: USB-Audio - Studio 1810c
                      PreSonus Studio 1810c at usb-0000:00:14.0-2, high speed


bda utilisateur non connecté France
Non, il y a bien deux modules différents (enfin de mémoire, je n'ai pas de machine avec cg nvidia). L'un des deux doit être du genre snd_hda_codec_hdmi. Il te faut créer un fichier /etc/modprobe.d/hdmi_audio_blacklist.conf contenant:
install snd_hda_codec_hdmi /bin/true

Le mettre simplement en blacklist n'a jamais fonctionné sur mon précédent PC.

piratebab utilisateur non connecté
effectivement, j'ai un snd_hda_codec_hdmi

piratebab utilisateur non connecté
j'ai réussi à dégager le module
lsmod | grep hdmi

ne retourne plus rien.
Mais la sortie audio est toujours listée
cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xef128000 irq 132
 1 [S1810c         ]: USB-Audio - Studio 1810c
                      PreSonus Studio 1810c at usb-0000:00:14.0-2, high speed
 2 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xef080000 irq 17



j'ai blacklisterHDA_intel pour enfin voir disparaitre cette carte hdmi fantôme.
Mais du coup, je n'ai plus de son sur la sortie casque du PC

bda utilisateur non connecté France
Si c'est un portable, peut être que bbswitch (du projet bumblebee) peut désactiver la cg nvidia si elle n'est pas utile. Certains BIOS/UEFI peuvent aussi mais c'est assez rare.

piratebab utilisateur non connecté
Oui, c'est ça, je ne tourne que sur la carte intel.
Mais le fait qu'elle existe dans /proc/asound/cards, mais que aplay -l ou arecord -l ne la voit pas est un probleme pour OpenSoundMeter.
Lorsque je veux choisir la carte d'interface, il se bloque.
J'ai informé le concepteur de OpenSoundMeter de ce problème, je vais bien voir si il répond.

piratebab utilisateur non connecté
J'ai du blacklister HDA intel pour ne plus avoir cette carte fantome, mais du coup je n'ai plus de tout de son interne (sortie casque)

piratebab utilisateur non connecté
Je n'ai que ma LZ4 qui à ce comportement anormal avec les sorties hdmi "fantômes";
Par ex sur une autre machine en debian testing:

cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xf9ff8000 irq 33
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfbafc000 irq 32


aplay -l
**** Liste des périphériques matériels PLAYBACK ****
carte 0 : Intel [HDA Intel], périphérique 0 : ALC1200 Analog [ALC1200 Analog]
  Sous-périphériques : 1/1
  Sous-périphérique #0 : subdevice #0
carte 0 : Intel [HDA Intel], périphérique 1 : ALC1200 Digital [ALC1200 Digital]
  Sous-périphériques : 1/1
  Sous-périphérique #0 : subdevice #0
carte 1 : NVidia [HDA NVidia], périphérique 3 : HDMI 0 [HDMI 0]
  Sous-périphériques : 1/1
  Sous-périphérique #0 : subdevice #0
carte 1 : NVidia [HDA NVidia], périphérique 7 : HDMI 1 [HDMI 1]
  Sous-périphériques : 1/1
  Sous-périphérique #0 : subdevice #0
carte 1 : NVidia [HDA NVidia], périphérique 8 : HDMI 2 [HDMI 2]
  Sous-périphériques : 1/1
  Sous-périphérique #0 : subdevice #0
carte 1 : NVidia [HDA NVidia], périphérique 9 : HDMI 3 [HDMI 3]
  Sous-périphériques : 1/1
  Sous-périphérique #0 : subdevice #0
carte 1 : NVidia [HDA NVidia], périphérique 10 : HDMI 4 [HDMI 4]
  Sous-périphériques : 1/1
  Sous-périphérique #0 : subdevice #0


La sortie hdmi est bien vue comme une sortie normale.

Est ce qu'il y a quelque chose de spécifique sur LS4 vis à vis des sorties hdmi ?

bda utilisateur non connecté France
Rien de spécifique à LZK, c'est une évolution du noyau. Il me semble que les périphériques HDA sont maintenant séparés, avant ils apparaissaient comme une seule interface.

Mais bbswitch ou nvhda  Image devrait résoudre ton problème en faisant disparaître la carte nvidia.

piratebab utilisateur non connecté
Merci pour ces pistes;
Pour nvhda
should be obsolete for kernels >=5.4 as the HDA device is enabled per pci quirk

Je suis en kernel 5.10 sur la LBZK et 6.0 sur la debian.
Je vais essyer d'upgrader en 6.0 la LBZ4 car il semble y avoir des évolutions dans la prise en compte du son hdmi depuis quelques versions.

bda utilisateur non connecté France
Tu devrais regarder la doc nvidia  Image .

piratebab utilisateur non connecté
bda,
j'ai regardé le lien que tu as donné, il s'agit du driver propriétaire nvidia.ko, LBZ4 utilise le driver libre nouveau.

bda utilisateur non connecté France
Oui, mais le pilote nouveau est limité sur ce point. En ajoutant le dépôt "non-free", il est possible de remplacer nouveau par le pilote officiel et désactiver la CG complètement.
Apparemment il y a une autre solution mais jamais essayé: nvidia-gpu-off  Image .
Parce qu'en passant par le noyau de Debian testing, tu perds les avantages du noyau LZK.

piratebab utilisateur non connecté
C'est violent comme procédure!
A la base je ne veux pas virer la sortie son hdmi, je veux juste qu'elle soit vue correctement par aplay et arecord (et par tout les autres logiciels utilisant les cartes son car ce trou dans la numérotation en perturbe certains).
Ca fonctionne sur une debian, mais je n'arrive pas à trouver pourquoi j'ai ce phénomène sur LBZ4.

bda utilisateur non connecté France
Je comprend bien mais avec nvidia c'est toujours problématique, en particulier sur portable.
Si tu veux profiter des avantages du noyau LZK, tu n'as pas trop de choix si ce n'est de désactiver la CG nvidia.
Avec un noyau plus récent tu perds les optimisations spécifiques à LZK.

As-tu essayé pipewire? Perso depuis 2 mois je tourne avec (remplace pulseaudio et jack de façon transparente) sous Arch et j'ai 0 soucis d'une manière générale. Pourtant juste avec l'audio intégrée de mon mini pc.
Par contre je n'utilise pas Debian ou LZK et je ne sais pas si c'est bien supporté.

Sinon attendre que LZK utilise un noyau 6.x...

jujudusud utilisateur non connecté France
Salut,

Si ton but est de pouvoir utiliser un noyau de la série 6.x et d'avoir les configurations de basse latence que fournis le noyau LibraZiK4, alors compiles toi même un noyau avec les configurations du noyau LZK4.

Page : 1/2  [Suivant]
1  2 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

calixtus06, 18:59, mer. 01 Feb 2023: Bonjour et bienvenue à MimiDuBeausset:)
jujudusud, 16:02, mer. 01 Feb 2023: Venez m'aider à catégoriser les distributions : [Lien]
olinuxx, 17:24, mar. 31 Jan 2023: Nouveautés à propos de LibraZiK : [Lien]
calixtus06, 07:18, lun. 30 Jan 2023: Bonjour et bienvenue à blug et X836461 :-)
olinuxx, 09:11, dim. 29 Jan 2023: @louiesauvage, utilise plutôt les forums pour poser des questions.
louiesauvage, 12:11, mar. 24 Jan 2023: Qui utilise Ardour avec antelopes audio
olinuxx, 18:56, lun. 23 Jan 2023: Bonjour et bienvenue à zigaboo, gotouch, et Yrbua cool
olinuxx, 21:35, lun. 16 Jan 2023: Bonjour et bienvenue à KABORE Alain et à minimalist cool
calixtus06, 07:04, ven. 13 Jan 2023: Bonjour et bienvenue à bullrai :-)
calixtus06, 07:23, lun. 09 Jan 2023: Bonjour et bienvenue à editgo :-)
allany, 18:30, jeu. 05 Jan 2023: Les années passent, reste l'éditorial ! [Lien]
olinuxx, 16:24, mar. 03 Jan 2023: Bonjour et bienvenue à runny cool