Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

Dernier post

[RÉSOLU] Carte son USB U46mk2

luluone utilisateur non connecté
Bonjour à tous,

Je suis sous ubuntu karmic version desktop.
Je possède une carte son USB U46mk2 de chez Mixvibes que j'utilise avec des vinyles timecodés (sous windows).
Mon but est de l'utiliser sous Ubuntu avec le logiciel Mixxx sur un noyau temps réel avec Jackd.

Dans Préférences > Son ma carte apparait bien mais il m'indique 1 entrée/1 sortie alors que celle-ci possède 4 entrées/6 sorties.
Sur le site alsa-project ma carte est bien listée U46mk2

Et là je suis un peu perdu...
J'ai du mal à m'y retrouver

1- Faut-il installer la dernière version d'ALSA?
2-Si oui celle-ci est installée sous forme de modules, non?
3-Le noyau intègre déjà une version d'ALSA (1.0.20), non?
4-Dans ce cas faut-il supprimer la version d'ALSA présente dans le noyau?

Merci pour vos conseils

Samuel utilisateur non connecté Allemagne
Salut

si tu veux utiliser jack (et tu veux utiliser jack), ce qui est important se trouve dans la partie connections de QJackCtl.

Configure correctement jack, pour qu'il se lance sur ta mixvibes et pas sur ta carte interne. Une fois lancé, toutes tes entrées/sorties devraient s'afficher dans les connections.
Tiens nous au courant.

jy_moustache utilisateur non connecté
salut

je pense que samuel a raison mais comme tu es débutant, j'en profite pour ajouter que ce réglage se fait dans la fenêtre réglage de QJackCtl, Périphérique d'entrée et Périphérique de sortie est ce que tu cherches.
cliques sur les fleches à droite et sélectionne ta carte

voila

jy

olinuxx utilisateur non connecté France
du nouveau ici ?
a+
Olivier

luluone utilisateur non connecté
Je n'ai pas encore trouvé la solution pour faire fonctionner ma carte son avec Mixxx.
Je viens d'installer UbuntuStudio 10.10 RC avec la dernière version de Mixxx (1.8.0). Je vais voir si ça donne quelque chose.

olinuxx utilisateur non connecté France
OK, cool, tiens nous au courant (:wink)
a+
Olivier

luluone utilisateur non connecté
La carte fonctionne directement sur UbuntuStudio 10.10.
Dans Préférences > Son la carte apparait avec 1 entrée/1 sortie alors que celle-ci possède 2 entrées/3 sorties RCA. La carte fonctionne pourtant parfaitement.
Les CD et vinyls timecodés de Mixvibes ne fonctionnent pas sur Mixxx (version 1.8.1) pour le moment.

olinuxx utilisateur non connecté France
Content que ça marche pour toi !
Profites-en pour signaler que cette interface fonctionne quelque part dans les pages de Portail Matériel et mettre un [résolu] dans le titre de ton premier message.
a+
Olivier

pooosoook utilisateur non connecté
up up

Salut a tous !!

cela fait un moment que je cherche a régler mon problème de configuration de cette carte son sous kubuntu et ubuntu studio

il se trouve en effet que je n arrive pas a séparer mes sorties audio indépendamment ... j ai cherché du coté de la configuration de pulseaudio mais rien n a pu me permettre de configurer ma carte son de manière a avoir au moins 2 sorties stéréo séparées ( la carte en compte 3X2) et de pouvoir les retrouvées dans les menus d assignations/sorties de mes logiciels

apparemment luluone avait le même soucis , mais je doute qu il soit encore par ici pour nous dire s il a trouvé la solution ...

J accepte volontiers toute l aide qui pourra m être fournie :-)

allany utilisateur non connecté
Hello !

Bon, je t'avoue que je n'ai pas tout lu de la discussion qui précède.
J'en retire quand même qu'alsa donne cette carte comme "usb", sans précisions autres.
Ce qui signifie que le driver est le "générique" snd-usb-audio pourvu de 2 entrées et deux sorties et ne fonctionnant qu'en 16 bits/44100 hertz.

Tu devrais donc disposer de 2 entrées et 2 sorties.
Sois vigilant sur la procédure d'allumage qui, souvent, doit se dérouler séquentiellement ainsi :
  • carte éteinte (ou USB déconnecté), allume l'ordi,
  • logge-toi,
  • allume (ou branche) ta carte.
Ensuite, peux-tu poster les résultats de :
  • aplay -l
  • cat /proc/asound/cards
  • lsmod | grep snd
afin qu'on y voie plus clair ?

A+

pooosoook utilisateur non connecté

merci allany pour la célérité de ta réponse !!

alors que la carte restait en permanence allumée au démarrage du système , elle était présente dans liste matérielle de phonon

en suivant ta procédure de connexion de la carte son , cette dernière ne s y trouve plus , de même que ma carte son intégrée
Dans la liste ne se trouve plus que le serveur son pulseaudio

voici les résultats donnée cependant par les commandes que tu m as conseillées :

aplay -l

[+]
cat /proc/asound/cards

0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xdb300000 irq 46
 1 [U46DJ          ]: USB-Audio - U46DJ
                      ESI U46DJ at usb-0000:00:1d.1-2, full speed


lsmod | grep snd

[+]

j ai beau chercher , je ne vois toujours pas a quel endroit opérer afin de séparer ces satanées sorties ...

allany utilisateur non connecté
Bon, la carte est bien présente, reconnue et son driver est bien chargé...

Dans Jack, tu devrais avoir au moins deux possibilités :
  • interface=hw:1
  • P. entrée=défaut
  • P. sortie=défaut
ou
  • interface=défaut
  • P. entrée=hw:1,1
  • P. sortie=hw:1,0

Après, comme ça se généralise un peu trop ces derniers temps, il est fort possible que le HDMI fiche le souk.
Pulseaudio (que je n'ai jamais installé) n'a pas, non plus, très bonne presse, ici.
Sa présence semble inadaptée à la MAO, semblerait-il...

Peux-tu nous lister le contenu de /etc/modprobe.d ?

A+

pooosoook utilisateur non connecté
je pense aussi a un soucis causé par pulseaudio , mais n étant pas vraiment encore très performant sous linux , j ai un peu peur de trop bidouiller ...

pour le contenu de /etc/modprobe.d :
$ ls /etc/modprobe.d 
alsa-base.conf              blacklist-modem.conf
blacklist-ath_pci.conf      blacklist-oss.conf
blacklist.conf              blacklist-rare-network.conf
blacklist-cups-usblp.conf   blacklist-watchdog.conf
blacklist-firewire.conf     nvidia-graphics-drivers.conf
blacklist-framebuffer.conf



les sorties sont separées par le 5.1 d office , ( front l , front r , rear l , rear r , subwoofer ) j ai toutefois réussi a séparer mes sorties via pulseaudio (avec mixxx) mais je n ai pas trouvé comment faire de même avec jackd !!

tout conseil est le bienvenu :-)

allany utilisateur non connecté
Bon, rien qui puisse nous aider dans ton modprobe.d.
Passons !

As-tu testé successivement les deux possibilités de paramétrage que je t'ai indiquées, pour Jack ?

En effet, ne touche pas à Pulseaudio, pour l'instant. Ca semble parfois risqué (suppression drivers Alsa...).

A+

pooosoook utilisateur non connecté
en effet , j ai testé les possibilité de parametrage que tu m as données , mais peut importe la carte ou les sorties selectionnées , le son sort uniquement des HP de mon laptop ... pas moyen de trouver une sortie sur ma carte son usb dans jackd ( QJackCtl )...

bref je ne sais plus vraiment comment m y prendre et vers ou me tourner pour régler ce probleme

allany utilisateur non connecté
Avant de lancer Jack, est-ce que tu "tues" Pulseaudio ?
Je crois que tu peux le faire avec une commande du genre :
sudo pulseaudio -k


A vérifier...

A+

pianolivier utilisateur non connecté France
coucou pooosoook,

Je te conseille de (re?) jeter un œuil au tuto de premier lancement de jack, en particulier le réglage "interface".
Ensuite ouvre un nouveau fil dédié si tu as encore des problèmes, c'est plus facile à suivre et si tu penses que ton problème est lié à un sujet existant, ajoute simplement un lien sur celui-ci.

++ oliv'

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]


r1

Mégaphone [Afficher / Cacher]

ycollet, 14:03, ven. 24 mai 2019: Live coding en C: /
olinuxx, 17:14, jeu. 23 mai 2019: Bonjour et bienvenue à Tom cool
sub26nico, 23:37, mer. 22 mai 2019: Bienvenue à adlibitom et patoche44 :-)
sub26nico, 09:48, sam. 18 mai 2019: Salut et bienvenue à Florentdu19 :-)
olinuxx, 13:18, mar. 14 mai 2019: Bonjour et bienvenue à MAOfccl cool
sub26nico, 09:20, sam. 11 mai 2019: Salut et bienvenue à Adi :-)
olinuxx, 13:06, ven. 10 mai 2019: Bonjour et bienvenue à DTSSSE cool
sub26nico, 21:51, jeu. 09 mai 2019: Salut et bienvenue à Fladmay :-)
sub26nico, 18:02, mer. 08 mai 2019: Salut et bienvenue à pvd57 :-)
diigitae, 20:02, mar. 07 mai 2019: pierrotlo beau modulaire XD
sub26nico, 23:02, dim. 05 mai 2019: Salut et bienvenue à botzaile et botzilla
allany, 19:55, dim. 05 mai 2019: Ben oui, il est là l'édito ! [Lien]