Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [CONSEILLÉ] PRODIPE 49C / Jack - Comportement etrange
Dernier post

[CONSEILLÉ] PRODIPE 49C / Jack - Comportement etrange

nitnit01 utilisateur non connecté
Bonjour,

Je me suis acheté un clavier avec une connectique USB et un autre MIDI (en vue d'un prochain achat de carte son) PRODIPE 49C.

Je l'ai branché en USB sur mon ordi. Au lancement de JACK, sous l'onglet alsa, le port n'est reconnu que par intermittence ce qui rend impossible de l'utiliser (autrement dit ça clignote, comme si l'engin décrochait constamment).

J'ai tenté sur d'autre port USB mais rien.

A noté qu'il est reconnu sous XP sans aucun soucis.

Pour info je suis sur une distrib Ubuntu Lucid Lynx 10.04, noyau 2.6.32-26-generic

olinuxx utilisateur non connecté France
Coucou,

en avant propos, quand ton clavier fonctionnera, merci de le reporter sur la page clavier midi et éventuellement de lui créer une page dédiée. Si tu veux, je t'aiderai à ça.


Une petite recherche sur le net ne donne pas grand chose, peut tu nous donner un retour de :
cat /proc/asound/cards


a+
Olivier

nitnit01 utilisateur non connecté
Bonjour et merci de ton intérêt,

Si le problème a une solution, je ne manquerai pas de faire ce que tu me demandes, avec ton aide.

J'ai tapé ta commande :

0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xf9ff8000 irq 22
 1 [U0x2180x201    ]: USB-Audio - USB Device 0x218:0x201
                      USB Device 0x218:0x201 at usb-0000:00:1d.0-2, full speed


Il me semble que le clavier est bien reconnu. Je me demande si ce n'est pas un problème de latence du port usb lui même.

J'ai suivi les conseils de dominique concernant les latences d'une carte son usb :

Citation :
La période des interruptions d'un port usb est de 1 msec. Cela implique que pour obtenir des latences faibles avec un tel port et jack, il faut régler jack avec quelque chose comme 48 kHz et 3 périodes. Cela va faire du temps de buffer de jack un multiple de 1 msec et permettra de meilleures latences que 2 périodes.


à 48000 Hz et une période de 3 dans les paramètres. Même en élevant la valeur, c'est toujours la même chose.

La fenêtre message de jack me renvoie cela sur la période d'activation du clavier

23:04:43.031 Client activé.
23:04:43.033 Changement des connexions JACK.
23:04:43.035 Changement du graphique des connexions JACK.
23:04:46.122 Changement du graphique des connexions ALSA.
23:04:46.236 Changement des connexions ALSA.
23:04:46.365 Changement du graphique des connexions ALSA.
23:04:46.438 Changement des connexions ALSA.
23:04:46.806 Changement du graphique des connexions ALSA.
23:04:46.839 Changement des connexions ALSA.
23:04:47.049 Changement du graphique des connexions ALSA.
23:04:47.241 Changement des connexions ALSA.
23:04:47.461 Changement du graphique des connexions ALSA.
23:04:47.642 Changement des connexions ALSA.
23:04:47.697 Changement du graphique des connexions ALSA.
23:04:47.844 Changement des connexions ALSA.
23:04:48.105 Changement du graphique des connexions ALSA.
23:04:48.245 Changement des connexions ALSA.
23:04:48.345 Changement du graphique des connexions ALSA.
23:04:48.447 Changement des connexions ALSA.


et la commande dmesg donne une appréciation similaire du problème:

[ 2623.595969] usb 6-2: configuration #1 chosen from 1 choice
[ 2623.849549] usb 6-2: USB disconnect, address 88
[ 2624.089019] usb 6-2: new full speed USB device using uhci_hcd and address 89
[ 2624.251998] usb 6-2: configuration #1 chosen from 1 choice
[ 2624.262699] usb 6-2: USB disconnect, address 89
[ 2624.993015] usb 6-2: new full speed USB device using uhci_hcd and address 90
[ 2625.152008] usb 6-2: configuration #1 chosen from 1 choice
[ 2625.162326] usb 6-2: USB disconnect, address 90
[ 2625.772030] usb 6-2: new full speed USB device using uhci_hcd and address 91
[ 2625.932030] usb 6-2: configuration #1 chosen from 1 choice
[ 2626.181552] usb 6-2: USB disconnect, address 91
[ 2626.421515] usb 6-2: new full speed USB device using uhci_hcd and address 92
[ 2626.584031] usb 6-2: configuration #1 chosen from 1 choice
[ 2626.837551] usb 6-2: USB disconnect, address 92
[ 2627.080015] usb 6-2: new full speed USB device using uhci_hcd and address 93
[ 2627.241057] usb 6-2: configuration #1 chosen from 1 choice
[ 2627.493077] usb 6-2: USB disconnect, address 93
[ 2627.733023] usb 6-2: new full speed USB device using uhci_hcd and address 94
[ 2627.896060] usb 6-2: configuration #1 chosen from 1 choice
[ 2628.149547] usb 6-2: USB disconnect, address 94
[ 2628.389014] usb 6-2: new full speed USB device using uhci_hcd and address 95
[ 2628.548058] usb 6-2: configuration #1 chosen from 1 choice
[ 2628.797546] usb 6-2: USB disconnect, address 95
[ 2629.037517] usb 6-2: new full speed USB device using uhci_hcd and address 96
[ 2629.200100] usb 6-2: configuration #1 chosen from 1 choice
[ 2629.449551] usb 6-2: USB disconnect, address 96
[ 2629.688031] usb 6-2: new full speed USB device using uhci_hcd and address 97
[ 2629.848104] usb 6-2: configuration #1 chosen from 1 choice
[ 2629.858417] usb 6-2: USB disconnect, address 97
[ 2630.468022] usb 6-2: new full speed USB device using uhci_hcd and address 98
[ 2630.632120] usb 6-2: configuration #1 chosen from 1 choice
[ 2630.885551] usb 6-2: USB disconnect, address 98
[ 2631.124018] usb 6-2: new full speed USB device using uhci_hcd and address 99
[ 2631.288125] usb 6-2: configuration #1 chosen from 1 choice
[ 2631.541051] usb 6-2: USB disconnect, address 99
[ 2631.836024] usb 6-2: new full speed USB device using uhci_hcd and address 100
[ 2631.896345] hub 6-0:1.0: unable to enumerate USB device on port 2
[ 2632.680016] usb 6-2: new full speed USB device using uhci_hcd and address 101
[ 2632.840168] usb 6-2: configuration #1 chosen from 1 choice
[ 2632.851542] usb 6-2: USB disconnect, address 101
[ 2642.192033] usb 6-2: new full speed USB device using uhci_hcd and address 102
[ 2642.351326] usb 6-2: configuration #1 chosen from 1 choice
[ 2642.365437] usb 6-2: USB disconnect, address 102
[ 2643.097520] usb 6-2: new full speed USB device using uhci_hcd and address 103
[ 2643.259343] usb 6-2: configuration #1 chosen from 1 choice
[ 2643.270638] usb 6-2: USB disconnect, address 103
[ 2643.877525] usb 6-2: new full speed USB device using uhci_hcd and address 104
[ 2644.040360] usb 6-2: configuration #1 chosen from 1 choice
[ 2644.293555] usb 6-2: USB disconnect, address 104
[ 2644.533521] usb 6-2: new full speed USB device using uhci_hcd and address 105
[ 2644.696384] usb 6-2: configuration #1 chosen from 1 choice
[ 2644.949555] usb 6-2: USB disconnect, address 105
[ 2645.188031] usb 6-2: new full speed USB device using uhci_hcd and address 106
[ 2645.347388] usb 6-2: configuration #1 chosen from 1 choice
[ 2645.597575] usb 6-2: USB disconnect, address 106
[ 2645.836506] usb 6-2: new full speed USB device using uhci_hcd and address 107
[ 2646.000400] usb 6-2: configuration #1 chosen from 1 choice
[ 2646.253550] usb 6-2: USB disconnect, address 107
[ 2646.492019] usb 6-2: new full speed USB device using uhci_hcd and address 108
[ 2646.707419] usb 6-2: configuration #1 chosen from 1 choice
[ 2646.957562] usb 6-2: USB disconnect, address 108
[ 2647.197021] usb 6-2: new full speed USB device using uhci_hcd and address 109
[ 2647.356431] usb 6-2: configuration #1 chosen from 1 choice
[ 2647.569076] usb 6-2: USB disconnect, address 109
[ 2725.864025] usb 6-2: new full speed USB device using uhci_hcd and address 110
[ 2726.023148] usb 6-2: configuration #1 chosen from 1 choice
[ 2726.273056] usb 6-2: USB disconnect, address 110
[ 2726.596034] usb 6-2: new full speed USB device using uhci_hcd and address 111
[ 2726.761166] usb 6-2: configuration #1 chosen from 1 choice
[ 2727.013558] usb 6-2: USB disconnect, address 111
[ 2727.253520] usb 6-2: new full speed USB device using uhci_hcd and address 112
[ 2727.417174] usb 6-2: configuration #1 chosen from 1 choice
[ 2727.429612] usb 6-2: USB disconnect, address 112
[ 2776.956023] usb 6-2: new full speed USB device using uhci_hcd and address 113
[ 2777.116330] usb 6-2: configuration #1 chosen from 1 choice
[ 2777.369566] usb 6-2: USB disconnect, address 113
[ 2777.637020] usb 6-2: new full speed USB device using uhci_hcd and address 114
[ 2777.800340] usb 6-2: configuration #1 chosen from 1 choice
[ 2778.053593] usb 6-2: USB disconnect, address 114
[ 2778.292017] usb 6-2: new full speed USB device using uhci_hcd and address 115
[ 2778.451387] usb 6-2: configuration #1 chosen from 1 choice
[ 2778.701563] usb 6-2: USB disconnect, address 115
[ 2778.940020] usb 6-2: new full speed USB device using uhci_hcd and address 116
[ 2779.099366] usb 6-2: configuration #1 chosen from 1 choice
[ 2779.349563] usb 6-2: USB disconnect, address 116
[ 2779.588026] usb 6-2: new full speed USB device using uhci_hcd and address 117
[ 2780.112278] usb 6-2: device not accepting address 117, error -71
[ 2780.168038] hub 6-0:1.0: unable to enumerate USB device on port 2
[ 2902.424270] usb 6-2: new full speed USB device using uhci_hcd and address 119
[ 2902.583443] usb 6-2: configuration #1 chosen from 1 choice
[ 2902.837564] usb 6-2: USB disconnect, address 119
[ 2903.104023] usb 6-2: new full speed USB device using uhci_hcd and address 120
[ 2903.262467] usb 6-2: configuration #1 chosen from 1 choice
[ 2903.513553] usb 6-2: USB disconnect, address 120
[ 2903.753032] usb 6-2: new full speed USB device using uhci_hcd and address 121
[ 2903.915472] usb 6-2: configuration #1 chosen from 1 choice
[ 2904.165562] usb 6-2: USB disconnect, address 121
[ 2904.404015] usb 6-2: new full speed USB device using uhci_hcd and address 122
[ 2904.564478] usb 6-2: configuration #1 chosen from 1 choice
[ 2904.817558] usb 6-2: USB disconnect, address 122
[ 2905.056020] usb 6-2: new full speed USB device using uhci_hcd and address 123
[ 2905.215494] usb 6-2: configuration #1 chosen from 1 choice
[ 2905.465552] usb 6-2: USB disconnect, address 123
[ 2905.704019] usb 6-2: new full speed USB device using uhci_hcd and address 124
[ 2905.863509] usb 6-2: configuration #1 chosen from 1 choice
[ 2905.873869] usb 6-2: USB disconnect, address 124
[ 2906.480856] usb 6-2: new full speed USB device using uhci_hcd and address 125
[ 2906.639532] usb 6-2: configuration #1 chosen from 1 choice
[ 2906.892055] usb 6-2: USB disconnect, address 125
[ 2907.132021] usb 6-2: new full speed USB device using uhci_hcd and address 126
[ 2907.291546] usb 6-2: configuration #1 chosen from 1 choice
[ 2907.541561] usb 6-2: USB disconnect, address 126
[ 2907.780025] usb 6-2: new full speed USB device using uhci_hcd and address 127
[ 2907.939557] usb 6-2: configuration #1 chosen from 1 choice
[ 2908.189552] usb 6-2: USB disconnect, address 127


Une recherche sur Google ne donne aucune réponse à cela. Je ne sais d'ailleurs pas comment nommer ce problème...

olinuxx utilisateur non connecté France
OK,

utilises-tu un Le noyau Temps-Réel ou un noyau générique ?

(pour le savoir : tape
uname -a
dans un terminal)

Olivier

nitnit01 utilisateur non connecté
Re,

C'est un générique

Citation :
2.6.32-26-generic #47-Ubuntu SMP Wed Nov 17 15:59:05 UTC 2010 i686 GNU/Linux


Lucid Lynx, d'après ce que j'ai pu lire n'a pas de RT dédié. J'ai récupéré un PREEMPT dispo dans mon grub. Mais rien n'y fait.

nitnit01 utilisateur non connecté
Petit redemarrage sous kernel PREEMPT

Citation :
2.6.31-11-rt #154-Ubuntu SMP PREEMPT RT


et mêmes manips que précédemment. Aucun changement. Je note que le clavier allume toute ses diodes et ne répond pas "normalement".

olinuxx utilisateur non connecté France
ouép, je te demandais ça car avec un noyau RT, on peut gérer les conflits d'IRQ et je me disais que ça pouvais être un conflit d'IRQ. Mais bon, c'est juste une idée en l'air, même pas une intuition ... wink

Tu peux aller jeter un œil du côté de la page Temps-réel pour les processus IRQ quand tu démarres sur ton Le noyau Temps-Réel, et regarder si tu n'as pas l'interruption (IRQ) du contrôleur USB de ton clavier qui est la même qu'autre chose, pis sinon, y'a bien des gens qui vont t'aider à trouver car moi, là, si c'est pas ça, je sèche...

a+
Olivier

PS : n'hésite pas à upper ton message si tu n'as pas de réponse dans quelques jours.

jy_moustache utilisateur non connecté
salut
ce n'est visiblement pas la gestion des IRQ qui est a mettre en cause puisque le problème apparaît aussi sur un noyau générique.
non a mon avis, il faudrait chercher du côté d'udev et de la gestion des connections usb à chaud (ce que suggère le log de dmesg).

peux-tu faire la manip suivante :
  • démarre sur le noyau générique
  • après t'être loggé, donne le log de
    dmesg
    (pour voir si tout s'est bien passé)
  • branche ton clavier
  • donne le log de
    dmesg
    (pour voir ce qu'il fait)
  • et aussi peux-tu nous renvoyer deux logs successifs de
    lsusb
    , ton clavier a l'air de changer de ports en permanence

jy

nitnit01 utilisateur non connecté
Merci tout de même Olivier,

J'ai pu en savoir un peu plus sur le sujet des IRQ que je découvre.

Jy, je te remercie de ton intérêt. J'avais déjà un petit soupçon sur le comportement des ports usb.

sur dmesg (sans clavier)


[+]
puis dmesg avec clavier branché :


[+]
Ton diagnostique semble juste à première vue.

Ensuite avec la commande lsusb sans clavier :

Bus 008 Device 003: ID 056a:0062 Wacom Co., Ltd 
Bus 008 Device 002: ID 045e:0040 Microsoft Corp. Wheel Mouse Optical
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Même commande avec clavier :

Bus 008 Device 003: ID 056a:0062 Wacom Co., Ltd 
Bus 008 Device 002: ID 045e:0040 Microsoft Corp. Wheel Mouse Optical
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 098: ID 0218:0201  
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Étrange réponse du bus 005. Quelque chose a l'air branché qui n'est pas reconnu. Est-ce cela ?

nitnit01 utilisateur non connecté
Désolé pour le mauvais usage des codes que je viens enfin de comprendre, soit:

{ QUOTE}

et

{ CODE}

jy_moustache utilisateur non connecté
ca fait 3 fois que je réécris ce message mais a chaque fois mon browser plante donc on y retourne evil

ton clavier est bien reconnu comme un clavier MIDI (chargement du module snd_usb_audio) en revanche comme on le suspectait déjà, il est monté/démonté en permanence.

c'est udev qui gère le montage/démontage des périphériques à chaud. je suspecte donc qu'il soit le responsable.

malheureusement, ici on a des compétences sur tout ce qui est logiciels et configuration des OS pour la MAO mais pas vraiment pour les éléments de base des distributions comme udev.

je te conseille donc d'aller faire une demande sur http://ubuntuforums.org/ , la version anglaise des forums, tu auras probablement une réponse. j'obtiens beaucoup plus de réponses dans la version anglaises que dans la version francaise des forums ubuntu donc je te les conseilles

autre chose, as-tu essayé de changer le cable USB, parfois certains cables déconnent (faux contact etc)...

bon courage et tiens nous au jus.

jy

superleon écrit :
salut à tous.

je déterre ce topic car j'ai ce prodipe mide usb 25 c.
le clavier est reconnu par tango studio en tant que

1 [CONTROLLER     ]: USB-Audio - WORLDE CONTROLLER
<br />                      WORLDE WORLDE CONTROLLER at usb-0000:00:1d.2-1, full speed



lorsque je lance qjackd, celui ci me renvoi cette erreur :

Impossible de connecter le serveur JACK comme client.
- L'opération a échoué.
<br />- Incapable de se connecter au serveur.
<br />Veuillez consulter la fenêtre des messages pour plus d'informations.


il est à noter que je n'ai pas d'onglet alsa dans la fenetre "connecter" de jack.
de plus, lorsque je lance alsamaixer via un terminal, il n'y a pas de "fader" et j'ai ce message :

This sound device does not have any controls.



je n'y comprend rien....

est ce alsa qui ne veut pas de mon clavier?

si quelqu'un à fait des trouvailles a ce sujet je suis prenneur!


superleon écrit :
up!


Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 12:40, dim. 11 Apr 2021: Bonjour et bienvenue à seagull31 et à agaelus cool
olinuxx, 13:08, sam. 10 Apr 2021: Bonjour et bienvenue à hhhve et à Largol cool
sub26nico, 17:38, ven. 09 Apr 2021: Salut et bienvenue à arnaoned, Tripayou et zoulou3 :-)
olinuxx, 13:46, jeu. 08 Apr 2021: Bonjour et bienvenue à kpoman cool
sub26nico, 22:06, mer. 07 Apr 2021: @stratojaune, ouvres un fil de forum pour ça
stratojaune, 18:54, mer. 07 Apr 2021: c'est pour avoir 4 pistes en REC au lieu de 2, j'ai oublié de dire ça aussi, comme Félicie !
stratojaune, 18:51, mer. 07 Apr 2021: sans latence, j'ai oublié de le dire !
stratojaune, 18:48, mer. 07 Apr 2021: je cherche de l'aide pour synchroniser une carte son de carte mère et une autre PCI dans Ardour sur AVLinux
olinuxx, 21:26, mar. 06 Apr 2021: Hisse et ho, hisse et ho ! Santiaahannno
sub26nico, 20:59, mar. 06 Apr 2021: Et même Toto sur son radeau en suivant les oiseaux :-)
allany, 12:32, mar. 06 Apr 2021: Alors j'y cours, à vélo, à moto, en auto ou en bateau !!!
olinuxx, 12:26, mar. 06 Apr 2021: Y'a que les poireaux, les pipos et les molos qui ne lisent pas l'édito !