Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [resolu] M-Audio Fast Tack Pro : les entrées n'apparaissent pas...
Dernier post

[resolu] M-Audio Fast Tack Pro : les entrées n'apparaissent pas...

zamanika utilisateur non connecté France
Bonjour,

J'essaie d'installer une fast track pro (sous tango studio). Tout ce passe presque bien, sauf que je n'ai pas les entrées audio sad

J'ai essayé toutes les possibilités dans jack (hw:1, hw1:0, hw 1:1 etc...) rien à faire. Au démarrage de jack j'ai un message "cannot open card for capture", un truc du genre. Bref, jack me dit qu'il ne peut pas ouvrir la carte pour la capture, donc qu'il laisse tomber. Remarque : j'ai aussi une carte interne que je ne peux pas désactiver.

En revanche, j'ai bien les deux sorties audio qui fonctionnent. Autre nouvelle, le midi IN marche (le out je n'ai pas testé, mais quand tout marchera je testerai pour compléter la page de la carte sur le wiki - enfin sauf s'il ne marche plus quand les entrées fonctionnent)...

J'ai constaté que alsamixer reconnait bien ma carte (il marque fasttrackpro), mais donne une message "pas de controle pour cette carte" et effectivement, il n'y a aucun curseur de volume.

D'où, deux questions :
- Est-ce que quelqu'un à une idée de la solution ?
- Est-ce que tant que alsamixer ne me permet pas de controler ma carte, c'est même pas la peine de me prendre la tête avec jack ? Ca me permettrai de juste concentrer mes efforts sur la couche alsa, sans me préoccuper de jack.

Merci pour votre aide,

zamanika utilisateur non connecté France
J'ai fait quelques progrès :

Visiblement c'est un problème avec Jack :

- En essayant d'enregistrer avec audacity, ça marche : je peux, dans les préférences d'audacity, régler la fast track pro en entrée comme en sortie. J'ai fait un test d'enregistrement et c'est ok.

Remarque : il y avait un problème de friture comme évoqué dans le wiki sur la carte. J'ai suivi la procédure indiquée sur le site de tango studio (install de rtirq-init, édition du fichier /etc/default/rtirq pour modifier la ligne "RTIRQ_NAME_LIST="rtc usb snd i8042" en mettant usb avant snd, reboot et ça fonctionne - enfin il a fallu que je débranche et rebranche la carte après le boot)

- Dans jack, j'arrive à avoir soit les entrées soit les sorties, mais pas les deux en même temps et au prix d'une petite ruse : si change le mode duplex en capture only, ça ne marche pas, les entrées de la FTP n'apparaissent pas. Mais, si je laisse en Duplex et que je selectionne comme entrée la FTP et comme sortie la carte son interne de mon portable les entrées apparaissent...eek

Donc c'est pas encore la situation idéale, mais les dernières expérimentations sont encourageantes...

cjpsimon utilisateur non connecté
zamanika écrit :
J'ai fait quelques progrès :

Visiblement c'est un problème avec Jack :
J'ai eu un problème similaire avec ma FTP.

Je ne l'allume qu'après le boot.

zamanika utilisateur non connecté France
Merci pour ton aide,

Je vais essayer de procéder comme tu dis, c'est un des rares test que je n'ai pas tenté. Je vous tiens au courant.

pianolivier utilisateur non connecté France
salut zamanika

tu nous file ton log de jack et le résultat de la commande cat /proc/asound/cards stp ?

oliv'

zamanika utilisateur non connecté France
Bonjour et merci de vous intéresser à mon problème,

Donc, je ne branche la carte qu'après le boot (juste avant de lancer jack).

  • Résultat de cat /proc/asound/cards

cat /proc/asound/cards
0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xf2620000 irq 17
 1 [Pro            ]: USB-Audio - FastTrack Pro
                      M-Audio FastTrack Pro at usb-0000:00:1a.0-1.1, full speed
29 [ThinkPadEC     ]: ThinkPad EC - ThinkPad Console Audio Control
                      ThinkPad Console Audio Control at EC reg 0x30, fw 6MHT35WW-1.10


J'ai donc ma carte intégré en 0, la Fasttrack en 1 et ... Ben 29 je sais pas trop ce que c'est....


  • Les entrées / sorties présentes dans la configuration de jack :

Entrées :
hw:0 HDA Intel
hw:0,0 HDA Intel géneric
hw:1 FastTrack Pro
hw:1,1 USB Audio #1
hw:29 : ThinkPad Console Audio Control

Sorties
hw:0 HDA Intel
hw:0,0 HDA Intel géneric
hw:0,3 Intel HDMI
hw:1 FastTrack Pro
hw:1,0 USB Audio
hw:1,1 USB Audio #1
hw:29 : ThinkPad Console Audio Control


  • Suivant les "hw 1,X" que je sélectionne en entrées/sorties dans Jack deux cas de figure se présentent :

Soit Jack démarre, mais je n'ai pas les entrées audio, seulement les sorties :
entrée : hw1 / FastTrackPro
sortie : hw1 / FastTrackPro
Ou
entrée : hw1 / Fasttrack Prod
sortie : hw1,0 / USB Audio
Ou
Interface hw1 et le reste sur par défaut.

jack ne veut pas ouvrir la capture
18:40:58.832 Baie de brassage désactivée.
18:40:58.833 Réinitialisation des statistiques.
18:40:58.844 Changement du graphique des connexions ALSA.
18:40:59.042 Changement des connexions ALSA.
18:49:35.902 Script de démarrage...
18:49:35.903 artsshell -q terminate
sh: artsshell: not found
18:49:36.305 Script de démarrage terminé avec statut de sortie=32512.
18:49:36.305 JACK démarre...
18:49:36.305 /usr/bin/jackd -dalsa -r44100 -p2048 -n2 -D -Chw:1 -Phw:1
18:49:36.307 JACK a été démarrer avec le PID=2079.
jackd 0.118.0
Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
Memory locking is unlimited - this is dangerous. You should probably alter the line:
     @audio   -  memlock    unlimited
in your /etc/limits.conf to read:
     @audio   -  memlock    1440129
no message buffer overruns
JACK compiled with System V SHM support.
loading driver ..
apparent rate = 44100
creating alsa driver ... hw:1|hw:1|2048|2|44100|0|0|nomon|swmeter|-|32bit
control device hw:1
ALSA: Cannot open PCM device alsa_pcm for capture. Falling back to playback-only mode
configuring for 44100Hz, period = 2048 frames (46.4 ms), buffer = 2 periods
ALSA: final selected sample format for playback: 16bit little-endian
ALSA: use 2 periods for playback
18:49:38.367 Configuration du serveur enregistrée dans "/home/zamanika/.jackdrc".
18:49:38.368 Réinitialisation des statistiques.
18:49:38.798 Client activé.
18:49:38.800 Changement des connexions JACK.
18:49:38.805 Changement du graphique des connexions JACK.



Soit jack ne démarre pas du tout...
entrée : hw1,1
sortie : hw1,0
Ou
entrée : hw1,1
sortie : hw1,1
Ou
entrée : hw1,1
sortie : hw1
Ou
Interface : hw1,1 et le reste par défaut

jack ne démarre pas du tout
18:54:58.533 Baie de brassage désactivée.
18:54:58.533 Réinitialisation des statistiques.
18:54:58.545 Changement du graphique des connexions ALSA.
18:54:58.740 Changement des connexions ALSA.
18:55:01.129 Script de démarrage...
18:55:01.130 artsshell -q terminate
sh: artsshell: not found
18:55:01.533 Script de démarrage terminé avec statut de sortie=32512.
18:55:01.533 JACK démarre...
18:55:01.533 /usr/bin/jackd -dalsa -r44100 -p2048 -n2 -D -Chw:1,1 -Phw:1,0
18:55:01.535 JACK a été démarrer avec le PID=2322.
jackd 0.118.0
Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
Memory locking is unlimited - this is dangerous. You should probably alter the line:
     @audio   -  memlock    unlimited
in your /etc/limits.conf to read:
     @audio   -  memlock    1440129
no message buffer overruns
JACK compiled with System V SHM support.
loading driver ..
apparent rate = 44100
creating alsa driver ... hw:1,0|hw:1,1|2048|2|44100|0|0|nomon|swmeter|-|32bit
control device hw:1
configuring for 44100Hz, period = 2048 frames (46.4 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 16bit little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 16bit little-endian
ALSA: use 2 periods for playback
ALSA: could not start playback (Broken pipe)
DRIVER NT: could not start driver
cannot start driver
18:55:01.656 JACK a été arrêté avec succès.
18:55:01.657 Script post-extinction...
18:55:01.658 killall jackd
jackd: aucun processus trouvé
18:55:02.067 Script post-extinction terminé avec statut de sortie=256.
18:55:03.601 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Incapable de se connecter au serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.


  • Les autres réglages de Jack :
- Temps réel coché, rien d'autre dans cette colonne

- Priorité "par défaut"
- Echantillon "2048"
- Freq d'échantillonage : 44100
- Périodes/Tampon : 2
- Résolution : 16, Attente 21333, Canaux Par défaut > Mais ces trois cases sont grisées
- Nb port maxi : 256
- Décompte : 500
- Retard démarrage : 2

- Interface : selon les essais...
- Audio : Duplex
- Periph entrée/sortie : selon les essais
- Canaux entrée/sortie : par défaut
- Latence entrée/sortie : par défaut

Voilà ...

pianolivier utilisateur non connecté France
coucou et merci

ta carte est donc en effet lancée par defaut sur le slot 1
pour y voir plus clair, merci de faire les réglages suivants :
  • interface : hw:1
  • périphérique (e/s) : defaut
  • frame/périod : 512
  • périod/tampon : 3

relance le tout et renvoi le nouveau log de jack

oliv'

ps : merci de rajouter l'option "wordwrap" dans les balises de code lorsqu'on y pense wink

zamanika utilisateur non connecté France
Voilà le log de Jack suite aux modifs :

15:13:47.005 Baie de brassage désactivée.
15:13:47.077 Réinitialisation des statistiques.
15:13:47.096 Changement du graphique des connexions ALSA.
15:13:47.377 Changement des connexions ALSA.
15:13:56.477 Script de démarrage...
15:13:56.478 artsshell -q terminate
sh: artsshell: not found
15:13:56.880 Script de démarrage terminé avec statut de sortie=32512.
15:13:56.880 JACK démarre...
15:13:56.880 /usr/bin/jackd -dalsa -dhw:1 -r44100 -p512 -n3
15:13:56.883 JACK a été démarrer avec le PID=8646.
jackd 0.118.0
Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
Memory locking is unlimited - this is dangerous. You should probably alter the line:
     @audio   -  memlock    unlimited
in your /etc/limits.conf to read:
     @audio   -  memlock    1440129
no message buffer overruns
JACK compiled with System V SHM support.
loading driver ..
apparent rate = 44100
creating alsa driver ... hw:1|hw:1|512|3|44100|0|0|nomon|swmeter|-|32bit
control device hw:1
ALSA: Cannot open PCM device alsa_pcm for capture. Falling back to playback-only mode
configuring for 44100Hz, period = 512 frames (11.6 ms), buffer = 3 periods
ALSA: final selected sample format for playback: 16bit little-endian
ALSA: use 3 periods for playback
15:13:58.959 Configuration du serveur enregistrée dans "/home/zamanika/.jackdrc".
15:13:58.961 Réinitialisation des statistiques.
15:13:58.991 Client activé.
15:13:58.992 Changement des connexions JACK.
15:13:58.994 Changement du graphique des connexions JACK.


Jack se lance, j'ai les sorties audio... Mais toujours pas les entrées sad

zamanika utilisateur non connecté France
Le problème est résolu, mais sans vraiment savoir pourquoi : en désespoir de cause j'ai reinstallé tango studio (v1.1) et ça a marché du premier coup...

Remarque :
- Je branche la carte après le boot (je n'ai pas essayé avant, mais vu que ça fonctionne, je veux pas tout casser...)
- Je l'ai branché sur un autre port usb. Mais je l'avais déjà fait à l'occasion de précédents tests ce qui n'avait rien changé.

Bref, j'imagine que de manipulation en manipulation j'ai "cassé" des choses et que sur une install tout fraiche jack a retrouvé ses petits...

J'ai pas encore testé à fond, (réglages fin de jack, midi...), mais dès que cela fonctionne je fais un retour dans le wiki.

En tout cas, merci pour vos aides !

qnitech utilisateur non connecté
Salutations amis de la musique libre et du libre en musique etc ...

J'ai le souci des entrée qui n'apparaissent plus avec la fasttrack pro, comme mon honoré collègue ci dessus, j'ai effectué consciencieusement les diverses manip pour lister, tenter de détecter etc .. nib, pas l'ombre de la queue d'une avancée.

Je répugne à réinstaller mon système parce que :
1 C'est l'apanage de Micr****t !!
2 C'est plus hygiénique !!
3 C'est mieux qu'en tube !!?!

C'est donc plein d'espoir que je me tourne vers vous, tout disposer à vous donner des copie de toutes les consoles possible et imaginables après avoir exécuté les commandes qui vont bien...

Allez, Kénavo les potos!!

JOhn

pianolivier utilisateur non connecté France
@zamanika : ca a l'air d'etre un soucis avec le pilote de la carte-son, a priori il est possible donc de résoudre ceci sans tout ré-installer
merci d'ouvrir un nouveau sujet dans le forum pour continuer la discussion

++
oliv'

qnitech utilisateur non connecté
pianolivier écrit :
@zamanika : ca a l'air d'etre un soucis avec le pilote de la carte-son, a priori il est possible donc de résoudre ceci sans tout ré-installer
merci d'ouvrir un nouveau sujet dans le forum pour continuer la discussion

++

oliv'


C'est fait Monsieur, merci de ton aide.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 12:35, sam. 28 Nov 2020: Nouvelles du mois de novembre pour LibraZiK : [Lien]
olinuxx, 12:34, sam. 28 Nov 2020: Bonjour et bienvenue à diogene et à klopkloc cool
olinuxx, 19:45, mer. 25 Nov 2020: Bonjour et bienvenue à endymion93 cool
calixtus06, 07:13, mar. 24 Nov 2020: Bonjour et bienvenue à Noxanera ! :-)
sub26nico, 10:40, lun. 23 Nov 2020: Ardour 6.5 est disponible, le bogue d'export a été corrigé
Houston4444, 20:35, dim. 22 Nov 2020: Ardour 6.4 a de serieux soucis selon robin gareus lui-même. Attendez la 6.5 !
sub26nico, 18:00, dim. 22 Nov 2020: Ardour 6.4 est disponible :[Lien]
olinuxx, 14:48, dim. 22 Nov 2020: Bonjour et bienvenue à ykrons cool
olinuxx, 14:47, dim. 22 Nov 2020: @diigitae : [Lien]
diigitae, 02:54, dim. 22 Nov 2020: comment faire pour cloturer mon compte de linuxmao diigitae
olinuxx, 11:40, sam. 21 Nov 2020: LibraZiK-3 dispose à présent d'un live ! [Lien]
Sahaathyva, 20:42, jeu. 19 Nov 2020: Hey!