Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

3 - Le site : philosophie, organisation, problèmes...

> Forums de discussion > 3 - Le site : philosophie, organisation, problèmes... > [RÉSOLU] [BOGUE] Déplacement de fils de discussions
Dernier post
Page : 1/2   -   Aller directement à la page : 1  2 

[RÉSOLU] [BOGUE] Déplacement de fils de discussions

J'ouvre ce sujet pour remonter un "bug" sur la fonction de déplacement de fil de discussion
de moi même le dim. 12 mai 2013 00:05 écrit :
Un bug relevé à l'instant et pas le moindre:tiki-view_forum_thread.php?comments_parentId=36633&topics_offset=2
Quand on déplace un sujet dans la liste d'un forum il il faut faire attention à déplacer toutes ses réponse avant vers un sujet temporaire puis déplacer le sujet pour y rapatrier ensuite ses réponse sinon on perd une partie du contenu evil je vient de me faire avoir bêtement et du coup je doit faire une copie des posts pour rapatrier le contenu ... (à partir d'une copie du site que j'ai ici)


xzu utilisateur non connecté France
GGRRRR evil

c'est quoi ce plan?

Bon, moi j'y toucherai pas! Merci d'avoir prévennu!

Faudra quand me que je te montre comment faire en cas de besoin ;) on fera un fil bidon sur deux deux forums de manière à ce que tu puisse teser le truc ;) ok
je te laisse verrouiller ce fil on ré-ouvrira à l'oocasion du test ?

Citation :
bon ben j'ai plus qu'a recopier les posts manquants dans les 2 sujets que j'ai déplacé l'autre jour :


Laisse te casse pas la tête
le tuto a pu être avancé d'autant que tu vas les retrouver coment les posts ? j'ai déja eut le soucis et je n'ai pas de réponse sur le sujet confused

pianolivier utilisateur non connecté France
trop tard c'est recopié
je reçoit tout sur ma boite email

t'as pas ceux que citait xzu des fois ... (je déconne)

xzu utilisateur non connecté France
hahaha.

on attend un peu avant de fermer?

Non on ferme

Je rouvre le sujet :
joli bug
On peut déplacer une réponse d'un forum à un autre à partir du moment ou il sont dans la même section
exemple: je peux déplacer le sujet sur n'importe quelle sujet de la section " Le site : philosophie, organisation, problèmes, ... Administrer la fonctionnalité " mais pas ailleurs

Je le signale juste en passant ...

pianolivier utilisateur non connecté France
lapin compris

C'est parce que le lièvre court trop vite :-)

olinuxx utilisateur non connecté France
Mise-à-jour

Le probleme :
  • Si un administrateur des forums essaie de déplacer un fil de discussions dans une autre section, il y a un bogue qui fait que on se retrouve avec uniquement le message numéro 1 (celui qui crée le fil de discussion) et la dernière réponse du fil.
  • À noter que si on re-déplace le fil de discussion dans sa section d'origine, on récupère tous les messages du fil de discussion.

J'ai trouvé une solution "a-la-main" qui consiste à déplacer le fil d'une section à une autre. Là on a le bogue. Puis de passer par la base de données pour réattribuer les différents messages à la bonne section.

Le bogue et la solution que j'ai adopté sont remontés chez Tiki .

Bref, s'il y a besoin, je peux le faire.

Super (excellent même) Merci de m'avoir partagé l'info par MP ;) ...

olinuxx utilisateur non connecté France
Merci pour le lien. C'est réparé. J'en ai profité pour effacer ce que tu avais recopié à la main et qui faisait doublon à présent et pour réattribuer le message d'evilshit (le dernier message) à lui-même.

Je ne te remercie pas car le dicton dit que lorsqu'on remercie quelqu'un c'est qu'on a plus besoin de ce quelqu'un en question ;) .

Ceci dit ce n'était pas lié à la mise à jour c'était déja le cas sur tiki 6
(pour ton info les deux fils que tu as relevé tout à l'heure était déjà hs depuis tiki 6.1)

olinuxx utilisateur non connecté France
OK, chouette pour l'historique du truc. Pour info, j'ai corrigé le premier des 2 liens donnés par pianolivier au dessus. Pour le deuxième. y'a du taf et je ferai ça demain.

olinuxx utilisateur non connecté France
C'est fait aussi. Tous les fils bancals mentionnés dans cette page ont été corrigé.

J'ai mis une note dans l'aide aux admins-forum, et j'ai envoyé un message aux admins "Système", "Général" et "Forum".

Je change le type de sujet pour un sujet "normal" à présent.

xzu utilisateur non connecté France
ok noté!

Page : 1/2  [Suivant]
1  2 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 14:27, dim. 20 Sep 2020: Bonjour et bienvenue à ladyash84 cool
olinuxx, 13:45, sam. 19 Sep 2020: Bonjour et bienvenue à tpeyron cool
olinuxx, 12:02, mar. 15 Sep 2020: Bonjour et bienvenue à Exencii cool
jphaenlin, 16:01, lun. 14 Sep 2020: Nouvelle version de TX Modular : [Lien]
olinuxx, 13:43, mer. 09 Sep 2020: Bonjour et bienvenue à borbor cool
sub26nico, 11:26, mar. 08 Sep 2020: Salut et bienvenue à Exeter et amar :-)
sub26nico, 19:59, lun. 07 Sep 2020: Ardour 6.3 est disponible : [Lien]
olinuxx, 14:42, sam. 05 Sep 2020: C'est l'édita... l'édite... l'éditi... l'édito ! [Lien]
olinuxx, 14:26, sam. 05 Sep 2020: Bonjour et bienvenue à java05 cool
sub26nico, 15:41, ven. 04 Sep 2020: Salut et bienvenue à Thomas Sechet :-)
olinuxx, 14:44, mar. 01 Sep 2020: LibraZiK-1 est morte. Longue vie à LibraZiK ! [Lien]
olinuxx, 14:43, mar. 01 Sep 2020: Bonjour et bienvenue à kiwienerver, LeFunambule, et pbor cool