Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

3 - Le site : philosophie, organisation, problèmes...

> Forums de discussion > 3 - Le site : philosophie, organisation, problèmes... > [RÉSOLU] [BOGUE] Messagerie - fonction "Répondre à tous"
Dernier post

[RÉSOLU] [BOGUE] Messagerie - fonction "Répondre à tous"

olinuxx utilisateur non connecté France
Salut à toutes et tous.

J'ai repéré un bogue. Dans la messagerie de linuxmao, si vous faites "Répondre à tous", alors ceci va supprimer le premier destinataire.

Ce bogue a été confirmé par programLyrique.

Le contournement évident est de ré-ajouter à la main la personne manquante.

Olivier

Hello

Histoire d'aider à cibler le problème: la fonction "Répondre à tous" n'éfface pas le premier destinataire mais n'inclut pas une réponse à celui qui émet le message.
de :User emetteur
À :user 1
Cc :user 2

Répondre à tous (on voit qu'il zape l'auteur qui envoit le message
À :user 1
Cc :user 2

(La fonction répondre par contre fonctionne bien). Peut être que chez tiki il pourraient directement inclure le champ qui inclut l'émetteur du premier message. Le bug n'est donc pas spécifique à lmao .
Bonne journée.

pianolivier utilisateur non connecté France
Ajouté à la liste des bugs

oliv'

olinuxx utilisateur non connecté France
Super.

olinuxx utilisateur non connecté France
Remontée

olinuxx utilisateur non connecté France
Remontée du fil de discussion.

olinuxx utilisateur non connecté France
grâce à "m31z0nyx", ce problème est résolu !

Je recopie ici sa solution :




Bon, j'ai passé plus de temps à mettre en œuvre la messagerie qu'à trouver le bug.
En fait les champs tels que préremplis s'appuient sur la présence d'un reply-to qui n'existe pas forcément.

La modif dans templates/messu-read.tpl:

on à 2 forms consécutifs qui appellent messu-compose.php.

ça donne:

Image

Dans le 2nd form il faut remplacer la ligne

Image

C'est tout. ça ne doit pas avoir d'influence sur le vrai mail (pas testé).




Je viens de l'appliquer sur le serveur de linuxmao. Puis j'ai purgé les caches de Tiki. Et ça semble fonctionner après un test.
Merci m31z0nyx !

Je mets un [RÉSOLU] dans le titre de ce fil de discussion et supprime de ce pas la ligne correspondante dans la page bugs.

C'est remonté chez Tiki : https://dev.tiki.org/item5493 .

Ce fil est prêt à être fermé et je le laisse ouvert quelques temps pour permettre de voir s'il n'y a pas d'effet secondaire.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 17:39, lun. 30 mars 2020: Bonjour et bienvenue à JulienRadio cool
sub26nico, 23:48, dim. 29 mars 2020: Salut et bienvenue à Chihiro49130, Gigi, Ptilou, yudas, FF63, mimifloch, mvvl et tophque :-)
malt, 15:55, dim. 29 mars 2020: @Sahaathyva. Je n'avais pas vu ton post!
malt, 15:51, dim. 29 mars 2020: Ardour 6.0-pre1: [Lien]
sub26nico, 20:50, ven. 27 mars 2020: Salut et bienvenue à Topyweb, Serge Samson, ChtiJeff, Zeplead et Zonzon :-)
r1, 20:27, ven. 27 mars 2020: La joute 15 est sur les rails ! [Lien] Viendez jouer avec nous !!!
bluedid29, 17:13, ven. 27 mars 2020: Bon week-end, à fond encore sur Musescore et LibraZik-2... ...bientôt utilisation régulière sur LibraZik-3...
sub26nico, 14:11, ven. 27 mars 2020: @tolliac, ouvres un fil spécifique dans les forums.
tolliac, 11:41, ven. 27 mars 2020: Bonjour, je ne me suis intéressé jusqu'ici qu'à l'écriture de partitions via lilypond et Frescobaldi et pour résoudre des problèmes de lecture de fichiers MIDI je me retrouve dans l'univers de la MAO chaleureusement accueilli mais complètement perdu. quel
Sahaathyva, 09:08, ven. 27 mars 2020: 1 billet de mr Paul : [Lien]
Sahaathyva, 09:07, ven. 27 mars 2020: Salut a tous!
GuillaumeD, 10:58, jeu. 26 mars 2020: @sub26nico, merci pour le message et ravi de vous rejoindre. Le meilleur reste à venir... ;)