Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

3 - Le site : philosophie, organisation, problèmes, ...

> Forums de discussion > 3 - Le site : philosophie, organisation, problèmes, ... > [RÉSOLU] [BOGUE] Messagerie - fonction "Répondre à tous"
Dernier post

[RÉSOLU] [BOGUE] Messagerie - fonction "Répondre à tous"

olinuxx utilisateur non connecté France
Salut à toutes et tous.

J'ai repéré un bogue. Dans la messagerie de linuxmao, si vous faites "Répondre à tous", alors ceci va supprimer le premier destinataire.

Ce bogue a été confirmé par programLyrique.

Le contournement évident est de ré-ajouter à la main la personne manquante.

Olivier

jams utilisateur non connecté
Hello

Histoire d'aider à cibler le problème: la fonction "Répondre à tous" n'éfface pas le premier destinataire mais n'inclut pas une réponse à celui qui émet le message.
de :User emetteur
À :user 1
Cc :user 2

Répondre à tous (on voit qu'il zape l'auteur qui envoit le message
À :user 1
Cc :user 2

(La fonction répondre par contre fonctionne bien). Peut être que chez tiki il pourraient directement inclure le champ qui inclut l'émetteur du premier message. Le bug n'est donc pas spécifique à lmao .
Bonne journée.

pianolivier utilisateur non connecté France
Ajouté à la liste des bugs

oliv'

olinuxx utilisateur non connecté France
Super.

olinuxx utilisateur non connecté France
Remontée

olinuxx utilisateur non connecté France
Remontée du fil de discussion.

olinuxx utilisateur non connecté France
grâce à "m31z0nyx", ce problème est résolu !

Je recopie ici sa solution :




Bon, j'ai passé plus de temps à mettre en œuvre la messagerie qu'à trouver le bug.
En fait les champs tels que préremplis s'appuient sur la présence d'un reply-to qui n'existe pas forcément.

La modif dans templates/messu-read.tpl:

on à 2 forms consécutifs qui appellent messu-compose.php.

ça donne:

Image

Dans le 2nd form il faut remplacer la ligne

Image

C'est tout. ça ne doit pas avoir d'influence sur le vrai mail (pas testé).




Je viens de l'appliquer sur le serveur de linuxmao. Puis j'ai purgé les caches de Tiki. Et ça semble fonctionner après un test.
Merci m31z0nyx !

Je mets un [RÉSOLU] dans le titre de ce fil de discussion et supprime de ce pas la ligne correspondante dans la page bugs.

C'est remonté chez Tiki : https://dev.tiki.org/item5493 .

Ce fil est prêt à être fermé et je le laisse ouvert quelques temps pour permettre de voir s'il n'y a pas d'effet secondaire.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 19:29, sam. 25 mars 2017: bonjour et bienvenue à Foretriks :-)
bluedid29, 15:16, sam. 25 mars 2017: N'hésitez-pas à participer, discuter, papoter... ...et bon week-end ! :-)
bluedid29, 15:15, sam. 25 mars 2017: Le thème pour la prochaine joute est ici : [Lien]
tenryu, 10:31, jeu. 23 mars 2017: @seal20: poses ta question dans le forum, et avec plus de détails, s'il te plait !
seal20, 03:12, jeu. 23 mars 2017: Bjr, comment assigner des pistes Rosegarden vers ardour svp ?
r1, 22:23, mer. 22 mars 2017: Io, bien cool cet edito, merci !
olinuxx, 21:46, mer. 22 mars 2017: [ANNONCE] : l'éditorial du mois est de retour : [Lien] !
olinuxx, 14:00, mer. 22 mars 2017: bonjour et bienvenue à Ephencore :-)
olinuxx, 13:51, mer. 22 mars 2017: toutafé malt, voir : [Lien]
malt, 15:56, mar. 21 mars 2017: Steinberg support pour Linux: [Lien] Perso, j'utilise + les sf2/sfz mais bon.
olinuxx, 08:14, mar. 21 mars 2017: bonjour et bienvenue à Woodnote :-)
bluedid29, 23:29, lun. 20 mars 2017: Par contre je rajoute systématiquement des effets Calf, je mettrais bientôt en ligne les infos sur LinuxMao rubrique Création ;-)