Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

3 - Le site : philosophie, organisation, problèmes...

Dernier post

[2/3 FAIT] Inscriptions

olinuxx utilisateur non connecté France
1) Suggéré par "Atelier Sento" et confirmé par moi : lors d'une nouvelle inscription, si le "Pseudonyme" contient un accent, l'inscription ne fonctionnera pas. Il faudra mettre un avertissement sur la page de formulaire.

2) Il m'a fallu (quasiment à chaque test que j'ai fait pour confirmer la remarque ci-dessus - c'est à dire au moins 8 fois sur une dizaine de tests) cliquer 2 fois sur "s"inscrire". Ça n'est pas très grave en soit, il suffirait d'ajouter un commentaire dans le formulaire d'inscription disant qu'il faut cliquer 2 fois, mais j'aimerai avant de faire ceci que vous confirmiez ce problème.

3) Que l'inscription réussisse ou pas, j'ai été systématiquement redirigé vers une erreur 503 de type :
Citation :
Error 503 Service Unavailable

Service Unavailable
Guru Meditation:

XID: 1751257096

Varnish cache server

Ceci dit, l'inscription est bien validée. Merci là aussi de confirmer ceci.

Citation :
1) Suggérer par "Atelier Sento" et confirmer par moi : lors d'une nouvelle inscription, si le "Pseudonyme" contient un accent, l'inscription ne fonctionnera pas.


C'est pas d'aujourd'hui que ça datte...
Il avait été décidé que les pseudos ne devaient plus contenir de caractère spéciaux car en engendrait des problèmes comme par exemple cet utilisateur utilisateur_anonyme (donc moi) qui même si j'uploade un avatar ne s'affichera pas.
C'est noté quelques part mais je ne me souvient plus où (désolé).
Par contre j'avais ouvert un sujet en 2012 sur mon problème d'avatar ...

Aussi il faudrait vérifier que le formulaire (le gabarit du formulaire d'inscription) ne soit pas en cache. Vérifier les propriétés de la page en question passe la configue sur "pas de cache" puis vider le cache du site et retenter l'expérience ...
Aussi à chaque modife du gabarit en question il faut vider le cache à chaque fois pour que les modifes puissent être fonctionnelles...

olinuxx utilisateur non connecté France
(voir le Journal des modifications - 2015 du 02 mai 2015)

Je prévois d'ajouter dans le gabarit d'inscription (le formulaire), une note en gros et gras qui explique qu'il ne faut pas mettre d'espace, ni d'apostrophe, ...).

olinuxx utilisateur non connecté France
Message de l'utilisateur moarg :
message 1
> j'ai cherché plusieurs fois à m'inscrire, mais à chaque soumission du formulaire, j'ai une « connexion interrompue ». J'ai vérifié, effectivement, c'est bien une interruption du POST sur tiki-register.php, et non une erreur HTTP.
> Pour retrouver dans vos logs : (à voir dans la boîte aux lettres "info" pour les admins)
> Merci pour votre aide !
> PS: y'a-t-il des contraintes sur les caractères dans les pseudos ? A priori je prendrais moA:Rg (j'ai également essayé moa_rg et moarg, problème identique)
message 2
> …mais l'inscription est quand même passée (j'ai reçu le mail de confirmation après vous avoir écrit).

déjà, merci à moarg d'avoir pris le temps de reporter ce souci.

Note pour moi-même (ou pour quiconque voudrait prendre des tâches d'administration en mains) : il faut vraiment que je prenne le temps d'ajouter une note dans la page d'inscription concernant les caractères spéciaux !

olinuxx utilisateur non connecté France
Allez hop, c'est fait.
J'ai ajouté une note dans le Formulaire Inscription et j'ai purgé le cache pour que ça apparaisse.
Dites moi ce que vous en pensez.

olinuxx utilisateur non connecté France
Ça à l'air d'être bon pour tout le monde. Il faut retester le point numéro 2) .

olinuxx utilisateur non connecté France
Des informations ont été ajoutées dans le formulaire. Tout est donc réglé ici. Je mets un [FAIT] dans le titre et fermerai ce fil a mon prochain passage de maintenance.

olinuxx utilisateur non connecté France
Je ré-ouvre ce sujet car j'aimerai bien que nous puissions corriger le problème concernant le message "connexion réinitialisée". C'est pas bloquant pour la prise en compte de l'inscription. Ceci dit, ça n'est pas rassurant pour un nouvel utilisateur, encore moins pour quelqu'un qui est débutant.

Bref, à voir la remarque de utilisateur_anonyme plus haut concernant la mise en cache de la page et le message de moarg.

olinuxx utilisateur non connecté France
Depuis la migration d'hier chez tuxfamily, il n'y a plus de problème de "connexion réinitalisée" et, après inscription, on voit un beau message d'inscription réussie :

Image

Problème corrigé donc :-)

olinuxx utilisateur non connecté France
(remontée)

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]


Mégaphone [Afficher / Cacher]

olinuxx, 13:17, dim. 15 Sep 2019: Bonjour et bienvenue à wwp et à Kraod cool
sub26nico, 22:18, sam. 14 Sep 2019: Salut et bienvenue à Gretsh56 :-)
olinuxx, 13:44, sam. 14 Sep 2019: Bonjour et bienvenue à T-Yo cool
PenZyh, 16:09, mar. 10 Sep 2019: Merci ^^
olinuxx, 16:08, mar. 10 Sep 2019: Bienvenue e bonjour également à PenZyh cool
olinuxx, 14:47, mar. 10 Sep 2019: Bonjour et bienvenue à SKUNKLOAD cool
sub26nico, 10:29, lun. 09 Sep 2019: Salut et bienvenue à aldepr :-)
olinuxx, 09:01, dim. 08 Sep 2019: Bonjour et bienvenue à nuka cool
sub26nico, 20:21, jeu. 05 Sep 2019: Salut et bienvenue à smo :-)
olinuxx, 10:31, jeu. 05 Sep 2019: Il est tout beau, il est tout chaud, c'est l'édito de linuxmao ! [Lien]
olinuxx, 20:15, dim. 01 Sep 2019: Bonjour et bienvenue à Gordus cool
olinuxx, 01:46, ven. 30 Aug 2019: Bonjour et bienvenue à leouiche et à Bellus cool