Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

Dernier post

M-Track guitarix [RESOLU]

jeanvaljean123456 utilisateur non connecté France
Bonjour à tous,

Je suis nouveau sur le forum, bien que je connaisse votre site depuis quelque temps. Je suis aussi nouveau en MAO, j'ai décidé de me lancer depuis quelque semaines. Malheureusement, je suis coincé et j'espere trouver un peu d'aide dans vos forums...
J'ai récupéré un ordinateur sur lequel j'ai installé UbuntuStudio. J'ai acheté une carte son externe M-audio M-track (un modèle un peu plus récent que celui présenté sur le site), et pour commencer je souhaiterais juste réussir à amplifier ma guitare et m'enregistrer.

Tout d'abord, je pense que la carte est reconnue. Voilà le retour de la commande aplay -l :
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: Intel [HDA Intel], périphérique 0: AD1984 Analog [AD1984 Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: Intel [HDA Intel], périphérique 2: AD1984 Alt Analog [AD1984 Alt Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: MTrack [M-Track], périphérique 0: USB Audio [USB Audio]
  Sous-périphériques: 0/1
  Sous-périphérique #0: subdevice #0
carte 2: HDMI [HDA ATI HDMI], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0


et la commande cat /proc/asound/cards :
0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfebdc000 irq 45
 1 [MTrack         ]: USB-Audio - M-Track
                      M-Audio M-Track at usb-0000:00:1a.0-1, full speed
 2 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfe9bc000 irq 47


Lorsque je branche simplement ma guitare sur la carte son, sans lancer aucun soft, le son est faiblement amplifié, ce qui confirme que ma carte est reconnue. Lorsque je lance Jack, dans les messages je reçois :

02:29:55.736 Baie de brassage désactivée.
02:29:55.767 Réinitialisation des statistiques.
02:29:55.785 Changement des connexions ALSA.
02:29:55.794 DBUS : le service est disponible (org.jackaudio.service soit jackdbus).
02:29:55.813 Changement des connexions JACK.
02:29:55.819 Client activé.
(qjackctl:9612): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
(qjackctl:9612): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed


Donc apparemment tout va bien, à moins que les deux dernieres lignes posent problème ?

C'est maintenant que ça se corse : si je lance guitarix, le son de ma guitare n'est pas du tout amplifié, bien que je ne reçoive aucun message d'erreur.
De plus, je ne sais pas si ça pose probleme, mais sur alsamixer, si je sélectionne ma carte son, je vois s'afficher "ce périphérique n'a pas de commande".
Ca fait un bout de temps que je tourne en rond, que j'écume les tutoriels... je commence à désespérer. J'espere que vous pourrez m'aider!

allany utilisateur non connecté
Hello !

Ne désespère pas...
Ta carte est, en effet, bien reconnue physiquement.
Alsa semble bien utiliser le driver générique snd-usb-audio.
Seul Jack me semble être en cause, en aucun cas Guitarix. Ca rétrécit le champ des recherches, déjà.
D'autre part, il semble que certains s'en servent avec succès ici-même.
Si ce n'est pas le même modèle, on va affiner nos recherches...

Peux-tu simplement nous poster les paramètres que tu passes à Jack dans "interface et périphériques d'entrée/sortie", quels sont les choix que te propose Jack avec les flèches ">" et "V" ainsi que le message complet du lancement de jack, en particulier la ligne où figurent les hw:x,y ?

A+

jeanvaljean123456 utilisateur non connecté France
Bonjour allany,

Dans jack, "Interface" j'ai mis hw:MTrack,0, pour périphérique d'entrée et de sortie j'ai mis par défaut.
Pour les choix ">" donne : hw:MTrack ; hw:MTrack,0 (je ne met pas ce qui concerne les 2 autres cartes)
"v" donne : hw:Intel,2 ; hw:0 , plughw:0 ; /dev/audio ; /dev/dsp

Au fait, pour pouvoir lancer une sesssion jack, j'ai besoin de désactiver ma carte son dans PulseAudio.
Je ne sais pas comment avoir le message complet du lancement de jack depuis l'interface graphique. Si je lance la commande
jackd -sRp 70 -d alsa -d hw:2 -r 44100 -H -z s &

J'obtiens :
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2013 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
no message buffer overruns
no message buffer overruns
no message buffer overruns
JACK server starting in realtime mode with priority 10
audio_reservation_init
Acquire audio card Audio1
creating alsa driver ... hw:MTrack|hw:MTrack|1024|2|44100|0|0|hwmon|swmeter|-|32bit
configuring for 44100Hz, period = 1024 frames (23.2 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 24bit little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 24bit little-endian
ALSA: use 2 periods for playback


jeanvaljean123456 utilisateur non connecté France
C'est bon, j'ai trouvé le probleme! Je ne savais pas quels parametres chousir dans peripheriques par defaut car je n'avais pas vu la deuxième flèche... En selectionnant la bonne carte son ça a résolu le problème. Merci allany!

olinuxx utilisateur non connecté France
Super, c'est chouette de voir Allany avoir du temps à redonner sur le forum :-)

jeanvaljean123456, merci de mettre un [RÉSOLU] dans le titre de ton premier message en l'éditant stp.

allany utilisateur non connecté
Cool !

Au fait, tu as passé quoi, comme paramètres à Jack ?

En te relisant, je vois que tu passes par pulseaudio. Lui et Jack ne sont pas très potes, pour la MAO. On te conseillera de lire ceci, au cas où...

Content que ça marche, bonne zique,

A+

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]


bluedid29
kmchen

Mégaphone [Afficher / Cacher]

sub26nico, 23:25, mar. 02 mars 2021: Salut et bienvenue à lastrodamo :-)
sub26nico, 22:45, mar. 02 mars 2021: Bonjour et bienvenue à Razmus :-)
CyrilRos, 21:43, lun. 01 mars 2021: TuxNMix 20.2.1 avec noyau 5.10 disponible
sub26nico, 23:34, dim. 28 Feb 2021: salut et bienvenue à rainbowalice et did1 :-)
r1, 21:06, ven. 26 Feb 2021: @christorbec: je te conseille d'ouvrir un fil sur le forum.
christorbec, 11:28, ven. 26 Feb 2021: bonjour,le suis embêté,car le curseur ne suis plus les notes sur la tablature de tuxguitar,depuis que je sui passer sous debian avec librazik 3....si quelequ'un a une idée?
Nolwen, 18:18, mar. 23 Feb 2021: Mise à disposition de Carla 2.3RC1 ! C'est par ici : [Lien]
sub26nico, 21:03, lun. 22 Feb 2021: Ardour 6.6 est disponible :[Lien]
Nolwen, 17:37, lun. 22 Feb 2021: Sortie de MusE 4.0pre3, dernière release avant la sortie officielle de la version 4 : [Lien] À vos tests et retours !
sub26nico, 13:34, lun. 22 Feb 2021: Bonjour et bienvenue à Inda et MarcoZik46 :-)
olinuxx, 18:42, ven. 19 Feb 2021: Bonjour et bienvenue à richerol cool
sub26nico, 22:06, jeu. 18 Feb 2021: Salut et bienvenue à ZeZombini et jonglacryl :-)