Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : JACK, PulseAudio et autres...

> Forums de discussion > 5 - Les serveurs son : JACK, PulseAudio et autres... > [résolu] Jack ne reconnait plus la RMEfireface 400
Dernier post

[résolu] Jack ne reconnait plus la RMEfireface 400

xav utilisateur non connecté
Salut à tous,

Mon interface n'est plus reconnue par jack alors que le mixer ffado a l'air de fonctionner et que l'interface se met au vert. Je ne sais pas si ça a un lien mais peu avant j'ai suivi la procédure du site :

"Intégration transparente de PulseAudio avec Jack

Il suffit de valider le module jack-sink de PulseAudio avec la commande "pactl load-module module-jack-sink" pour voir apparaitre JACK dans les sorties standard de PulseAudio. Si jack-sink n'est pas dispo sur votre machine aller dans le chercher dans les addon de PulseAudio, il est dispo en standard sur toutes les distributions Linux digne de ce nom. Sur OpenSuse on le trouve dans le package pulseaudio-module-jack."

j'ai donc tapé la commande (j'ai eu 23 en retour), jack sink est apparu dans le menu pulse audio mais plus au prochain démarrage. Dans jack, j'ai que system et midi qui apparaissent
UN message d'erreur apparait dans les messages de jack type:
(qjackctl:2535): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed


Il me semble que GTK clié à l'interface graphique de pulse audio non?

Je ne sais pas ou trouver les addon de pulse audio, a vrai dire je suis un peu dans l'errance et les lignes de commande c pas encore mon dada.

Attention, je ne sais pas si cela impacte sur les infos qui vont suivre mais a l'heure ou je vous parle l'ordi n'est pas relié en firewire a mon interface audio.

0 Intel : HDA-Intel - HDA Intel
HDA Intel at 0xfebf8000 irq 41

                Liste des Périphériques Matériels PLAYBACK **** 

carte 0: Intel HDA Intel, périphérique 0: ALC880 Analog ALC880 Analog
Sous-périphériques: 1/1
Sous-périphérique #0: subdevice #0
carte 0: Intel HDA Intel, périphérique 1: ALC880 Digital ALC880 Digital
Sous-périphériques: 1/1
Sous-périphérique #0: subdevice #0
xav@xav-A6VC:~$
C
xav@xav-A6VC:~$
C
xav@xav-A6VC:~$


Salutations à tous...
Xav

informationinfo
Édition admin olinuxx 13 octobre 2015 : ajout des balises CODE. @xav, merci de le faire toi même la prochaine fois, c'est une des balises dans la barre d'édition des messages.


xav utilisateur non connecté
Je republie ça ici car je me suis trompé de forum..

xav@xav-A6VC:~$ ls /etc/security/limits.d
audio.conf

xav@xav-A6VC:~$ cat ~/.config/rncbc.org/QjackCtl.conf
[Splitter]
AudioConnectView\sizes=437, 304, 507
MidiConnectView\sizes=34, 20, 34
AlsaConnectView\sizes=34, 20, 34
PatchbayView\sizes=34, 20, 34
InfraClientSplitter\sizes=12, 12

[Geometry]
qjackctlMessagesStatusForm\x=0
qjackctlMessagesStatusForm\y=0
qjackctlMessagesStatusForm\width=1280
qjackctlMessagesStatusForm\height=778
qjackctlMessagesStatusForm\visible=false
qjackctlSessionForm\x=6
qjackctlSessionForm\y=157
qjackctlSessionForm\width=639
qjackctlSessionForm\height=428
qjackctlSessionForm\visible=false
qjackctlConnectionsForm\x=0
qjackctlConnectionsForm\y=0
qjackctlConnectionsForm\width=1280
qjackctlConnectionsForm\height=778
qjackctlConnectionsForm\visible=true
qjackctlPatchbayForm\x=59
qjackctlPatchbayForm\y=427
qjackctlPatchbayForm\width=821
qjackctlPatchbayForm\height=369
qjackctlPatchbayForm\visible=false
qjackctlMainForm\x=320
qjackctlMainForm\y=252
qjackctlMainForm\width=506
qjackctlMainForm\height=100
qjackctlMainForm\visible=true

[Program]
Version=0.3.10

[Presets]
DefPreset=(par d\xe9\x66\x61ut)

[Options]
Singleton=true
StartJack=true
StopJack=true
StartupScript=false
StartupScriptShell=
PostStartupScript=false
PostStartupScriptShell=
ShutdownScript=false
ShutdownScriptShell=
PostShutdownScript=false
PostShutdownScriptShell=
StdoutCapture=true
XrunRegex=xrun of at least ([0-9|\\.]+) msecs
ActivePatchbay=false
ActivePatchbayPath=
MessagesLog=false
MessagesLogPath=qjackctl.log
BezierLines=false
TimeDisplay=0
TimeFormat=0
MessagesFont="Droid Sans,10,-1,5,50,0,0,0,0,0"
MessagesLimit=true
MessagesLimitLines=1000
DisplayFont1="Droid Sans,12,-1,5,75,0,0,0,0,0"
DisplayFont2="Droid Sans,10,-1,5,50,0,0,0,0,0"
DisplayEffect=true
DisplayBlink=true
JackClientPortAlias=0
ConnectionsIconSize=0
ConnectionsFont="Droid Sans,10,-1,5,50,0,0,0,0,0"
QueryClose=true
KeepOnTop=false
SystemTray=false
StartMinimized=false
DelayedSetup=false
ServerConfig=true
ServerConfigName=.jackdrc
ServerConfigTemp=false
QueryShutdown=true
AlsaSeqEnabled=true
DBusEnabled=true
AliasesEnabled=false
AliasesEditing=false
LeftButtons=true
RightButtons=true
TransportButtons=true
TextLabels=true
BaseFontSize=0

[Defaults]
PatchbayPath=
MessagesStatusTabPage=0
ConnectionsTabPage=0
SessionSaveVersion=true

[Settings]
Server=/usr/bin/jackd
ServerName=
Realtime=true
SoftMode=false
Monitor=false
Shorts=false
NoMemLock=false
UnlockMem=false
HWMon=false
HWMeter=false
IgnoreHW=false
Priority=70
Frames=512
SampleRate=44100
Periods=3
WordLength=16
Wait=21333
Chan=0
Driver=firewire
Interface=hw:0
Audio=0
Dither=0
Timeout=500
InDevice=
OutDevice=
InChannels=0
OutChannels=0
InLatency=0
OutLatency=0
StartDelay=3
Verbose=false
PortMax=256
MidiDriver=aucun
ServerSuffix=

[History]
ServerPrefixComboBox\Item1=/usr/bin/jackd
ServerPrefixComboBox\Item2=jackd
ServerPrefixComboBox\Item3=jackdmp
ServerPrefixComboBox\Item4=jackstart
ServerNameComboBox\Item1=(par d\xe9\x66\x61ut)
InterfaceComboBox\Item1=hw:0
InterfaceComboBox\Item2=(par d\xe9\x66\x61ut)
InterfaceComboBox\Item3=plughw:0
InterfaceComboBox\Item4=/dev/audio
InterfaceComboBox\Item5=/dev/dsp
InDeviceComboBox\Item1=(par d\xe9\x66\x61ut)
InDeviceComboBox\Item2=hw:0
InDeviceComboBox\Item3=plughw:0
InDeviceComboBox\Item4=/dev/audio
InDeviceComboBox\Item5=/dev/dsp
OutDeviceComboBox\Item1=(par d\xe9\x66\x61ut)
OutDeviceComboBox\Item2=hw:0
OutDeviceComboBox\Item3=plughw:0
OutDeviceComboBox\Item4=/dev/audio
OutDeviceComboBox\Item5=/dev/dsp
XrunRegexComboBox\Item1=xrun of at least ([0-9|\\.]+) msecs
XrunRegexComboBox\Item2=d\xe9synchronisation (XRUN) d'au moins ([0-9|\\.]+) ms
MessagesLogPathComboBox\Item1=qjackctl.log
ServerConfigNameComboBox\Item1=.jackdrc
xav@xav-A6VC:~$


informationinfo
Idem


L'intégration transparente de pulseaudio n'apporte pas toujours que du bon.
Perso j'ai gardé pulseaudio sur ma machine (à des fins de tests) mais dans les réglages de session (ou applications par défaut) j'ai désactivé le démarrage de pulseaudio et éventuellement je le démarre via cadence (mais à vrai dire je ne m'en sert pas).

A oui tes réglages jack périod 2 c'est mieux et accessoirement portmax 1024 ...

[Settings]
...
Periods=2
...
PortMax=1024
...


xav utilisateur non connecté
Merci pour ta réponse je vais appliquer tes réglages si j'arrive a refaire fonctionner le bazare... Le principal souci que j'ai c que mon interface n'apparait pas dans jack. G juste system et midi, même si le ffado mixer fait allumé l'interface. J'essayais d'en trouver la cause en évoquant ma manipulation avec pulse audio car c a partir de ce moment que ça a foiré même si je ne vois pas vraiment le rapport.

Salutations

olinuxx utilisateur non connecté France
@xav, j'ai édité tes messages pour qu'ils soient davantage lisibles. Merci de regarder comment ça fonctionne pour pouvoir le faire toi même lors des prochaines fois.

Olivier (admin)

olinuxx utilisateur non connecté France
Si ton interface est une firewire, prend bien soin de sélectionner firewire en tant que pilote dans ton démarreur de jackd (qjackctl, ladish, cadence, ...) car si tu sélectionne ALSA en tant que pilote, ça ne fonctionnera pas.

Citation :
Le principal souci que j'ai c que mon interface n'apparait pas dans jack.


Pour préciser ce que dit Olinuxx en fait tu ne verra pas l'interface dans qjackctl en fait seul le fait d'utiliser le pilote firewire permet la connexion à ta carte son mais,

Cela dit sur la dernière version de debian j'avais du utiliser le pilote freebob (avec qjackctl) ...

Citation :
J'essayais d'en trouver la cause en évoquant ma manipulation avec pulse audio car c a partir de ce moment que ça a foiré même si je ne vois pas vraiment le rapport.


Le principal problème avec pulse audio c'est que si tu démarre avec pulseaudio il kidnappe ton interface audio dans ce cas cas tu peux toujours dire à jack "connecte toi à ma carte" il te dira bin désolé je trouve pas ta carte.

Donc commence par t'assurer que pulseaudio n'est pas actif voir même désactive le comme indiqué sur la page MAO sans Pulseaudio et Pulseaudio sans MAO
et seulement après tu pourras t'assurer qu'il ne vienne pas de casser les pieds ...

allany utilisateur non connecté
(admin) J'ai supprimé le post qui faisait doublon dans "matériels et pilotes...".
Bonnes recherches à vous (le firewire, c'est trop loin pour moi cool, désolé).
A+

xav utilisateur non connecté
Merci les gars pour vos précieux conseils qui permettent de sortir la tête du guidon. La config marche nickel. Votre travail est précieux. Eteindre pulse audio et mettre en 1024 était la solution. Je vais essayer de faire des posts plus propres à l'avenir.razz

A+

Super t'a plus qu'à passer ton sujet en [Résolu] (en éditant le premier post de cette discussion ;) )

allany utilisateur non connecté
Oooops !
J'ai mis le "résolu". Content que ça marche !

hhub54 utilisateur non connecté France
Merci pour les commentaires et solutions : ma Fireface UCX est USB mais aussi Firewire, et cela me permettra sans doute de l'utiliser en firewire avec mon vieux Tosh (iba, pas Peter) portable.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 09:01, jeu. 18 Aug 2022: Bonjour et bienvenue à oldchap56 cool
olinuxx, 13:21, sam. 13 Aug 2022: Bonjour et bienvenue à Bacoco19 cool
olinuxx, 11:05, ven. 12 Aug 2022: Sur une plage, habillé ou à poil, ou même le soir avant d'aller au bal, prenons le temps de lire l'éditorial !
sub26nico, 20:45, jeu. 11 Aug 2022: Bonjour et bienvenue à crou68 et Tomato :-)
bluedid29, 22:09, sam. 06 Aug 2022: Merci allany et toute l'équipe ;-)
allany, 10:53, sam. 06 Aug 2022: Ça c'est pas banal, v'là l'éditorial ! [Lien]
olinuxx, 09:06, sam. 06 Aug 2022: Bonjour et bienvenue à noedig et à adasper cool
bluedid29, 01:18, sam. 06 Aug 2022: Qtractor 0.9.27 dispo en App c'est cool pour tester :-) [Lien]
bluedid29, 19:47, mer. 03 Aug 2022: LibraZiK 4 en test tous les jours... ...cela se passe plutot bien ! Bon été :-)
sub26nico, 16:33, jeu. 28 Jul 2022: Bonjour et bienvenue à kam et johntheripper :-)
olinuxx, 09:53, dim. 24 Jul 2022: Bonjour et bienvenue à kakajc et à marionux.
olinuxx, 19:56, jeu. 21 Jul 2022: Bonjour et bienvenue à trentin et à lazyn cool