Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

Dernier post

Pas de son & erreur avec pulseaudio

Xon utilisateur non connecté
Bonjour,
Je suis tout nouveau sur linux et j'essaie de l'installer sur mon macbook pro.
L'installation s'est bien passée, mais je n'arrive pas à avoir du son sur le web ou avoir le son d'un fichier audio ou sur une appli audio.

J'ai installé Xubuntu, ainsi que les répertoires de KXstudio (Cadence).

Qaund je fais :
xon@xon-Ubuntu:~$ pulseaudio -D
E: [pulseaudio] main.c: Échec lors du démarrage du démon.


ou :

xon@xon-Ubuntu:~$ start-pulseaudio-x11
Échec : Échec lors de l'initialisation du module


Je compte utiliser prinicpalement jack pour l'audio et bridger PulseAudio dans Jack, d'allumer Jack avec différentes configs, mais rien n'y fait.

Toute aide appréciée pour avoir du son, enfin...
Merci,
Christophe

Xon utilisateur non connecté
Voici certaines infos de ma config. En espérant que qqn puisse m'indiquer une voie pour régler ce pb :
Merci,
Christophe


xon@xon-Ubuntu:~$ cat /proc/asound/cards
 0 [MID            ]: HDA-Intel - HDA Intel MID
                      HDA Intel MID at 0xbbc00000 irq 30
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xb3080000 irq 16



xon@xon-Ubuntu:~$ ls /etc/security/limits.d
audio.conf



xon@xon-Ubuntu:~$ cat ~/.config/rncbc.org/QjackCtl.conf
cat: /home/xon/.config/rncbc.org/QjackCtl.conf: Aucun fichier ou dossier de ce type


olinuxx utilisateur non connecté France
@Xon : j'ai édité tes deux messages pour les mettre en page afin de les rendre plus facilement lisibles. J'ai utilisé les balises de CODE disponible dans la barre d'édition lorsque tu édites un message. Regarde comment j'ai fait pour la prochaine fois.
a+

Est ce que jack et pulseaudio sont vraiment installés ?

Xon utilisateur non connecté
Théoriquement, jack et pulseaudio sont installés.
J'ai même essayé de désinstaller et réinstaller Pulseaudio via la logithèque.
Mais le problème avec pulseaudio persiste.
Et concernant Jack, après avoir installé les répertoires KXstudio, j'ai fait :

sudo apt-get install libjack-jackd2-dev


Xon utilisateur non connecté
Hello,
Juste pour donner plus d'indications quant à mon problème de son :
Une capture d'écran de Cadence, Catia, Alsamixer...

J'ai lancé une vidéo sur internet et une synthèse dans SuperCollider.
On peut voir les vumètres bouger dans Cadence et Pulseaudio.

Mais aucun son ne sort.
Une idée pour régler ce problème de son.
Merci
Christophe

Image

Houston4444 utilisateur non connecté France
Salut.
Je dirais comme ça que si le vu-mètre de PulseAudio réagit et que tu n'as pas de son c'est que Cadence n'est pas réglé sur la bonne carte son (ou interface audio, c'est pareil).
Jette un oeil en cliquant sur "configure" dans Cadence, puis l'onglet "driver".
Si tu utilises la carte son interne de ton ordi, a priori c'est dans la rubrique ALSA, si Cadence est réglé sur un autre pilote (genre DUMMY ou FIREWIRE), c'est normal que ça ne marche pas.
Si ça ne fonctionne pas mieux, post une capture d'écran de "configure", onglet "driver".

Xon utilisateur non connecté
Merci,

Voici l'ecran de l'onglet driver. J'ai essayé plusieurs types d'interfaces, mais rien n'y fait.
Cela doit être qqch de stupide à enclencher. Mais je n'arrive pas à déterminer quoi ?

Image

Houston4444 utilisateur non connecté France
Décoche Hardwares Aliases et Hardware Monitonring déjà, j'avoue que je ne sais pas à quoi servent ces options mais je n'en ai jamais eu besoin.
Met plutôt Input channels et Output channels sur 0, jack mettra automatiquement le nombre maximal d'entrées/sorties.
Regarde les interfaces disponibles, Hwmid,0 est peut-être la bonne mais essaye les autres si ça marche pas mieux (enfin, stop et start JACK entre chaque essai (!).

Voilà essaye tout ça et dis nous tout

fais voir ta config de cadence :
cat ~/.config/jack/conf.xml

Dans un temps si je puis me permetre evite de lancer cadence directement sur le plugin pulseaudio.
Utilise alsa et seulement après tu lance pulseaudio (si besoin).

Xon utilisateur non connecté
Bonjour,

J'ai enfin réussi à avoir du son en faisant :
killall pulseaudio
alsactl init


Mais maintenant, je n'ai du son que sur les HP de mon ordi. Et le casque n'est pas détecté quand il est branché.

J'ai posté la question dans linuxmusicians :
http://linuxmusicians.com/viewtopic.php?f=6&t=14816
Si qqn a la réponse...
Merci,
Christophe

Houston4444 utilisateur non connecté France
J'ai déjà eu ce genre de souci, c'était le volume casque qui était remis à 0 quand je le débranchais et pas forcement remonté après. en fait il y a un réglage qui permet de commuter enceintes du laptop et casque, si bien qu'il est aussi possible d'avoir du son dans les enceintes ET dans le casque.

Mais tout ça c'est sous KDE et ce genre de truc est géré par Kmix (élément qui gère une partie du son sous KDE) et se règle depuis l’icône son de la boîte à miniatures. Je ne sais pas si xfce propose quelque chose comme ça. Tu as regardé ?

Xon utilisateur non connecté
Merci,

Je viens de m'apercevoir que le son vient des HP de mon ordi ou de la sortie casque, en fonction de ce qui est branché au moment du démarrage.
Si des écouteurs sont branchés au démarrage, le son sort seulement sur le casque et je dois déconnecter le casque, rebooter l'ordi pour avoir du son sur les HP.
Comment faire pour que le switch HP / casque soit dynamique, sans avoir besoin de rebooter ?
Bien que je manipule les données dans qasmixer ou alsamixer, rien ne change...

Ci-dessous, ce que j'ai dans :

cd /usr/share/pulseaudio/alsa-mixer/paths/
sudo nano analog-output-headphones.conf


[General]
priority = 90
description-key = analog-output-headphones

[Properties]
device.icon_name = audio-headphones

[Jack Dock Headphone]
required-any = any

[Jack Dock Headphone Phantom]
required-any = any
state.plugged = unknown
state.unplugged = unknown

[Jack Front Headphone]
required-any = any

[Jack Front Headphone Phantom]
required-any = any
state.plugged = unknown
state.unplugged = unknown

[Jack Headphone]
required-any = any

[Jack Headphone Phantom]
required-any = any
state.plugged = unknown
state.unplugged = unknown

# This jack can be either a headphone *or* a mic. Used on some ASUS netbooks.
[Jack Headphone Mic]
required-any = any

[Element Hardware Master]
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

[Element Master]
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

[Element Master Mono]
switch = off
volume = off

[Element Speaker+LO]
switch = off
volume = off

[Element Headphone+LO]
required-any = any
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

[Element Headphone]
required-any = any
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

[Element Headset]
required-any = any
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

[Element Line HP Swap]
switch = on
required-any = any

; This profile path is intended to control the first headphones, not
; the second headphones. But it should not hurt if we leave the second
; headphone jack enabled nonetheless.
[Element Headphone2]
switch = mute
volume = zero

[Element Speaker]
switch = on
volume = ignore

[Element Desktop Speaker]
switch = on
volume = ignore


Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]


MasToo

Mégaphone [Afficher / Cacher]

sub26nico, 22:38, dim. 23 Feb 2020: Salut et bienvenue à maxxbt92 et csvg :-)
sub26nico, 23:14, sam. 22 Feb 2020: Salut et bienvenue à icarius, Cernunos et BD :-)
sub26nico, 22:21, ven. 21 Feb 2020: Salut et bienvenue à math49 et Nov13 :-)
locutor99, 15:31, ven. 21 Feb 2020: I am working in / and https://www.locutortv.es
sub26nico, 11:32, jeu. 20 Feb 2020: @Sahaathyva, merci, fil de forum effacé
Sahaathyva, 10:07, jeu. 20 Feb 2020: On s est fait spammer? Pub de vente de yescards dans la section 2 forum toutes les applications . Pas légal non?
sub26nico, 22:15, mer. 19 Feb 2020: Salut et bienvenue à berangerla7 :-)
sub26nico, 08:40, mar. 18 Feb 2020: Salut et bienvenue à Mehu :-)
olinuxx, 21:44, dim. 16 Feb 2020: [ANNONCE] Une possibilité de se rencontrer autour d'une table ronde et/ou d'un atelier : [Lien]
olinuxx, 19:49, ven. 14 Feb 2020: Bonjour et bienvenue à mbj335 cool
olinuxx, 13:40, ven. 14 Feb 2020: Bonjour et bienvenue à metaalex cool
bda, 21:33, mer. 12 Feb 2020: Un générateur de grosse caisse, un générateur lo-fi et une station granulaire avec csound [Lien]