Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [ABANDONNÉ] Focusrite Scarlett 18i8 et Alsa 1.0.29-1
Dernier post

[ABANDONNÉ] Focusrite Scarlett 18i8 et Alsa 1.0.29-1

BackFromHell utilisateur non connecté
Bonjour,

Je viens d'acquérir une superbe Focusrite Scarlett 18i8 et je viens de passer plus d'une semaine à me battre avec elle, mon PC et Linux.

L'Historique.
Testes
J'ai commencé par la tester avec diverses LiveDVD KxStudio 14.10, UbuntuStudio 15.4 et IO GNU Linux, cela fonctionnait bien avec les aléas du média.

Stretch.
J'ai décidé d'installer une Debian Stretch (Testing), dans un premier temps, j'ai opté pour une installation basic sans interface graphique. J'installais les paquets alsa-base, alsa-tools et alsa-utils et j'arrivais à jouer un wav sur cette carte. Mais un reboot cassait tout, aplay -l me montrait bien mes carte (une Intel HDA on board et la Scarlet) mais pas moyen de faire jouer la Scarlet. Après une semaine de recherches, j'ai décidé d'utiliser une distribution spécialisée, j'ai pris l'UbuntuStudio 15.04.

UbuntoStudio 15.04.
L'installe se déroulait parfaitement, ma carte fonctionnait mais à la première mise à jour, plus rien. Après 3 installations, j'ai baissé les bras et décidé de reprendre ma Stretch.

Stretch, le retour.
A la première installe, la carte à fonctionné. Après un réboot, j'ai du purger et réinstaller les paquets à plusieurs reprises pour pouvoir entendre à nouveau du son. J'ai enfin compris, je sais, je suis dure à la détente, qu'il devait s'agir d'un problème de driver Alsa, j'ai donc opté pour installer le kernel de jessie.
Rien n'y fit.

La Résolution.
J'ai décidé d'installer une Jessie avec KDE et là miracle, elle fonctionnait parfaitement même après un reboot. Enfin, je bosse sur ce problème depuis le 23 décembre 2015 à 19h30, sans compter mon temps et là enfin quelque chose de stable.

J'ai bloqué la mise à jour des paquets alsa-base, alsa-utils et libasound2 pour qu'ils restent en 1.0.28-1 (version Jessie). J'ai adapté mon source.list pour Stretch et mis à jour. Résultat cela fonctionne toujours.

Les Victimes potentielles Debian et dériovées connues.
  • Debian Stretch.
  • Debian SID.
  • Ubuntu 15.04 et dérivées comme UbuntuStudio 15.04.

Les Constations techiques.
  • Les modules son semblent correctement montés.
  • aplay ne retourne pas d'erreur, joue le wav jusqu'au bout mais aucun son n'est audible.
  • aplay -l et aplay -L retourne bien la liste des cartes présentes.
  • Alors qu'un fichier audio est joué, lsof /dev/snd ne retourne rien.
  • Avec un kernel 4.3, alsactl init retourne :
alsactl: sysfs_init:48: sysfs path '/sys' is invalid

Found hardware: "USB-Audio" "USB Mixer" "USB1235:8014" "" ""
Hardware is initialized using a generic method

  • Avec un kernel 3.16, alsactl init ne retourne aucun code d'erreur, simplement :
Found hardware: "USB-Audio" "USB Mixer" "USB1235:8014" "" ""
Hardware is initialized using a generic method


Maintenant.
  • Je n'ai pas encore retourné l'info chez Debian.
  • Cela touche t-il d'autres cartes son USB ?
  • Quelqu'un d'aute a-t-il déjà eu le problème ?
  • Cela touche t-il d'autres distributions ? J'ai lu des postes mais ils touchaient essentiellement des cartes Intel HDA.

Voilà, je vous transmet mon expérience, je n'ai pas vraiment de solution sauf le 'downgrade' d'Alsa.

Bien à vous.

Thierry

olinuxx utilisateur non connecté France
Bonjour et chouette pour ce rapport détaillé que j'ai intégré (grâce à un lien vers ici) dans la page Focusrite Scarlett 18i8.

BackFromHell utilisateur non connecté
De rien.... Un semaine de "perdue" vaut bien un petit post.
Merci pour le lien.

ycollet utilisateur non connecté France
J'ai remarqué que pour que la carte soit reconnue correctement, il faut que je l'allume après m'être loggé dans ma session.
Si je l'allume avant, impossible de sortir un son dessus.
Ca doit être un problème lié à PulseAudio. Mais je n'ai pas cherché plus que ça.

Yann

olinuxx utilisateur non connecté France
@BackFromHell: des nouvelles ?

olinuxx utilisateur non connecté France
Si pas de nouvelle de ta part @BackFromHell, je fermerai ce fil d'ici 3 ou 4 semaines.

À noter l'information de ycollet : Scarlett 18i8 ... again.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 21:29, mer. 22 Sep 2021: Bonjour et bienvenue à tezere cool
funroad34, 15:50, lun. 20 Sep 2021: c est surtout lors de la connection que ça rame sinon c 'est correct niveau timming a l'ouverture des pages..
funroad34, 15:43, lun. 20 Sep 2021: slt Oui patience et perseverence...
Houston4444, 11:17, lun. 20 Sep 2021: Ici on apprend la patience, bientôt la cafetière aura terminé sa mission avant que la page soit chargée...
sub26nico, 17:50, dim. 19 Sep 2021: pas de souci ici
funroad34, 14:14, dim. 19 Sep 2021: Bonjour idem chez moi
Geis007, 18:03, sam. 18 Sep 2021: binjch, c'est très lent, en effet !
binjch, 22:51, ven. 17 Sep 2021: Salut c'est hyper lent chez tout le monde là? Ou c'est moi qui ai un problème?
olinuxx, 18:46, jeu. 16 Sep 2021: Bonjour et bienvenue à pierre2 cool
zicstef, 22:40, mer. 15 Sep 2021: Hello, il y a bien longtemps que je n'ai pas eu la joie de passer. Découvert au détour d'un surf: /
olinuxx, 18:30, lun. 13 Sep 2021: [INFO] nouveau compte Diaspora pour linuxmao : [Lien] Venez nous y rejoindre cool
Samuel, 02:44, dim. 12 Sep 2021: [Lien] C'est la video de présentation du futur de VCV RACK, un synthé modulaire