Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [résolu] M-AUDIO 49, problème de soundfont ?
Dernier post

[résolu] M-AUDIO 49, problème de soundfont ?

darkpassenger utilisateur non connecté
Salut à tous,

Je me suis fait plutôt discret ces temps-ci :-(... car d'autres priorités.

Je viens d'acquerir un M-AUDIO Keystation 49 et il marche bien... mais.... en le testant avec Qsynth et Swami, je remarque qu'il ne reconnait pas certaine soundfont. A moins que cela vienne d'autres choses.

Du coup, j'ai branché mon AKAI LPK25, et avec lui, cela fonctionne. J'arrive à jouer convenablement.

J'ai mis des captures d'ecran, ci dessous :

Image

Image

Avec Qtractor, cela marche, mais, pareil, si j'utilise certaines soundfont, rien, de rien, de rien :-(


Merci
Fabrice

Note modéro-forum olinuxx le 21 septembre 2017 :j'ai modifié tes messages pour qu'on ait les images directement sur linuxmao plutôt que sur un site externe. C'est mieux.


sub26nico utilisateur non connecté France
Bizarre le lien entre un clavier midi et une soundfont.
Je pencherais vers un reconnaissance incomplète du clavier par Alsa.

darkpassenger utilisateur non connecté
Ok, je suis en train de voir du coté d'ALSA. Voici la config déjà.

+
test de latence ALSA :

fabrice@spectre:~/alsa-midi-latency-test-master$ alsa-midi-latency-test -l
 Port    Client name                      Port name
 14:0    Midi Through                     Midi Through Port-0
 28:0    Keystation 49                    Keystation 49 MIDI 1
 28:1    Keystation 49                    Keystation 49 MIDI 2
128:0    TiMidity                         TiMidity port 0
128:1    TiMidity                         TiMidity port 1
128:2    TiMidity                         TiMidity port 2
128:3    TiMidity                         TiMidity port 3


fabrice@spectre:~/alsa-midi-latency-test-master$ alsa-midi-latency-test -i 14:0 -o 14:0 -R -w 2
> alsa-midi-latency-test 0.0.5
> running on Linux release 4.4.0-92-lowlatency (version #115-Ubuntu SMP PREEMPT Thu Aug 10 09:53:57 UTC 2017) on x86_64
sched_setscheduler: Operation not permitted
> set_realtime_priority(SCHED_FIFO, 99).. done.
> clock resolution: 0.000000001 s
> interval between measurements: 2.000 ms

> sampling 10000 midi latency values - please wait ...
> press Ctrl+C to abort test

sample; latency_ms; latency_ms_worst
     0;      0.105;      0.105     
   127;      0.116;      0.116     
  2296;      0.124;      0.124     
  3590;      0.143;      0.143     
  7084;      0.164;      0.164     
  9999;      0.016;      0.164     
> done.

> latency distribution:
  0.0 -  0.1 ms:     9924 ##################################################
  0.1 -  0.2 ms:       75 #
  0.2 -  0.3 ms:        1 #

> SUCCESS

 best latency was 0.0 ms
 worst latency was 0.2 ms, which is great.


F.

olof utilisateur non connecté
moi je pencherais plutot pour une histoire de canal midi, l'un envoyant les messages sur tous les canaux, l'autre sur un seul...
pour en avoir le coeur net, le plus simple est de coller un petit qmidiroute derriere et de voir ce qui arrive comme messages, pour juger de la difference

darkpassenger utilisateur non connecté
J'ai installé qmidiroute, sans trop savoir ce que cela fait :-)

Je l'ai connecté au clavier avec JACK, et cela donne :

Image

Les touches ont l'air de bien être reconnues (si cela sert à çà confused ).

F.

darkpassenger utilisateur non connecté
Le problème venait du fait que mon clavier envoyait sur le canal 15 au lieu du 1.

Merci à ceux qui mon aidé sur le forum et sur le chat.

Fabrice

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 21:18, mar. 28 Jun 2022: Bonjour et bienvenue à zenon cool
bluedid29, 21:30, lun. 27 Jun 2022: Et hop, nouvelle interface audio AUDIENT iD4 testée sur LibraZiK-4... ...impec :-)
PascalC67, 15:21, dim. 26 Jun 2022: Merci Olinuxx :-)
olinuxx, 08:51, dim. 26 Jun 2022: Merci pour les retours Bluedid29 et PascalC67. Bonnes musiques à vous !
olinuxx, 08:51, dim. 26 Jun 2022: Bonjour et bienvenue à PascalC67 cool
PascalC67, 00:23, dim. 26 Jun 2022: Bien joué Olinuxx. :-) Librazik4 + Harrison Mixbus 32C + Bitwig studio 4 + 01V96i
bluedid29, 22:12, sam. 25 Jun 2022: Test en cours LibraZiK-4 et nouvelle interface audio Audient iD4... ...tout se passe bien, super boulot olinuxx :-)
PascalC67, 19:39, sam. 25 Jun 2022: Bonsoir. retour d'un ancien. Je vais tenter une installe de Librazik 4 sur l'un de mes HPZ sous XEon et 01V96i. Si ca tourne bien j'envisagerai ... de connecter une carte MERGING via AES67 dessus en ethernet
Jim-Bo33, 16:42, sam. 25 Jun 2022: Bonjour Olinux, finalement j'ai retrouvert mon login et mon logon. tout va bien
bluedid29, 19:24, ven. 24 Jun 2022: Et hop,distribution LibraZiK-4 installée à partir de Debian 11 Voyager, y'a plus qu'à tester ! Bon week-end :-)
olinuxx, 20:50, mer. 22 Jun 2022: Bonjour et bienvenue à agp cool
olinuxx, 22:35, ven. 17 Jun 2022: Bonjour et bienvenue à lerenti cool