Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

3 - Forum dédié à Ardour

> Forums de discussion > 3 - Forum dédié à Ardour > [Abandonné] Ardour6.9 couleurs bizarres
Dernier post

[Abandonné] Ardour6.9 couleurs bizarres

zicstef utilisateur non connecté
Bonsoir à tous,
Je suis sur Tux|N|Mix et ai réussi à démarer Ardour suite à une modification expliqué dans le fil de support Tux|N|Mix forumthread93112

Je joint un lien d'une capture d'écran pour que vous vous fassiez une idée ^^
https://ibb.co/kSbwZ7X

Image

les choix de thème n'y changent rien. Auriez vous une idée de ce qui arrive? J'ai l'impression que ce problème est inédit :-)

Bonne soirée.
Cordialement, Stéphane

Note modération : merci de poster les captures d'écran directement dans les messages comme expliqué dans la page concernant les forums du manuel du site. Cela permet de garder une meilleure compréhension du fil lorsque les liens ne sont plus disponibles après quelques temps.


zicstef utilisateur non connecté
Je n'arrive pas à changer le titre, pour qu'il soit plus explicite "Ardour 6.9 couleurs bizarres"

sub26nico utilisateur non connecté France
Citation :
les choix de thème n'y changent rien. Auriez vous une idée de ce qui arrive? J'ai l'impression que ce problème est inédit

C'est pourtant le résultat typique de l'affichage d'Ardour quand il est paramétré pour démarrer sur un thème qui n'existe plus.
Change de thème, sauvegarde ton projet, éteins puis redémarra Ardour. Si cela ne fonctionne pas, il te faudra nettoyer le dossier Ardour dans ~/.config/ardour6/.
Pour renommer le titre, édite ton premier post en cliquant sur l'icône de gauche en face du titre, sur la droite de la page.

sub26nico utilisateur non connecté France
Petit rectificatif, c'est quand Ardour ne trouve pas certaines palettes de couleur qu'il attribut des couleurs aléatoires à certains objets du thème graphique.
Voir ce post (ainsi que la réponse de x42/robin gareus plus bas) du forum d'Ardour.

zicstef utilisateur non connecté
Merci pour tes réponses Sub26nico je vais checker ça de suite :-)

Edit: cela fait des heures que je tente des trucs en suivant des fils sur plein de sites en relation avec Ardour et Arch mais ma situation n'évolue malheureusement pas pour le moment. SI quelqu'un a une suggestion à me faire, je suis client :-)
Je continue mes recherches et expérimentations!

zicstef utilisateur non connecté
Bon en fait, les variables d'environnements ne se créent pas :/ je ne trouve pas pourquoi. qu'en pensez vous?

olinuxx utilisateur non connecté France
note modération forum : @zicstef : j'ai modifié le message initial de ce fil. Merci de déposer les captures d'écran ici sur le site plutôt qu'en extérieur.


Loki Harfagr utilisateur non connecté
As-tu déjà testé cette manip ?

Avant de lancer Ardour :
cd ~/.config/ardour6
 mv themes themes.$(date +%s)


Puis, lance Ardour :

puisque tu utilises Arch, si tu as installé la version Ardour du site mère :
/usr/local/bin/Ardour6


ou si tu utilises une version préinstallée dans ta variante Arch :
/usr/bin/ardour6


zicstef utilisateur non connecté
Bonjour Loki Harfagr,

merci pour ton intervention.

Je n'ai pas de dossier themes dans le dossier ~/.config/ardour6. Je vais essayer de faire cette manip sur le dossier /usr/share/ardour6/themes. --> ne fonctionne pas

Ardour6.9.0 (compilé avec 6.9 et GCC version 11.1.0)
Ardour: [INFO]: Votre système est configuré pour limiter Ardour à 524288 fichiers ouverts
Ardour: [INFO]: Chargement du fichier de configuration-système /etc/ardour6/system_config
Ardour: [INFO]: Chargement du fichier de configuration-utilisateur /home/zikstef/.config/ardour6/config
Ardour: [INFO]: CPU vendor: GenuineIntel
Ardour: [INFO]: AVX-capable processor
Ardour: [INFO]: AVX with FMA capable processor
Ardour: [INFO]: CPU brand: Intel(R) Core(TM) i5-10210U CPU @ 1.60GHz
Ardour: [INFO]: Using AVX and FMA optimized routines
Ardour: [INFO]: Chargement du fichier de métadonnées de greffon /usr/share/ardour6/plugin_metadata/plugin_tags
Ardour: [INFO]: Chargement du fichier de style par défaut (/etc/ardour6/default_ui_config) pour l'interface graphique
Ardour: [INFO]: Chargement du fichier utilisateur de la configuration de l'interface graphique /home/zikstef/.config/ardour6/ui_config
Ardour: [INFO]: Chargement des patches MIDI 452 depuis /usr/share/ardour6/patchfiles
__Ardour: [WARNING]: Fichier couleur de dark non trouvé avec /home/zikstef/.config/ardour6/themes:/usr/share/ardour6/themes__
Couleur gtk_background introuvable
Couleur gtk_foreground introuvable
Couleur theme:contrasting clock introuvable
Ardour: [INFO]: Loading bindings from /etc/ardour6/ardour.keys
Chargement du fichier de configuration ui /etc/ardour6/clearlooks.rc
/etc/ardour6/clearlooks.rc:10: Invalid symbolic color 'bases'
/etc/ardour6/clearlooks.rc:10: error: invalid identifier 'bases', expected valid identifier
Couleur gtk_background introuvable
Couleur gtk_foreground introuvable
Couleur theme:contrasting clock introuvable
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
Found nothing along /home/zikstef/.config/ardour6/templates:/usr/share/ardour6/templates


Au vu du log de démarrage dans le terminal, je copie le dossier /usr/share/ardour6/themes dans ~/.config/ardour6 --> ne fonctionne pas

[zikstef@zikstef-nj5070cu ardour6]$ ardour6
Ardour6.9.0 (compilé avec 6.9 et GCC version 11.1.0)
Ardour: [INFO]: Votre système est configuré pour limiter Ardour à 524288 fichiers ouverts
Ardour: [INFO]: Chargement du fichier de configuration-système /etc/ardour6/system_config
Ardour: [INFO]: Chargement du fichier de configuration-utilisateur /home/zikstef/.config/ardour6/config
Ardour: [INFO]: CPU vendor: GenuineIntel
Ardour: [INFO]: AVX-capable processor
Ardour: [INFO]: AVX with FMA capable processor
Ardour: [INFO]: CPU brand: Intel(R) Core(TM) i5-10210U CPU @ 1.60GHz
Ardour: [INFO]: Using AVX and FMA optimized routines
Ardour: [INFO]: Chargement du fichier de métadonnées de greffon /usr/share/ardour6/plugin_metadata/plugin_tags
Ardour: [INFO]: Chargement du fichier de style par défaut (/etc/ardour6/default_ui_config) pour l'interface graphique
Ardour: [INFO]: Chargement du fichier utilisateur de la configuration de l'interface graphique /home/zikstef/.config/ardour6/ui_config
Ardour: [INFO]: Chargement des patches MIDI 452 depuis /usr/share/ardour6/patchfiles
__Ardour: [INFO]: Chargement du fichier de couleur /home/zikstef/.config/ardour6/themes/dark-ardour.colors__



Alors je renomme le dossier ~/.config/ardour6/themes en themes.$(date +%s) --> ne fonctionne pas. (terminal idem que le premier)

Précisions: le premier log, Ardour démarre en mode "Arlequin" le deuxième, alors que theme est présent dans mon home, le démarrage bloque sur la recherchede dark-ardour.colors, mon tout premier bug.

Bonne journée :-)

Loki Harfagr utilisateur non connecté
Ouh la !
Bon, il y a un truc foireux dans ton installation ardour, a minima dans le themes/ (de plus le fait d'avoir viré celui de /usr/share/ardour6 a forcément mis le zonk total :-D )
D'après tes logs il semble que tu utilises la version fournie par la distro et pas celle fournie sur le site Ardour, alors la première piste de déboguage sera de désinstaller ce ardour là puis de le réinstaller, en supposant puisque basé sur Manjaro utiliser pamac :

pamac remove ardour
mv ~/.config/ardour6 ~/.config/ardour6.$(date +%s)
pamac install ardour

ardour6 -d -n -a -N testdebog


c'est à dire :
- désinstaller la version ardour intégrée existante
- "nettoyer/mettre de côté" le dossier local de réglages persos plus ou moins en état de choc
- installer la version ardour intégrée (via le gestionnaire de paquets pamac)
- lancer ardour en mode tranquillos, ne pas charger les plugins, pas d'écran splash, ne pas appeler la maison, créer une session de test vide nommée testdebog (mais bon tu las nommes comme tu veux hein, c'est juste pour éviter d'ouvrir en sélectionnant une session existante qui peut-être contient des problèmes)

Et voir si ça fonctionne mieux ou pas, et si non comment vont les logs et ce qu'elles racontent de neuf, tout ça :-)

J'ai bon espoir mais si ça ne fonctionne toujours pas, il faudra de nouveau désinstaller ce ardour et installer le Ardour6 trouvable sur le site mère.
(à ce propos, as-tu vérifié si tu avais quelque-chose dans :

ls -l /opt/Ardour-6*


Et si c'est le cas refaire d'abord le test vu plus haut mais en utilisant donc la version mère (avec un "A" majuscule) :

Ardour6 -d -n -a -N testdebog


zicstef utilisateur non connecté
Bonsoir,

super piste clé en main que tu me donnes oO merci beaucoup :-)
Je ne vois ça que maintenant donc je me pencherais dessus demain au calme :-)
Bonne soirée

zicstef utilisateur non connecté
Bonsoir,

j'ai un avertissement lors de la commande de désinstallation: je ne risque pas de casser plus de choses?

zikstef@zikstef-nj5070cu ~]$ pamac remove ardour
Préparation...
Vérification des dépendances...
Avertissement : amsynth peut nécessiter lv2-host: for LV2 plugin
Avertissement : amsynth peut nécessiter vst-host: for VST plugin
Avertissement : carla peut nécessiter lv2-host: for the LV2 plugin
Avertissement : carla peut nécessiter vst-host: for the VST plugin
Avertissement : drumgizmo peut nécessiter lv2-host: for LV2 plugin
Avertissement : geonkick peut nécessiter lv2-host: for LV2 plugin
Avertissement : lsp-plugins peut nécessiter ladspa-host: for LADSPA plugins
Avertissement : lsp-plugins peut nécessiter lv2-host: for LV2 plugins
Avertissement : lsp-plugins peut nécessiter vst-host: for VST plugins
Avertissement : qmidiarp peut nécessiter lv2-host: for LV2 plugins
Avertissement : rubberband peut nécessiter ladspa-host: for LADSPA plugin
Avertissement : setbfree peut nécessiter lv2-host: for LV2 plugin
Avertissement : yoshimi peut nécessiter lv2-host: for LV2 plugin
Avertissement : zynaddsubfx peut nécessiter lv2-host: for using the LV2 plugin
Avertissement : zynaddsubfx peut nécessiter vst-host: for using the VST plugin

À désinstaller  (1):
  ardour  6.9-4    community

Taille totale libérée: 72,6 Mo

Appliquer la transaction ? [o/N] m


Merci pour vos explications.
Bonne soirée

Loki Harfagr utilisateur non connecté
Ce ne sont que des avertissements concernant des plugins qui "pourraient" avoir besoin de "bidules" qui "pourraient" être désinstallés suite à la désinstallation de ardour dans le cas "possible" où ils n'auraient été par ailleurs portés via d'autres paquets ou par installation volontaire incluse dans le paquettage de la variante de Arch qu'est la variante de Manjaro que tu utilises (TuxNMix) :-)

Donc, en résumé, ce sont des "avertissements au lecteur", pas des "erreurs" ou des "blocages", de plus, tu désinstalles ardour à seule fin de le réinstaller ensuite donc les trucs qui pourraient disparaître ici vont nécessairement revenir à moins que le système de paquettage identifie qu'en fait ben non il avait juste envoyé plus d'avertissements que nécessaire car les trucs disparus ne sont plus liés aux paquets actuellement installés/utilisés.
Et, de toute façon, même dans le cas où tu finirais par en avoir besoin, du fait que tu viens de noter que si tu utilise "Truc" ou "Machin" et que quelque-chose vient à manquer tu connais déjà le nom des suspects manquants probables :-)

Tu peux éventuellement vérifier ceci-cela avec par exemple :
pactree -r lv2-host
 pactree -r vst-host


qui devrait répondre que c'est fourni du fait de l'installation de ardour (et a priori quand "si et seulement si" impliquerait que si tu n'utilises plus ardour tu n'auras pas besoin des autres non plus), mais comme je ne suis pas "paqueteur" si tu veux des réponses plus poussées sur ce sujet tu pourras poser la question soit ici au paqueteur de LibraZic mais ce serait préférable (y compris pour la tranquilité d'esprit et de temps d'olinux ;) )plus sûr de poser la question au paqueteur de TuxNMix et éventuellement sur un forum Manjaro ou un forum Linux dédié aux paquettages divers.

Personnellement je poursuivrais la désinstallation de ardour suivie comme vu précédemment du reste de la petite proc de nettoyage/réinstall/test etc. puisqu'au pire tu perdras des paquets qui ne te servent pas mais qui reviendront dès le retour d'ardour et sino le système de paquettage te permettra de les installer de force si tu y tiens vraiment ;)

Forza et sursum corda !

CyrilRos utilisateur non connecté France
Ne pas oublier une chose pour les paquets sur base arch/manjaro/tuxnmix :
Recommandé = optionnel
Requis = obligatoire
Orphelin = ne sert a rien donc a enlever

donc aucun risque en cas de désinstallation réinstallation sans soucis avec ces paquets la il va juste recharger les greffons au premier démarrage

zicstef utilisateur non connecté
Bonsoir, je n'ai qu'une chose à dire: Snif T_T

[zikstef@zikstef-nj5070cu ~]$ ardour7
Ardour7.0.pre0.2100 (compilé avec 7.0-pre0-2100-g54b3a3bf6b et GCC version 11.1.0)
Ardour: [INFO]: Votre système est configuré pour limiter Ardour à 524288 fichiers ouverts
Ardour: [INFO]: Chargement du fichier de configuration-système /etc/ardour7/system_config
Ardour: [INFO]: CPU vendor: GenuineIntel
Ardour: [INFO]: AVX-capable processor
Ardour: [INFO]: AVX with FMA capable processor
Ardour: [INFO]: CPU brand: Intel(R) Core(TM) i5-10210U CPU @ 1.60GHz
Ardour: [INFO]: Using AVX and FMA optimized routines
Ardour: [INFO]: Set Clip Library directory to '/home/zikstef/.local/share/.local/share/sounds/clips'
Ardour: [INFO]: Chargement du fichier de métadonnées de greffon /usr/share/ardour7/plugin_metadata/plugin_tags
Ardour: [INFO]: Chargement du fichier de style par défaut (/etc/ardour7/default_ui_config) pour l'interface graphique
Ardour: [INFO]: Chargement des patches MIDI 452 depuis /usr/share/ardour7/patchfiles
Ardour: [INFO]: Chargement du fichier de couleur /usr/share/ardour7/themes/dark-ardour.colors


Je vais me coucher.

Merci encore pour votre aide

Amicalement,
Stéphane

Loki Harfagr utilisateur non connecté
Euh, je suis embêté car ne comprends pas ton message :-D
Tu veux dire que ça fonctionne ou pas ? C'est un snif de joie et gratitude envers le programme ou de désespoir envers le vertige du vide incompréhensible ?

Je vais supposer cette dernière hypothèse…
Note que je suis étonné de voir que tu as installé une version alpha, la version 7 de Ardour n'est pas encore à utiliser (sauf si tu es dev ou bêta-testeur donc je rejette préalablement cette option wink
) et est actuellement en état d'instabilité variable d'une compil à l'autre :-D

Si c'est la version qui a été installée en utilisant pamac je suis étonné et il s'agit paut-être d'une spécificité de ta distro puisque en vérifiant sur ma Manjaro si je vérifie les versions dispos j'obtiens ceci :

:~>: pamac search ardour
recbox-ardour-theme-git                                                                     [Installed] r14.51d4f3a-1                  
    Dark theme for Ardour with Matcha Dark Sea color schema.
ardour-git                                                                                              7.0.pre0.r2002.g866ba8b174-1  AUR 
    A multichannel hard disk recorder and digital audio workstation (git version)
ardour                                                                                      [Installed] 6.9-4                         community 
    Professional-grade digital audio workstation


et donc à moins que tu aies choisi ardour-git par erreur volontaire indépendante de ta volonté le mystère vient d'ailleurs :-)


Tu peux de toute façon déjà au moins faire l'essai de la version réelle du site mère à prendre ici :
community.ardour.org / download

Ce sera la version 6.9, si tu n'es pas payeur ou donateur ce sera la version de "démo" mais elle te permettra de vérifier si c'est côté Ardour que tu as des soucis ou si c'est lié à ton installation totale ou aux paquets TuxNMix en cours puisqu'entièrement fonctionnelle hormis une interruption au bout de 10 minutes.) elle s'installera dans la partion (ou dossier) /opt et sera indépendante de ton installation "distro", hormis qu'il te sera bien sûr recommandé, comme vu plus haut, de supprimer ou renommer ron dossier de config locale.
:~>: mv ~/.config/ardour6 ~/.config/ardour6.$(date +%s)


Si cette version 6.9 fonctionne tu sauras alors que tes problèmes sont liés au paquetage TuxNMix ou à ton installation locale et on pourra affiner un peu pour tenter de voir la suite :-)

zicstef utilisateur non connecté
Bonsoir

désolé c'est un peu long, mais les mails en provenance de Ardour sont long à venir. La 2ème hypothèse est la bonne, il s'agit d'un snif de désespoire. Et j'ai utilisé le git présent dans pamac pour pouvoir avancer.Il est maintenant désinstalé.

A demain pour la suite de mes expérimentations Ardouèsques ;)

zicstef utilisateur non connecté
Bonsoir à tous,

et bien voilà, la version démo fonctionne, démarrage ok, pas de couleurs bizarres!!!

Pourquoi????

Puis si cette version est une démo, le temps d'utilisation est limitée c'est ça? -> oui "Se tait périodiquement après 10 minutes". c'est marqué sur le site, dsl pour cette question inutile

Bon en tout cas, Super bien vu Loki, merci de faire avancer le schmilblik :-)

Bonne soirée à tous

Loki Harfagr utilisateur non connecté
Bon, c'est déjà ça que tu ais retouvé confiance et possède à présent une version de Ardour qui te permet au moins de faire quelques petites choses biggrin

D'autre-part, puisque tu as désinstallé la version pamac 7.0pre/git tu peux également tester la version pamac 6.9.4 de ta distro, si elle fonctionne c'est que c'était bien un problème lié à ton dossier /home/.config/ardour6 ou bien à une install foireuse d'un paquet incomplet/endommagé.

Ceci dit, tu peux également conserver la version "officielle" et si tu utilises abondamment Ardour éventuellement penser à investir dans son "achat", soit par abonnement au support de développement, soit par paiement "unitaire" (valide pour une version y compris ses maj en sous-versions) le paiement minimal commençant à si peu (environ zéro) que ce n'est pas nécessairement un frein très blocant même s'il est recommandable de mettre ce qu'on peut dans une mesure un peu plus élevée que ce si peuwink

zicstef utilisateur non connecté
Bonsoir à tous,

toutes mes excuses pour ce long silence,j'ai souhaiter installé apodio à coté de manjaro ma mint et mon w10. Ce faisant je n'ai pas compris que le système se copie (mais ne s'installe pas) sans prendre garde aux autres profils du dossier /home....
C'est ma boulette j'ai tout perdu c'est comme ça.

Pour le coup j'ai installé ubuntu studio (que je boude à cause des snap toussatoussa mais pour le coup tout roule.
Bon ben je n'ai plus qu'a retrousser mes manche pour essayer de recréer à peut près ce que j'ai perdu. Et plusse encore ^^

Mille merci pour l'aide que vous m'avez apporté. Navré de ne pas avoir poussé le dépannage jusqu'au bout ne serait-ce que pour l'aide que cela aurait pu apporter à d'autres. Bonne créations à tous.

Messieurs les modérateur, comment dois-je taguer le titre? Abandonné? Merci pour votre réponse

sub26nico utilisateur non connecté France
Citation :
Messieurs les modérateur, comment dois-je taguer le titre? Abandonné? Merci pour votre réponse

Contourné ou Abandonné semblent appropriés.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

calixtus06, 06:45, sam. 03 Dec 2022: bonjour et bienvenue à Young_FireStorm :-)
calixtus06, 07:16, mer. 30 Nov 2022: Bonjour et bienvenue à Ikben Zogroot :-)
olinuxx, 18:07, lun. 28 Nov 2022: Bonjour et bienvenue à NicolasJ cool
calixtus06, 07:55, sam. 26 Nov 2022: Bonjour et bienvenue à Bob33 :-)
calixtus06, 08:54, mar. 22 Nov 2022: Bonjour et bienvenue à gadeu :-)
olinuxx, 10:02, dim. 20 Nov 2022: Bonjour et bienvenue à Neandertahl cool
sub26nico, 13:39, mer. 16 Nov 2022: Merci Samuel ;-)
Samuel, 21:17, lun. 14 Nov 2022: [Lien] C'est de la balle et c'est enregistré avec librazik
olinuxx, 18:53, dim. 13 Nov 2022: @christorbec : le mégaphone ne sert pas à se faire dépanner. Ouvre un fil dans le forum.
christorbec, 15:22, dim. 13 Nov 2022: changer de soundfont dans ToneLib-jam ?
calixtus06, 06:59, dim. 13 Nov 2022: Bonjour et bienvenue à Djefux :-)
calixtus06, 11:59, sam. 12 Nov 2022: Bonjour et bienvenue à zardoz45 :-)