Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

2 - Les distributions et les noyaux

> Forums de discussion > 2 - Les distributions et les noyaux > [RÉSOLU] Ubuntu 6.10 + Delta 44
Dernier post

[RÉSOLU] Ubuntu 6.10 + Delta 44

fourbissime utilisateur non connecté
Bonjour à tous

J'ai acheté dernièrement une carte son M-audio delta 44, et je me galère à la faire fonctionner sous Ubuntu.

j'avais déjà des galères sous Gentoo il y a peu - j'étais obligé de relancer le script d'initialisation d'ALSA à la main après chaque démarrage pour que ca se configure bien.

Ma situation est semble t'il assez classique j'ai le chipset son de la carte mère (via82xx) et la carte son PCI. Je souhaite me débarrasser du chipset, que je n'utilise plus, et qui semble être la source de conflits. Sauf que le désactiver dans le BIOS ne fait rien car Le système GNU Linux passe outre ces paramètres.

J'ai essayé diverses bidouilles dans /etc/modprobes.d/alsa-base, sans succès.

j'ai essayé d'inverser mes cartes son dans /etc/asound.conf. Je suis parvenu à déclarer la Delta44 comme carte son par défaut, mais dans ce cas je n'ai pas plus de son. Quand je lance mplayer, j'obtiens le message suivant :

alsa-init: using device default
alsa-init: format s16le are not supported by hardware, trying default
alsa-init: unable to set format: Invalid argument
AO: [oss] 44100Hz 2ch s16le (2 bytes per sample)


Mais le pire dans tout ca, c'est que lorsque je boote sur le liveCD d'Ubuntu, la carte son est parfaitement détectée. un petit aplay -l me dit même que la carte PCI est la carte 0, et le chipset sonore la carte 1.

Si vous avez des idées pour résoudre ce problème, je suis tout ouï.

Salut,

Citation :
j'avais déjà des galères sous gentoo il y a peu - j'étais obligé de relancer le script d'initialisation d'ALSA à la main après chaque démarrage pour que ca se configure bien.

Tu avais posé la question par ici ?

Citation :
Mais le pire dans tout ca, c'est que lorsque je boote sur le liveCD d'Ubuntu, la carte son est parfaitement détectée. un petit "aplay -l" me dit même que la carte PCI est la carte 0, et le chipset sonore la carte 1.

Boote sur le Live CD, note bien toutes les infos de config (/etc/modprobes.d/alsa-base etc.) pour les reporter sur ta config !


Citation :
Si vous avez des idées pour résoudre ce problème, je suis tout ouï.

Par exemple : http://doc.ubuntu-fr.org/installation/son#plusieurs_cartes_son (solution 4)
Mais je pense qu'il faudrait d'abord repartir de la config initiale. Au fait, avant tes bidouilles, les 2 cartes marchaient bien ? (qjackctl te permet de choisir l'une ou l'autre pour les tester).

T.

fourbissime utilisateur non connecté
1. non, je n'ai pas posé la question sur le forum - en revanche je suis passé sur le chan IRC, mais on n'a pas réussi à trouver comment résoudre le problème. Et étant donné que j'avais pas mal d'autres problèmes de config avec gentoo, j'ai décidé d'arrêter le masochisme ...

2. j'ai essayé de faire ca hier - j'ai regardé le contenu des fichiers en question, mais je n'ai pas constaté de différences (ou alors j'ai mal vu). Vu que le liveCD fait certainement une détection de matériel préalablement au chargement complet du système, je me demande si la différence ne viens pas de là. auquel cas, je ne verrai pas de changements dans mes fichiers de config. Mais bon, je vais regarder à nouveau ce soir, on sait jamais ...

3. pour ce qui est de la "solution 4", j'ai essayé, sans que ca ne change quoi que ce soit. Mais sur le coup je me suis peut être mélangé les pinceaux avec les différentes solutions possibles.

4. avant que je fasse mes bidouilles, la carte son via82xx marchait certainement - j'avoue ne pas avoir fait l'effort de brancher un casque sur sa sortie pour voir. En revanche, la delta44 ne fonctionnait pas, elle.

Citation :
1. non, je n'ai pas posé la question sur le forum - en revanche je suis passé sur le chan IRC, mais on n'a pas réussi à trouver comment résoudre le problème.

Ok, j'y traine depuis trop peu de temps ! Pas gave en tous cas, l'essentiel c'est d'utiliser la distrib' sur laquelle tu te sens à l'aise !

Citation :
2. j'ai essayé de faire ca hier - j'ai regardé le contenu des fichiers en question, mais je n'ai pas constaté de différences (ou alors j'ai mal vu).

Compare aussi les sorties de commandes comme lsmod et cat /proc/interrupts.

Citation :
3. pour ce qui est de la "solution 4", j'ai essayé, sans que ca ne change quoi que ce soit. Mais sur le coup je me suis peut être mélangé les pinceaux avec les différentes solutions possibles.

Ma crainte, c'est que tu ais fait plus de mal qu'autre chose wink
Avais-tu fais une sauvegarde des fichiers que tu as bidouillés ? Te rappelles-tu précisément de ceux que tu as modifiés ? (on peut considérer que tu en a une version de sauvegarde sur le Live-CD)

T.

fourbissime utilisateur non connecté
J'ai fini par trouver la solution. pour que l'inversion des cartes son fonctionne, il fallait utiliser l'option numéro 3 du howto. ca marche du feu de dieu maintenant.

merci pour le coup de main

Citation :
pour que l'inversion des cartes son fonctionne, il fallait utiliser l'option numéro 3 du howto.

Argghh, j'ai répondu trop vite ... Oui, c'est effectivement ce que je voulais dire : C'est bien la solution 3 qui correspond à ce qui est expliqué sur la page Alsa_Multicartes ... mea culpa et désolé pour le temps perdu redface.

En tous cas, content que ça marche biggrin.

T.

Édition (admin olinuxx) : sujet fermé car résolu. Merci de remonter les informations pertinentes dans les pages Wiki adéquates.
Si besoin de réouvrir le sujet, vous pouvez vous adresser à un des admins wink
Pour des conseils sur le fonctionnement général du forum, vous pouvez voir cette page.


Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

calixtus06, 09:27, lun. 17 Jan 2022: Bonjour et bienvenue à bigveuch :-)
calixtus06, 18:05, sam. 15 Jan 2022: Bonjour et bienvenue à Roobuntu :-)
calixtus06, 16:48, mer. 12 Jan 2022: Bonjour et bienvenue à Aiz_user404, cedricm,DrClick :-)
olinuxx, 12:16, sam. 08 Jan 2022: Bonjour et bienvenue à lia cool
calixtus06, 16:29, jeu. 06 Jan 2022: Bonjour et bienvenue à Youpida :-)
r1, 21:09, mer. 05 Jan 2022: Toujours de bons mots contre tous les maux dans nos éditos !
allany, 19:35, mer. 05 Jan 2022: Est-ce pour l'an nouveau qu'il s'est fait si beau, l'édito ? [Lien]
calixtus06, 10:07, lun. 03 Jan 2022: Bienvenue à Laserpithium et Iblain :-)
calixtus06, 21:31, sam. 01 Jan 2022: Bonne année en mieux pour 2022 !
SuShY, 13:18, sam. 01 Jan 2022: Belle et heureuse année 2022 à tous !
olinuxx, 12:06, ven. 31 Dec 2021: Bonjour et bienvenue à Toufik cool
calixtus06, 15:26, mar. 28 Dec 2021: Bonjour et bienvenue à 70115MAO :-)